Beta - Ezlo Linux v.2.0.11.1490.7 hot fix for Ezlo Plus, Ezlo Secure, Vera Edge controllers

We’ve release a new hot fix for Ezlo Linux firmware v.2.0.11.1490.7 for Ezlo Plus and Ezlo Secure controllers and Vera Edge running Ezlo Linux fw with the following:

Fixes:

  • Fixed the issue with scenes triggered by scene controllers not working after the firmware upgrade.

Known issues:

  • Issue on devices that support Tamper where the broadcasts and notifications generated are opposite to the actual tamper state

  • Issue on Z-Wave devices with “electric_meter_amper” that is updated only when the hub is restarted. Ampere meter not changing value instantly once pairing a device supporting it (for example pairing a switch and adding some load to it - e.g. connect a bulb)

  • Issue on Vera Edge where after the first update from Vera FW to the new Linux FW the “Internet” LED is OFF

  • Issues with some Door Locks, as Danalock V3, that are not added with S2 encryption

  • Vera Edge Wifi connectifity issues:

    • Issues the Vera Edge controller not being able sometimes to connect to a Wifi network
    • Issus with disabling wifi interfaces not working on Vera Edge
    • Issues with hub.network.get method reporting AP interface as up, even if it is disabled
5 Likes

Can controllers running this firmware trigger a Scene based on House Mode changing? That is, if it changes from “Home” to “Away” can that be used to trigger a Scene? And if so, will the same trigger work if user selects “Home” mode when it’s already in “Home” mode?

I’m asking, because with Vera these were impossible due to the way House Mode changes were handled.

How does the update happen, and how can I check the version? There seems to be no where to initiate an upgrade in the app.

Unplug the Vera Edge’s ethernet cable for 15-20 seconds, then reinsert. Alternatively, you can power cycle by unplugging power cord for 15-20 seconds then reinsert. Both methods should cause controller to update itself to latest beta firmware.

I would like to upgrade to this firmware. “Unplug the Vera Edge’s ethernet cable for 15-20 seconds, then reinsert. Alternatively, you can power cycle by unplugging power cord for 15-20 seconds then reinsert.” —Did not work for me. I am having problems with scenes after migrating from a Vera Secure which died in action.

Sorry, I was referring to the EZLO Plus. I think it just gets pushed to these new controllers.

I migrated to an Ezlo Plus.

No but you can use EZ-HouseMode-SceneRunner until it does… Additional details here

1 Like

I tried both methods to force an update, unplugging power and unplugging ethernet, Neither worked. If I do the unplug ethernet it switches to wifi, is that an issue?

Can someone on your end please force an update, my controller is ezlo plus serial number 90000800

Hello @farrissf
Your EzloPlus 90000800 is currently running the latest Live version available which is 2.0.10.1452.10.
In case you wish to make part of our Beta list to receive the newest firmware builds available, let me know and I will contact the department in charge.
*Either if you decide to stick with the official version or join our Beta, the updates will be pushed directly from our server and you should only notice a change in the LED pattern of the controller (Pink blinking, followed by a solid green color, and when the unit is ready to be used the LED will turn solid blue again).

Looking forward to your confirmation.

1 Like

Your latest firmware release has been horrible so far. My scenes are not working. I received dozens and dozens of erroneous push notifications.

Hi @farrissf.
Can you write please the serial number of your unit?
Also, add please more details on what exactly is not working except push notifications.
Do you have a scene which stopped to work after update to the latest build?

Thanks.

I got my Ezlo Secure a few weeks ago and I am slowly moving my devices over from my Vera3. (I’m having some difficulty as there is no user manual that I can find) I looked all over the Android App to find the Ezlo firmware version but I could only find the Android App version, 7.70.2.1, located in the Customer Care Tab. Where do I look to find the Ezlo Hub’s Firmware Version and, additionally, how do I update the firmware? I suspect something changed because my three Aeotec remote Devices suddenly changed the Scene assignments for all four buttons! … kinda like Tim Allen in the Home Improvement show was busy at my house.

Hello @FxEpic,
If you have an Android phone running the latest version of the VeraMobile app, you should be able to see the firmware version of the unit under “Settings” → “Customer Care.” You should see something like this:


If you don’t see the firmware version there, please go to the WebUI at ezlogic.mios.com, log in to your account, and go to the “Settings” tap. You should see the firmware version there, like this:
image
Please note that Ezlo controllers upgrade to the latest firmware version automatically. If your controller is still not running the latest firmware, a simple power cycle must be enough to make it upgrade.

sorry for the delay in response, the serial # is 90000800, I continue to have problems. Last week the controller went crazy and sent out over 1000 alerts that my house was flooding. I had to unplug it to get it to stop. I tried to turn on remote access but it did not work.

We are sorry for the inconveniences this issue is causing you. This problem is currently being investigated by our engineers.

Thank you for your patience.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules