Associating Aeotec nano switches in Veraplus

Hi Guys, apologies I’m sure this has been addressed multiple times, I’m just tearing my hair out trying to get it to work and haven’t been find specific info for my scenario.

It is related to device association - all I am trying to do is have a second device switch when the primary device switches. I am running on a Veraplus and I have a Aeotec Nano switch that controls some LED lighting in one spot in the bathroom, I recently installed some additional lighting but due to the location I can’t get wiring back to the original nano switch, so I have installed a second nano switch to control the additional lighting.
The first nano switch is controlled by S1 input to a standard 2-way switch. I would like when this device turns on/off, to switch the second nano switch on/off. Nothing more fancy then that.
I have researched and read that device association is a much better way to go then just setting up scenes and would much rather this way to minimise lag/controller involvement etc. but I cannot seem to get it to work, I’m sure I’m missing something simple.

The steps I have followed:

  1. Device options of the controlling device (ie. original nano switch connected to switch)
  2. Add Group (I chose group 3)
  3. Set Device (added second device and specified ID in text box)
  4. Save

Hoping someone will be able to correct me or point me in the right direction. Do I need to set config. settings?
Thanks again.

Hi Guys, still havent been able to solve this one and have hit a roadblock. Hoping someone maybe able to still help. Thanks.

Why did you choose group 3? Is that what it said in the user manual for these Aeotec nano switches?

Maybe state the exact model number of these nano switches and add a link here to its user manual.

I’ve never used these but on my Fibaro modules it would be association group 2 that I’d use.

Hi cc-kid, thanks for replying, appreciated. I haven’t ever used associations before as I haven’t found the need and only just learning about them. The devices I am using are Aeotec Nano Switches (ZW116).

The user manual doesn’t have much info around associations but I also found a specs document online that is what pointed me to using group 3 as it is switched externally from a wall switch connected to S1. Although I have also tried using Group 1 & 2 aswell with no success and combination of switching through app and wall switch.

Group Associations: http://manuals-backend.z-wave.info/make.php?lang=en&sku=ZW139-C&cert=ZC10-17035523&type=mini

User manual: Aeotec Nano Switch User Guide : Aeotec Help Desk

The process to associate the devices in Vera seems pretty straight forward I’m just not sure if I am missing a step.

Well what you did sounds about right to me, as far as adding an association group and then selecting the device to be controlled by that group on the primary device etc. There isn’t more to it really as far as the setup goes in Vera.

The only bit you did I doubt was this “and specified ID in text box”. I leave those fields blank and do not enter the device ID number.

For example this is my Thermostat device that controls a Boiler Receiver relay device via Group Association.

Have you searched the forum for Aeotec Nano Association?

Yeh I did read some further posts that mentioned a bit more on the “ID in Text Box” and how that related to multi-channel configs so I have also tried without adding any text, unfortunately with no luck. As far as I can see I have done the same steps as you have above so wondering if there is something else that is preventing it from working.
When I save the device I notice the message continually shows ‘Purging Associations’ so thinking there is a bigger issue that I need to research.

Yes you are correct I forgot about Multi Channel devices and what those fields were for.

I’ve had issues in the past setting association on some Fibaro modules and it would get stuck on “Settings User Association” in the GUI.

It is possible to not use the GUI at all and instead try setting up the association via a LUA command.

Take a look here for how I did that:

For Group 3 is says:

Send Basic Set (configured by parameter 0x51 ) to the associated nodes in Group 3 when the external switch S1 is operated.Note: The Switch Mode of external switch S1 should be identified successfully, which means that the value of Configuration parameter 0x78 should be non-zero, then the Basic Set can be sent to the associated nodes in Group 3 via triggering the S1 switch.

Did you also set those parameter settings it mentions ?

I assume it’s these ones:

Thanks for all the help cw-kid, I still have had no luck and thinking I’ll just revert to creating a scene to control which I didnt want to do as its messy for such a small task.
I have tried all of your suggestions above, including adding the Lua code direct and still doesnt seem to like it. I also tried to associate some different devices as the ones I was trying originally are not right next to the controller so thought that may be playing a part if comms is intermittent, but couldnt associate other devices either so not sure what the problem could be…Bit over it to be honest.
Still getting the purging associations error even after I have deleted associations in GUI so not sure what’s happening there either. I’m stumped.

Update - I can get associations to work successfully on another device - following normal steps with using Group 2 works fine. Just need to work out what the issue is with the devices I actually want to associate, I now cant even get them to unpair/re add to system, thinking its a comms issue.

Only thing you can try is some how bringing the Vera controller closer to these Nano devices.

Either a long ethernet cable or connecting the hub to the WiFi maybe.

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules