Are push notifications broken?

I had a notification to alert me if my garage was open. It’s been working fine until very recently. Vera’s native notifications (offline, etc) continue to work so this seems to be a Reactor specific issue. Anyone else noticing this problem?


Are you using the MyQ plug-in for your garage door? Also could you share your logic summary, it shows what’s happening when your logic goes true so we can see where it’s failing.

No, I use GoControl/Linear GD00Z-4.

And when I run the notification in the activities section nothing happens. Normally this would send a push notification.

Okay, your logic summary would help here. Can you please share that

Here’s the activity. If I hit the little runner button nothing happens, in the past that would run the activity and send out a notification (regardless of whether the conditions were true) to the 3 users.

That is not the logic summary. If you head over to that reactor sensor navigate to tools then under “Troubleshooting and Support” click the logic summary link and then copy paste whatever is in the browser. Dont worry there is not sensitive info in the summary. It just shows the events and actions so I can exactly see whats happening.

1 Like

Ah, I see. Sorry about that. Here you are:

*************************************************** REACTOR LOGIC SUMMARY REPORT ***************************************************
   Version: 3.8-20262 config 20190 cdata 20045 ui 20190 pluginDevice 19 LuaXP not loaded
    System: Vera version 1.7.5186 (7.31) on Sercomm G450 ID 36 (Vera Plus); loadtime 1612815810/1612815820; systemReady 1612815825
       Env: Lua 5.1; JSON dkjson 1.2; UnsafeLua=nil/true
Local time: 2021-02-08T12:23:56-0800; DST=0; Los Angeles, California United States; formats %m/%d/%Y %H:%M:%S
House mode: plugin 1; system 1; tracking off
  Sun data: {}
  Geofence: not running
        RS: 1612305646,1612305660,1612310028,1612417572,1612417709,1612506191,1612506297,1612809665,1612810029,1612815820
        NS: 1610409720:D,1610410440:U,1610723160:D,1610723460:U,1611282180:D,1611282600:U,1611283045:D,1611286980:U,1611946080:D,1611948060:U
Garage Door Notice (#20) DISABLED
    Version 19082.24 02/08/21 12:23:19
    Message/status: Disabled
    Condition group "Reactor Sensor 1" (AND)  false as of n/a <root>
      &-?-service Garage Door (18) urn:upnp-org:serviceId:SwitchPower1/Status = 1 for ge 900s [nil at n/a; F/F as of n/a/n/a] <cond0>
      &-?-trange bet ,,,22,0,,,,0,45 [nil at n/a; F/F as of n/a/n/a] <condo1kmqxu>
      &-?-interval 00h:15m relative to ,-,- [nil at n/a; F/F as of n/a/n/a] <condo1kn1kd>
    Activity root.true
        Notify method nil nid 1: sid 8 users 1741812 message "The garage is open."; index="1"
        2021-02-08 12:23:40: Reactor startup (Luup reload)
        2021-02-08 12:23:40: Aborting; disabled
        ZWave (1) urn:schemas-micasaverde-com:device:ZWaveNetwork:1 (19/0); parent 0; plugin -; mfg  model ; dev D_ZWaveNetwork.xml impl 
        Garage Door (18) urn:schemas-upnp-org:device:BinaryLight:1 (32/0); parent 1; plugin -; mfg Linear model GD00Z-5; dev D_BinaryLight1.xml impl 
    Special Configuration
        UseReactorScenes = 1
        Retrigger = 0
        FailOnTrouble = 0
        ContinuousTimer = 0

Okay so on initial inspection a LUUP reload has occurred since the last time the group went true so there is not info there. Are you able to capture the logic summary next time the group goes true? Also did you purposely have the reactor sensor disabled?

I think the luup reload occurred because I changed the number of users that would get the message before re-saving the activity.

I’m not sure what you mean by “Also did you purposely have the reactor sensor disabled?”

But give the above, shouldn’t pressing the “runner” icon run the activity regardless of the status of the garage? That was how it worked in the past and was helpful because I could test activities w/o the conditions being true.

Your logic summary shows that your reactor sensor is disabled. It should be enabled like this

You can also manually run the activity and capture the logic summary as well. I just checked my own push notifs and they worked for me. Lets see if anything comes up in the logic summary

1 Like

Ugh, it was the disabled status that did it. I’m not sure how that changed, must have been clicking too fast. Thank you for your help!

1 Like

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules