AltUI use case - offload processing from Vera

So, as the system grows, i’d like to distribute the work to a more powerfull unit.
The plan i’ve started with is to have a “Master” running openLuup on a linux system (Chromebox with Debian), and to run all plugins and logging on/from that.
This enables me to connect more Vera’s and even EzLo units, and have Reactor work with all of it.
But some things i’d like to retain:

  • Remote Login
  • Geofencing
  • Push notifications

I started with the thought that there was a possibility for remote access to Openluup, but i guess thats not the case?
The User setup also seems dependent on Vera hardware, is there a way to set this up so I can have a registered lisence in my name without Vera base (and that its not overwritten when I connect vera’s)?

All input is appreciated, especially from the folks who mentioned that they’ve gone to using the Vera only as a z-wave/zigbee hub. I’d like to know how they solved retaining the functions mentioned above…

1, you can use vpn to connect to openluup or forward a port.
2, i do not use geo fencing, i use Automate on all house mobile phones to register when a phone connects to home wifi.
3, i also use the cloud message function of Automate to send notifications to any android device i wish, using reactor http notifications.

1 Like
  1. vpn. I wrote a bot to control it without exposing the access to the external world
  2. I’m using ifft for this. It works 100% reliable.
  3. telegram bot. Very easy to integrate in lua. I can send the code, it should already be on the forum.
1 Like


You can use system like dataplicity for remote access to a Debian system. Instructions on how I did it is included here GitHub - reneboer/openLuup-ImperiHome: A simple LUA CGI file to make openLuup talk ImperiHome ISS

Cheers Rene

Yes, if you send me a screen shot of the AltUI footer showing that you have a licence I can supply a key for openLuup which enables AltUI to run on an un-bridged openLuup system.

I’m an Apple user myself, and use Prowl for push notifications to my iPhone. But there must beAndroid equivalents.

Ok, but that won’t give me the other geofencing options, like a wide area that initiates stuff when we both are far away, or at another geofence location?

Haven’t looked at IFTT yet, i’ll check that, VPN and telegam bot out. Thanks!

Ok, haven’t registered yet, but i’ll do that and get back to you. Thanks. :slight_smile:

Completely forgot about that one, also interesting as i have some imperihome panels!

Just using wifi no, but Automate has geo location etc to. You will obviously choose a solution that works for you.

Cool! I will give it a closer look. Thanks

Its running fairly OK now, but I still have no icons (did the GetFiles thing), and on luup Reload, i get the “Os Command execution request failed. (returned error)”
in the log it days that it exited with code: 42.

Is it a permissions issue?

I also tested setting up a reactor to replace one that was slow running on Vera. Its even slower now, 3 secons response time. Any tips to how i find out where the delay is?

Exit code 42 is openLuup’s standard status for a Luup reload command. That’s how it knows to reload and not to exit:

# reload loop for openLuup
# @akbooer, Aug 2015
# you may need to change ‘lua’ to ‘lua5.1’ depending on your install

lua5.1 openLuup/init.lua $1

while [ $? -eq 42 ]
   lua5.1 openLuup/init.lua

Have you tried enabling async mode for the VeraBridge plugin?

Variable AsyncPoll should be set to true.

That was it, Speed is much better. :slight_smile:

If 42 is Ok, what’s the error on executin OS command? Can’t find it in the logs…

It’s probably the standard one from AltUI as it tries to clean up a folder in /www/.

Ok, so “just ignore it”? fine by me.

Regarding Icons, they don’t download from the vera for some reason?

2020-09-15 17:04:30.818   openLuup.server:: GET /cmh/skins/default/img/devices/device_states/dimmable_light_off.png HTTP/1.1 tcp{client}: 0x55eca8d90cb8
2020-09-15 17:04:30.819   openLuup.server:: request completed (0 bytes, 0 chunks, 0 ms) tcp{client}: 0x55eca8d90cb8
  • What version of openLuup are you running?
  • What type of icons are they (file extension…)
  • Can you put a symbolic link from the relative reference location to the icons/ folder?

Openluup 20.5.22
Its the standard icons, bridge is fetching them from the vera… The location is correct on the remote vera.
Don’t know how to make a symbolic link?