[ALTUI] Group titles missing from status page

Hi rigpapa, since update to 3.9 there seems to be an issue with group titles in status page.

and the tools page is missing device spy and other elements


edit- (this seems to be cause by google cloud messaging repeating messages so not reactor issue - i am also having issues with an expression varible, i update this variable via a luup request but it seem to be resetting itself. This has been working for a year without issue.)

I can not post a logic report as there is no setting in tool section.

Hmm. No issues on Tools for me. Let’s make sure you’re on the latest stable branch release, since 3.9 is not yet released and I’m not quite sure what you mean by “since update to 3.9”… go to the Plugins page and type “stable” into the version field for Reactor and hit the update icon button. And hard-refresh your browser.

And let me know what theme you are using there, because that may related to the title issue (and I think I’ve addressed this once before, also leading me to believe you may not be on the latest).

I updated to stable 3 days ago, i’m on 3.9develop-20349. The theme is Darkly, but same if i reset themes.
But to be sure i just updated again , no change. Browser is firefox on android.

What do the group titles look like if you go back to the default theme?

The same

OK. This isn’t happening to me on the Android Firefox (version posted earlier) I have, nor on desktop. I see other issues related to layout on Firefox with the Boostrap4 that ALTUI is using, and I can address those, but the missing titles and half-painted Tools tab is not (yet) reproducible. I would recommend closing the app (hard closing), and restarting it. If that doesn’t work, restart the entire device. If still no, flush the browser cache and restart it.

I’m working on some field placement tweaks for Firefox.

Ok have -
closed app and restarted, no change.
force closed app cleared cache, no change.
restarted device and cleared cache and site data, no change.
and various other combinations, no change.

Will have to live with it if there is no fix, or change browsers, shame as i like the layout and functions/addons of the firefox android app.

I am on version 83.1.0 on my Samsung Galaxy Tab S2, and the most current release is 84.0 (two days ago). You reported your version as 68, which is past EOL. Are you able to upgrade?

Yes i tried the latest version about a month ago and it sucked, so i reverted back to 68, All addons and functionality was gone, forward and back buttons gone, no exprot to pdf, it was a nightmare. Has it improved any?

edit/ tried samsung browser which is chromium base latest version(13.0.2.9) on my samsung phone. And am getting the same issue with status title and tools. This may be due to Altui update and new bootstraps version.

OK. The problem with @amg0 randomly upgrading jQuery and Bootstrap is that he can catch up to any necessary changes for his own code before release, but all dependent plugins under ALTUI will also then have to catch up. This is especially complicated because the version of Bootstrap is so divergent from that on the legacy Vera platform, so it’s already difficult enough trying to get things to look decent without having to maintain two entirely separate code bases.

@amg0, since this is an issue, I’d love to have the option of previews, so I can verify functionality before you start having people install/upgrade. Otherwise, it’s a game of perpetual catch-up during brokenness, and worse, someday it might be at the step where the two systems are so divergent, it doesn’t make sense to try to keep a single code base. That would be a tough day, because more than 50% of the code in Reactor is the UI, and since it has to run across many versions of multiple browsers, it is the most difficult to test and maintain. Can I ask that there be a separate development channel/track and announcements for that? You may already have separate branches on Github and I’m just not aware of them (I do this for Reactor and most of my other plugins, as you may know).

@ElCid for you I would recommend going back to an earlier version of ALTUI. I don’t have the time right now to chase down and completely retest on every browser for this new version. I’ll need to add that to my to-do list.

Ok will do, @amg0 what do i need to type into ALTUI plugin page to revert to previous version?

Hi @rigpapa,

It looks like some of the (security?) changes are affecting the showGroupStatus function. Updating the text in grpel now seems to wipe its previous contents rather then to replace for the specified element.

Update: I think I found it. There is a change on the ‘short’ element notation (<div />). So changing the grpel variable to this seems to fix it.

		var grpel = $( '\
<div class="reactorgroup"> \
  <div class="grouptitle"><button class="btn condbtn"></button><span class="re-title">??</span> <span class="currentvalue"></span></div> \
  <div class="grpbody"> \
	<div class="grpcond"></div> \
  </div> \
</div>' );

However, I think there are more places giving this issue. The Activity Save button and Tools tab for example.

Cheers Rene

Yes, I’m aware of it; I’ve already got everything fixed, but I have to put it through my test suite and all of my browsers, and given my current schedule, that’s going to take some time. I’m going to have to start enforcing system requirements, as system changes like this are disruptive.

1 Like

OK. Version stamp 20354 in the Github stable branch. Not ready to release it to the AltAppStore yet; much left to do, but I need to get some other work done. The CHANGLOG and documentation have been updated with new system requirements.

To install, go to the “Plugins” page, find the Reactor row, type “stable” in the version field and then hit the upgrade button. After the files are installed, you’ll need a Luup reload and a hard refresh. Footers should say 20354.1000 for version.

OK update ALTUI again and installed 20354, All seems to be displaying again.

Thank you rigpapa, i know this must be a pain for you.

Nah, just bad timing for such an involved task. I homeschool my two teenage boys and they had exams this week as we rushed to finish for the holiday break, and then, of course, lots of development activities going on both in and outside this community. It usually takes me about two weeks to really test out, and rushing testing is always a great way to come a gutser. We’ll see…

I did address some issues that I think could improve Firefox Android… what’s that looking like for you now?

I admire that you home school.

The Firefox layout is much improved.

Ayup, that’s about as good as I was hoping for.

hi, just click the icon with the arrows in circle, it will revert back to the lates mios App Store released version which I keep a few version behind the GitHub one for that purpose.

thx @rigpapa , apologize for the inconvenience, but am also doing this when I have time & weekends so it is hard to manage this as a fully professional way. the App Store version is always a few version back so people can revert to it. When bootstrap reaches 5.0 official availability, we will most likely have similar things happening but I ll see if I can find a way to help transitions without getting into a fully professional code workflow which I cannot master …

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules