ALTUI: Failing in retrieving the device icons


Installed openluup+altui through the docker image by @vwout.
Docker container runs on my laptop while I am experimenting with altui/openluup.
Device icons are copied from Vera into cmh-ludl/icons.

From what I read and see in output on browser I need a symbolic link towards the cmh-ludl/icons folder. The docker image does not have this so I ran “ln -s /etc/cmh-ludl/icons /cmh/skins/default/img/devices/device_states”. Tried as well with physical folder where I explicitly copied the icons into.

But when showing the AltUI dashboard the http get of the icons fails and so a generic zwave icon is displayed. The only icons shown appear to point to an external resource on the internet.

Yes, did a hard refresh and even explicit delete of cache in webbrowser. The http get error from my browser control confi

Which version of openLuup? The Docker image is, no doubt, fairly old. Have you updated to the latest?

Running with these; believe these are most recent.
OpenLuup v20.5.22
AltUI v2.50.2549

Had to update AltUI but not OpenLuup.
Docker image was last build in July so quite recent.
Using the vwout/openluup Debian image; not the Alpine.

(checked as well permissions for the folders; r-x for everyone)


Latest openLuup (development branch) is actually v20.10.2 (yesterday) but I don’t think that this is your problem.

I know nothing about Docker (but perhaps that isn’t a problem either.)

Are you able to access the icons directly from a web browser (through openLuup) ?


Tried with 2 different png icons:
localhost:3480/icons/name.png gives “The image … cannot be displayed because it contains errors”.

If I try without explicit icon, then I get the same erorr as I can see from browser console and openluup.servlet log: “file not found:icons/index.html”. Correct that the icons directory not contains an index.html. Whom should produce this one?

file not found:icons/index.html
file not found:icons/button_home_selected.png


Ah, interesting.

The missing index.html is not an issue – it’s simply that openLuup will look for that in the absence of a specific file. It’s not what you want.

“The image … cannot be displayed because it contains errors”, is much more interesting, and points to some sort of error in the download process. Remind me again:

  • did the initial openLuup install script copy icons correctly, or not?
  • if not, how did you get them there?
  • where, exactly, is ‘there’ – a physical icons/ directory or a symbolic link?

Until we get this simple access to the icons correct, there is no hope that openLuup will display them properly on the Devices page.

Hi swiddy, welcome :slight_smile:

Could you please provide some additional information? Akbooer is the author of openLuup so together we should be able to help you.
In the docker image, the directory /etc/cmh-ludl/icons does exist. This directory has read permissions for everyone and only contains two icons (AltUI logos).

What do you mean here? First of all, of copying anything, copy it to /etc/cmh-ludl/icons. Do you mean that you manually copy files from Vera, or do you expect an automatic process to do this?

Why do you do this? In the docker container, /etc/cmh-ludl/icons exists. The directory /cmh/skins/default/img/devices/device_states on the other hand does not. This directory does exist on a Vera device, as /mios/www/cmh/skins/default/img/devices/device_states. The files in this directory are not available in the docker image, since these belong to the Vera product.

The docker file only contains what openLuup and AltUI contain: the images of openLuup and AltUI themselves. AltUI does not contain device files like xml, json and icon files for all the device types that Vera supports. That is why any device shows with a generic ZWave icon.

The easiest way to get the Vera files is to link a Vera device that you own to openLuup. You can do this via the VeraBridge plugin, see page 7.

I’ve been experiencing similar issues (fresh openLuup install on RPi3)
Understood, you did confirm that the files were contained in the /icon folders.

However, double check (I used WinSCP) that the actual .png files are not “zero” byte files.



I used openluup’s method to get the verafiles. This works for json&xml but not (anymore?) for the icons. Result is iconfiles of size 0.

I know now this has nothing to do with the docker image as I found others having the same problem who did not use docker.

Yes the files on opelnluup are zero byte files. Iconfiles on vera are correct.

Vera secure 1.7.5187 (7.31)

Well that’s the first clue.

In my case, I decided to install AltUI/openLuup on a fresh MicroSD (for the heck of it, and the linux learning practice)

I happened to have a (backup) folder on my laptop containing all of my icons. After installing a fresh openLuup on a fresh microSD, using WinSCP, I drug them over & overwrote the openLuup files in cmh-ludl/icons.

Later on I noticed AltUI/openLuup was showing some missing icons (again). I checked my cmh-ludl/icons folder, and I again had some zero length icon files. (I SWORE that I copied all the files once)

I’ll have to investigate further, but I’m guessing that my folder structure / permissions on my new install isn’t quite right. Although I started with Dos 3.1, I’m very weak on linux.

I’ll be doing another fresh install soon, and I’ll monitor the process more closely.

Best of Luck