AltUI doesnt update

I get the pop-up for updating on every logon, but it doesnt seem to update.

Beagleboard xM running debian 9.3


2018-07-16 08:17:21.050 openLuup.server:: request completed (4447 bytes, 1 chunks, 18628 ms) tcp{client}: 0x21dd010 2018-07-16 08:17:21.051 luup_log:4: AltAppStore : <job> phase 2018-07-16 08:17:21.052 luup_log:4: AltAppStore : Total size 0 2018-07-16 08:17:21.054 luup.variable_set:: 4.urn:upnp-org:serviceId:altui1.DisplayLine2 was: Alternate UI now: Alternate UI 100% #hooks:0 2018-07-16 08:17:21.055 luup_log:4: AltAppStore : updating icons in icons/ ... 2018-07-16 08:17:21.056 luup_log:4: AltAppStore : updating device files in ./ ... 2018-07-16 08:17:21.057 luup_log:4: AltAppStore : ... 0 icon files 2018-07-16 08:17:21.058 luup_log:4: AltAppStore : ... 0 device files 2018-07-16 08:17:21.059 luup_log:4: AltAppStore : Alternate UI update completed 2018-07-16 08:17:21.060 openLuup.luup:: device 4 'Alternate App Store' requesting reload 2018-07-16 08:17:21.061 luup.reload:: saving user_data 2018-07-16 08:17:21.143 openLuup.luup:: exiting with code 42 - after 0.0 hours

That last line stops the tail, and that happens every now and then…But it happens every time i try to update, at the same point.

Current Version:
AltUI v2.26.2405

is there any way to update from the command line?

Will updating AltUI also update the OpenLuup framework?

What version of openLuup are you running?
Can I see the latest openLuup startup log (not the regular log)?

not sure about openluup version, but it was installed as per the user guide as the same time as altUI? How do i confirm which version it is?

New to this, there is the log you want?

@Forzaalfa: try these:



@ak I have the same problem. It does update sometimes but I’m unsure under what circumstances. Have L_openLuup VERSION : 2018.07.15 and AltUI version: v2.29.2416

...a newer version #2418 of ALTUI is available...

Select Yes. openLuup restarts. Look into start up log and see nothing special (I don’t want to post the whole log):

2018-07-17 09:44:11.367 openLuup.userdata:: ...scene loading completed 2018-07-17 09:44:11.367 openLuup.userdata:: loading installed plugin info... 2018-07-17 09:44:11.368 openLuup.userdata:: [openLuup] openLuup (18.7.15) 2018-07-17 09:44:11.368 openLuup.userdata:: [8246] Alternate UI (2.29.) 2018-07-17 09:44:11.368 openLuup.userdata:: [AltAppStore] Alternate App Store (18.2.27) 2018-07-17 09:44:11.368 openLuup.userdata:: [VeraBridge] VeraBridge (18.7.4) 2018-07-17 09:44:11.368 openLuup.userdata:: [Z-Way] Z-Way (not.installed) 2018-07-17 09:44:11.368 openLuup.userdata:: [Arduino] MySensors (1.4.) 2018-07-17 09:44:11.368 openLuup.userdata:: [8211] DataYours (16.10.4) 2018-07-17 09:44:11.368 openLuup.userdata:: [9066] ALTHue (1.3.)

I do get this but that looks like some other issue - not sure why. The files are in fact not there but the AltHue plugin seems to dim OK.

2018-07-17 09:54:42.587 luup.create_device:: [155] D_ALTHUE.xml / I_ALTHUE.xml / D_ALTHUE_UI7.json (urn:schemas-upnp-org:device:althue:1) 2018-07-17 09:54:42.588 luup.create_device:: [156] D_DimmableALTHue1.xml / / () 2018-07-17 09:54:42.588 openLuup.chdev:: ERROR: unable to read XML file D_DimmableALTHue1.xml 2018-07-17 09:54:42.589 luup.create_device:: [157] D_DimmableRGBALTHue1.xml / / () 2018-07-17 09:54:42.589 openLuup.chdev:: ERROR: unable to read XML file D_DimmableRGBALTHue1.xml 2018-07-17 09:54:42.590 luup.create_device:: [158] D_DimmableRGBALTHue1.xml / / () 2018-07-17 09:54:42.590 openLuup.chdev:: ERROR: unable to read XML file D_DimmableRGBALTHue1.xml 2018-07-17 09:54:42.590 luup.create_device:: [159] D_DimmableALTHue1.xml / / () 2018-07-17 09:54:42.590 openLuup.chdev:: ERROR: unable to read XML file D_DimmableALTHue1.xml


Samething here too…

Latest DEV version for openLuup and Altui 2.00.2188
and can’t upgrade to latest version of Altui!

Saw nothing in the log.

Hmm I have been manually upgrading ALTUI from the plugin page rather than answering the prompt with a yes. It’s been going on for a while even though I have been running on my own fork of openLuup dated back to mid May.

AK - might just add, this has been going on for at least a couple of months.

I did a manual update as per @rafale77: AltUI–>More–>Plugins–> update button. That worked. Still nothing much of interest in the log.

I had the same issue. After SSH into the machine, I saw a complete set of AltUI files in both the cmh-ludl folder and the openLuup folder. I removed the redundant files from cmh-ludl and all worked fine afterwards. However, I’m not sure if I targeted the correct folder…

Now you tell me!

There should be nothing but openLuup distribution files in the openLuup folder of cmh-ludl/.

Edit: doesn’t help anyone, but it works for me… (Edit: I misunderstood, this is working from the plugins page…)

2018-07-17 07:30:58.623   luup_log:4: AltAppStore : (32 of 32)  31571 J_ALTUI_b_lua_compressed.js
2018-07-17 07:30:58.623   luup.variable_set:: 4.urn:upnp-org:serviceId:altui1.DisplayLine2 was: Alternate UI 97% now: Alternate UI 100% #hooks:0
2018-07-17 07:31:02.212   luup_log:4: AltAppStore : <job> phase
2018-07-17 07:31:02.212   luup_log:4: AltAppStore : Total size 2579.806 (kB)
2018-07-17 07:31:02.212   luup.variable_set:: 4.urn:upnp-org:serviceId:altui1.DisplayLine2 was: Alternate UI 100% now: Alternate UI 100% #hooks:0
2018-07-17 07:31:02.212   luup_log:4: AltAppStore : updating icons in icons/ ...
2018-07-17 07:31:02.212   luup_log:4: AltAppStore : updating device files in ./ ...
2018-07-17 07:31:02.293   luup_log:4: AltAppStore : ... 2 icon files
2018-07-17 07:31:02.293   luup_log:4: AltAppStore : ... 30 device files
2018-07-17 07:31:02.293   luup_log:4: AltAppStore : Alternate UI update completed
2018-07-17 07:31:02.294   openLuup.luup:: device 4 '   Alternate App Store' requesting reload
2018-07-17 07:31:02.294   luup.reload:: saving user_data
2018-07-17 07:31:02.501   openLuup.luup:: exiting with code 42 - after 38.8 hours

O, I haven’t told you either, bigger issues with other(Vera) upgrades ::). Same issue. When clicking upgrade from the prompt, it downloads, but the prompt to upgrade keeps coming back. In the plugin list you do see the new version number. If you click update from the plugin list it all works fine. Running openLuup on PI.

Cheers Rene


This is the files I have under /opt/cmh-ludl/openLuup

D_ALTUI.json I_ALTUI.xml J_ALTUI_iphone.js J_ALTUI_loc_fr.js J_ALTUI_multibox.js J_ALTUI_upnp.js L_ALTUI.lua L_ALTUIjson.lua D_ALTUI.xml J_ALTUI.js J_ALTUI_jquery.ui.touch-punch.min.js J_ALTUI_loc_it.js J_ALTUI_plugins.js J_ALTUI_utils.js L_ALTUI_LuaRunHandler.lua S_ALTUI.xml D_ALTUI_UI7.json J_ALTUI_api.js J_ALTUI_loc_es.js J_ALTUI_loc_nl.js J_ALTUI_uimgr.js J_ALTUI_verabox.js L_ALTUI_compress.lua

And this is under /opt/cmh-ludl/

D_ALTUI.json J_ALTUI_api.js J_ALTUI_b_javascript_compressed.js J_ALTUI_loc_it.js J_ALTUI_utils.js L_ALTUI_compress.lua D_ALTUI.xml J_ALTUI_b_blockly_compressed.js J_ALTUI_b_lua_compressed.js J_ALTUI_loc_nl.js J_ALTUI_verabox.js L_ALTUIjson.lua D_ALTUI_UI7.json J_ALTUI_b_blocks_compressed.js J_ALTUI_iphone.js J_ALTUI_multibox.js J_DeusExMachinaII1_ALTUI.js S_ALTUI.xml I_ALTUI.xml J_ALTUI_b_en.js J_ALTUI_jquery.ui.touch-punch.min.js J_ALTUI_plugins.js J_PresenceSensor_ALTUI.js J_ALTUI.js J_ALTUI_b_fr.js J_ALTUI_loc_es.js J_ALTUI_uimgr.js L_ALTUI.lua J_ALTUI_RulesEngine1.js J_ALTUI_b_it.js J_ALTUI_loc_fr.js J_ALTUI_upnp.js L_ALTUI_LuaRunHandler.lua

Somehow, that’s very wrong. They should not be in openLuup/.

Make sure the latest are in cmh-ludl/ and let’s keep an eye on this.

I will do some follow-up work. Sorry for the inconvenience.

There is something very odd about the latest 2418 tagged release in GitHub/AltUI. The previous one, 2405 loads just fine.

When AltUI asks for a release, it specifies a particular tagged release (using, for historic reasons, the parameter &TracRev=…) When downloading from the Plugins page we usually specify ‘master’ or ‘development’, but you can specify a particular tag too:

[ul][li]Doing this with 2405 in the Update box, downgraded me to that release just fine.[/li]
[li]A blank Update box (effectively, just picking from the master GitHub branch) successfully upgraded to 2418[/li]
[li]Specify 2418, and the update fails[/li][/ul]

@amg0… HELP!!

I tried to update to 2405 in the update box… and still having 2188 in the footer!

You did do the mandatory manual update a while ago?,61525.0.html

Ohh yeah.
So I just update the files (as my openssl is already OK.

After that, I just need to update the ALTUI ?

By the way, I’m always using your DEV branch for openLuup

Yup. Latest dev branch should be good.

Ok, so i tried rafale’s approach, and it updated, so i’m on 2418 now. seems to be working good. thanks. :slight_smile:

I’m running Openluup 5.1 on a RPI 3b Raspbian GNU/Linux 8 (jessie) I used to be quite conversant with this stuff but a recent powercut corrupted my sd card. The latest backup I had was from 2018. This sucessfully runs Altui but I cant update it. Even from the plugins page. I faintly remember having to do manual upgrade but all the links to the previous forum are dead ends
How to I

  1. update openluup
  2. update Altui

my openluup start up log

2024-02-03 15:06:04.271 openLuup.init:: version 2018.02.25 @akbooer
2024-02-03 15:06:04.461 openLuup.scheduler:: version 2018.01.30 @akbooer
2024-02-03 15:06:04.514 openLuup.wsapi:: version 2017.01.12 @akbooer
2024-02-03 15:06:04.514 openLuup.servlet:: version 2018.02.19 @akbooer
2024-02-03 15:06:04.515 openLuup.server:: version 2018.02.26 @akbooer
current version AltUI v2.29.2418, © 2018 amg0,88800000
please help