AltAppStore Error: No implementation

First of all thank you all for an excellent set of plugins for Openluup, AltUI and Store!
I installed OpenLuup earlier this spring/winter and have moved more and more of my automations from my old Vera Lite and Vera Plus.
I run OpenLuup on an old i3 PC with Ubuntu from the home directory and it is really working well.
I also manually set up the equally excellent Z-way plugin with a Razberry on an old Pi 3B running Z-way that I had laying around. Finally I could shift some devices that did not work properly on my Veras (Fibaro RGBW and Aeon Multisensor 6). Everything then controlled manually from Homewave when needed. All in all a very good setup!

Frequent reader on the forum, I usually manage to get by but this time I am stuck. The problem that I noticed a few days ago is that I cannot install any apps from AltAppStore. I cannot update my plugins under the plugin tab either.
When I try to install an app I get the dialogue “ERROR: No implementation”
When I try to update I get the “Are you sure” question and then not much more happens.

I am not so good reading the log file but I can see “No implementation” in it so something is obviously missing.

The AltAppStore did work earlier, I have e.g. installed Reacor and updated it once some week ago.
When AltAppStore stopped working for some reason I have tried to get it to work, and feel that I may very well have bodged it up somehow.

Any ideas someone? A clean reinstall of AltAppStore somehow seems as a possible first step to restore all those files, but I do not know how to do that in OpenLuup to be honest.


2020-04-06 09:50:32.718   openLuup.http:: GET /data_request?id=action&serviceId=urn:micasaverde-com:serviceId:HomeAutomationGateway1&action=CreatePlugin&PluginNum=openLuup&Version=development HTTP/1.1 tcp{client}: 0x5619fe18a538
2020-04-06 09:50:32.718   luup.call_action:: 0.urn:micasaverde-com:serviceId:HomeAutomationGateway1.CreatePlugin 
2020-04-06 09:50:32.718   luup.call_action:: 4.urn:upnp-org:serviceId:AltAppStore1.update_plugin 
2020-04-06 09:50:32.718   openLuup.requests:: No implementation
2020-04-06 09:50:32.718   openLuup.http:: request completed (148 bytes, 1 chunks, 0 ms) tcp{client}: 0x5619fe18a538
2020-04-06 09:50:33.536   luup.variable_set:: 10109.urn:micasaverde-com:serviceId:ZWaveNetwork1.LastPollSuccess was: 1586159071 now: 1586159431 #hooks:0
2020-04-06 09:50:33.766   openLuup.http:: request completed (15852 bytes, 1 chunks, 25155 ms) tcp{client}: 0x5619fdd5b1f8
2020-04-06 09:50:33.878   openLuup.http:: GET /data_request?id=lu_status2&output_format=json&DataVersion=157283683&Timeout=60&MinimumDelay=1500&_=1586157264170 HTTP/1.1 tcp{client}: 0x5619fdd5b1f8
2020-04-06 09:50:49.406 HTTP connection closed openLuup.http.receive closed tcp{client}: 0x5619fe18a538
2020-04-06 09:50:49.413 HTTP connection from tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.413   openLuup.http:: GET /console?page=log HTTP/1.1 tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.425   openLuup.http:: request completed (107893 bytes, 0 chunks, 11 ms) tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.456   openLuup.http:: GET /w3.css HTTP/1.1 tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.456   openLuup.http:: request completed (23361 bytes, 2 chunks, 0 ms) tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.472   openLuup.http:: GET /icons/openLuup.svg HTTP/1.1 tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.473   openLuup.http:: request completed (458 bytes, 0 chunks, 0 ms) tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.488   openLuup.http:: GET /favicon.ico HTTP/1.1 tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:49.488   openLuup.servlet:: file not found:favicon.ico
2020-04-06 09:50:49.488   openLuup.http:: request completed (126 bytes, 0 chunks, 0 ms) tcp{client}: 0x5619fde2bd88
2020-04-06 09:50:51.705   openLuup.http:: GET /console?page=log HTTP/1.1 tcp{client}: 0x5619fde2bd88

Welcome to the forum! Although you say you have been lurking, I see that this is your first post…

…sorry that you are having problems, but the forum is here to help!

Thank you, also, for posting a log (which I’ve reformatted in your post to make it easier to read) – so many people don’t do that, so this is a great start.

I may well be to blame for the issue, because I think a version of openLuup did briefly appear with an error.

  • what openLuup version are you running?
  • how did you initiate this openLuup update shown in the log?
  • a manual openLuup update is certainly possible…

…for manual update, simply replace the entire contents of the openLuup folder with files from the same folder in GitHub. You should be sure to update openLuup from the development branch which generally has the latest version.

Actually, just to share the blame, it turns out that GitHub has put in place some URL redirections which the LuaSocket library cannot cope with. The latest development version fixes this, but, of course, if update doesn’t work, we need to work around it.

Let me know how it goes.


Thank you AK!

Yes it happend to be my first post despite having been around reading for quite some time!

Just for my next post including a log; how do I get it formatted the correct way?

I am currently running version 19.12.27 which is the one I installed when I set up OpenLuup.

The update in the log was initiated via the AltUI plugin tab writing “development” in the update field and pressing the arrow button directly to the right of it.

I will try a manual update according to your instruction and report back.



The manual update seems to have worked perfectly!

I now have version 20.4.3 of OpenLuup installed.

I also tried to install NetMon and VirtualSensor and both installations seem to have been successful. The answers I got after each installation were:


where NN was “44” and “45” respectively.

An easy solution to the problem when you know what to do, thank’s for your swift help! I can now add that tool in my knowledge toolbox also. :slight_smile:


1 Like

You need to use the right markup syntax, but the buttons in the reply box…

…help with doing that. They all have a pop-up help text if you’re using a mouse. You can use the blockquote or preformatted buttons depending on need. You can also syntax highlight various code languages.

Block quote

-- this is Lua code
for i, j in pairs(x) do print (i, j) end

Yes, that’s a good way to do it (when it works!)

The manual update should sort all your problems.

…just read this. Good news! The usual update method should now work.


Thank you for the formatting tips!