Alpha update - Ezlo Linux fw v.1.0.17 for Vera Edge controllers

I am not wanting to do that. I am looking at what Ezlo are going to do and how it is going to affest my controller. I can already control any alexa device from my controller.
vera - node-red -alexa
vera -openluup - alexa
when i finally work out how to get Jquery on my vera i could just do
Vera - alexa

Then you already have an much improved functionality and reliability equivalent of VOI since it is not relying on the eZLO cloud and cuts the path much shorter. This has been my point from the beginning… The whole design concept of cloud first for this linux firmware has basically excluded itself from consideration for me. Even VOI which I find innovative is flawed at birth because it is cloud processed and relies on cloud to cloud. Everything about the new eZLO platform can and has been done better for months or years.

1 Like

And mostly local.

1 Like

The gap the VOI may close for my workflow is being able to control such API-connected devices as Smart Life gadgets and LG appliances directly versus their dedicated apps on Android (which refuses to run because my phone is rooted) it speaking to Alexa, or round tripping everything through IFTTT.
And yes, right now VOI also allows me to control Vera Plus devices by writing scenes on the Linux Edge, but I’m only putting up with that temporarily, in hopes that ezlo people figure out that’s less than ideal.

My train of thought is a little bit different.
I’m basically being asked to give Vera, via the VOI skill, access to my alexa or google home to have the same level of functionality as I have (to impersonate my voice basically). So, in case of google home I give it access to my calendar, my private notes, shopping lists, creating or cancelling appointments and so on (I have a credit card linked to that…)

From a privacy point of view, I’d basically never give that level of access to anyone, but especially won’t give this kind of access to the Vera team because I’m not only concerned that they might peak, but at their level of development I’m even more concerned about security holes (they can’t even get a damn android app fixed for over 2 months, and they now blame google for not pushing their updates. hint: don’t screw it up and test it in the first place). I’d hate to have someone troll me via my voice assistant or even worst…

1 Like

All possible with node-red running locally

I 'm all about privacy, and am not interested in marketing hype, I wish Ezlo every success but feel this is not the route for me. I have invested years in getting all my devices under one roof. I must thank all the developers that have invested time in great plugins and give great advise and ideas. From day one Vera never put the support/direction in, device intergration was slow and non exsistant for zigbee, plugins allowed to die and never removed and slow adaption of voice assitants and If This Then Never.

I will take a look at Ezlo’s new hubs and linux firmware when it is available in the UK., but it will need to do everything my plus can do now. They also need to support legacy devices fully or stop selling them.


@Ioana, my upgrade issue was self-inflicted. As I suspected, it was related to my prototyping running spread in a more secure manner (i.e. under a non-root user and group). I reverted all my changes except the override of the user:group to root:root in the spread.conf (I missed it on my first pass). Once I reverted my change and rebooted, the Edge performed the upgrade. Hope the team didn’t spend too much time on my mistake.



Great to hear that it is working now.
Also to make it work you can start recovery flow but it will remove all your data / devices from the controller.
For start recovery flow need to go through these steps:

  1. Need to power off the controller
  2. Press and hold sync button
  3. Power on controller
  4. Wait ~10 sec
  5. After it release sync button.
    It will take 10-15 min for recovery + it will start update flow after restoring firmware.
    It can take additional time.

@Oleh, good to know. To confirm, those steps will recover to the ezlo Linux firmware, right? If so, I’de like to try it from an end-user test-coverage standpoint. It’s pretty easy to set up my test devices and scenes so let me know.

It would be great If you try it from an end-user test-coverage standpoint.

Recovering a system means re-flash a system partition (replace a firmware by one stored in a recovery partition). It should be used if other ways to restore firmware functionality failed (soft reset, factory reset).

Note that recovery flow will remove all data / devices from the controller.
To start recovery you need:

  1. Power off the controller
  2. Press and hold sync button
  3. Power on controller
  4. Wait for ~10 seconds and release sync button.

And then wait until recovery finish, it can take up to 10-15 minutes (Usually recovered firmware will be older, so after recovery, firmware will check for new versions and start update flow - it can take additional time)

It worked perfectly - test passes. I can confirm that it worked because it generated a new ssl host key and wiped my configs. Time to set my devices and scenes again.

Any suggestions how to force my Edge to update to .17? Been waiting over 2 days.

Unplug the network cable, wait a minute, then plug it back in. Or you can power cycle it.

1 Like


You can also logon the the box and type the reboot command. I am no fan of hard power cycles on any system. Guess a nice user controlled way in the GUI (without an everlasting nag message!?) is in the making.

Cheers Rene

I used the power-cycle method, which worked and the upgrade to .17 took place automatically. Yes, it felt very brute-force and “wearing oven mitts” to me, especially when there was a long wait during which only one LED was lit (any Vera user knows the sphincter-clenching feeling that accompanies this!).

Agreed that I’d have preferred an actual Web UI or other means of “logging in” in this instance, but I don’t think such an accommodation has been made yet.

  • Libra
1 Like

The upgrade does take long with a couple of restarts it seems. Not for the fainthearted when used to Vera updates indeed. :wink:


So the question arises - will it be possible to control my devices and my Vera with Elzo firmware when the internet is down?
Also, are you planning a migration scheme to Elzo without need to reconnect devices? I have devices hidden deep in the structure of my home and accessing all of them to reconnect will be pain in the back.

1 Like

Hi @maclaw13,

Not at the moment. The only control is what the mobile app has. IMO, way too limited still to make a good setup, but at some point they should get where the Vera controllers are today.

Cheers Rene


I am trying to understand where it is used or if it is used in control of a vera device via alexa from an edge linux.