All devices lost after upgrade from AU Vera2 with dongle to Vera3

I’ve upgraded my AU Vera2 with a dongle to a Vera3 using the following procedure:

  • Upgraded to the latest UI5 on my Vera2
  • Backed up my configuration to a file
  • Installed my Vera3
  • Upgraded it to the latest UI5
  • Restored my previously saved configuration file

At this stage I noticed all my devices were listed, however I couldn’t communicate with them and had “No zwave dongle” displayed. I then changed the port setting to /dev/tty/s0 and all my devices were lost! All my scenes etc exist, but of course don’t work because there are no devices.

Anybody have any ideas?

is ‘dev/tty/s0’ port name a typo in your post or is that what you entered in Vera?

As the correct port to enter is /dev/ttyS0

It was a typo in my post. I actually have /dev/ttys0.

See the difference? Case matters.

And in fact I actually have it with the correct case, so still not working… :frowning:

You haven’t said… Are you intending to use the dongle with Vera3, or the internal Z-Wave radio?

I’m intending to use the internal Z-Wave radio.

I’m just going from memory when I upgraded my Vera2 to 3, but isn’t it a zero on the end? in which case, case shouldn’t matter…

Correct but the S does.

  • Garrett

Opa, it sounds like your Z-Wave network is still “on” the stick you were using for Vera2, and that you haven’t yet transferred it to an inside-Vera chip. Try this first and see if it works.

Plug the stick into the Vera3. Set the Z-Wave port to: /dev/ttyUSB0 (one digit, three capitals). Then reboot.

This is basically how I work (because my internal Z-Wave radio is a US one and hence useless).

If this works, you’ve ruled out any hardware issues with the Vera3.

Futzle, that was a great call! That was indeed the issue, and I am now at least using my Vera3 with all my devices, scenes etc working. :slight_smile:

The obvious question now is how to transfer it from the dongle to the inside-Vera chip?

Thanks for everybody’s help so far!

Is the chip in your Vera 3 in fact an AU compatible chip?

  • Garrett

Garret, yes it is an AU compatible chip.

And a good question it is, too.

My theory is that you do something like this:

  1. Using Setup > Z-Wave Settings > Advanced, back up the USB stick’s Z-Wave network.
  2. Change the Z-Wave port back to the internal Z-Wave chip (/dev/ttyS0 or whatever it was when Vera shipped to you).
  3. Pull out the USB dongle and reboot.
  4. Restore the backup you made in step 1.

No idea if this works, though. I’ve never had to do it. Maybe it’s time to put in a support email (since you’re no longer in a desperate hurry). Point them at this thread on the forum.

Futzle, I tried that, but no joy unfortunately. I’ve got a support email in and they’ve pretty much suggested the same as you, so I’ve let them know it didn’t work. We’ll see what they come up with next. I’ll keep you posted.

I am curuious why you said “or whatever it was when Vera shipped to you”. Could it be that I need to set it to something other than /dev/ttyS0 for use in AU? Of course I no longer have what it shipped to me with…

AFAIK, MCV Tech Support has a way of restoring just the Z-Wave database. Presumably to any target (USB dongle, internal chip, etc.). I was also told a while back that the Z-Wave database backup is indeed compatible between targets.

I use /dev/ttyS0 with my AU Vera, but I can’t remember what it shipped with either…just that it needed /dev/ttyS0 to work.

An update…support have managed to get all my devices back, and I am now operating without the dongle. However, all my devices have lost their names, and none of my scenes/triggers work. Support are still working on it…

A final update…support were unable to retrieve all my device names, so I had to reset them all manually, and redo all my scenes/triggers manually. Fortunately my network only has some 20 devices (so far)! Other than that, my Vera3 seems to be working fine.

Hi OPA…Can you please tell me what changes you had to make with the help of the support team… I am having similar issues… I have upgraded from vera 2 with dongle to vera 3 and lost all my settings…I have backed up my previous setting from vera 2, but its all stored in the usb. Cant get it to transfer to Vera 3 without dongle.
Thanks in advance