AEOTEC ZW096 Not reporting Power (Solved)

I bought 4 Aeotec Smart switch 6 (ZW 096) Firmware 1.0.
I added them to my system, a Vera Edge Firmware 1.7.2406 to discover they would not report power consumption, either power (w) or accumulated (kwh).
After looking around for a while in the luapnp.log i discovered the the device did not report any power.
I googled for the manual for this device, looking for more advanced options than the one in the box. Especially the Z-wave configuration data thinking this would be the place to start.
Found this one: (Sorry the insert hyperlink does not work?)
Found four options that seemed interesting:
(80) Enable to send notification Factory default 2
(90) Enables/disables parameter 91 and 92 Factory default 1 (Enabled)
(91) The value here represents minimum change in wattage to send message Factory default 25
(92) The value here represents minimum change in wattage percent to send message Factory default 5

Then came the problem of reading these values, being new to vera it took some googeling, but i eventually found this guide:
Did this and found out that actually all the Smart Switches i got had the wrong Factory default setting on parameter 90, they were all 0 so no power was ever reported.
Changed this to 1 and they seem to work like a charm.
There is only one problem that remains that i’m still working on:
Would expect a child device or two to show up, one for kwh and one for w, the latter not being so important since it is shown on the parent device.


Thanks for posting your fix. This worked for me as well. I have two of these units and they now report wattage updates.

I still am not able to poll the devices without getting the ‘Timed out waiting for the node to reply’ message, which is odd since the variable values do get updated when they are polled. Anyone else having the poll issue or is it just me?

This didn’t work for me but amending parameters 101 and 111 as set out is this thread did the trick -

I had two out of three that did not report power. This resolved it. However, why did one work without the extra settings?

Also, switching two units with the same load, one reports 3 watt, the other 16 watt (most like it)…?

Interesting just stumbled across this thread, have the same issue, have three of these devices and none report any power use stats. Contacted Vera support and they confirmed this is the case and had no solution at first level support so have raised it to 2nd level. I am going to ping them back with this thread and the other one mentioned in one of the posts. Maybe they need to add something to their on boarding wizard for these devices as its looks like no ones work straight out of the box :slight_smile:


This worked for me using Ezlogic

Login and chose your controller
Go to devices
Click on Function DropDown of the Aeotec zw096 device
Chose Z-wave Configuration and Add the following parameter and their values

Parameter 101 [4 byte dec]: 15 (report kwh, watt, voltage, current)
Parameter 111 [4 byte dec]: 30 (report every 30 seconds)
Parameter 102 and 103 [4 byte dec]: 0

See if these new settings to the report groups work for you. You should be getting sensor reports every 30 seconds with this setting.

Also set Parameter 90 [1 byte dec] to 0 to make sure that selective reporting is disabled
I picked this on another forum thanks to danielo515Danielo Rodríguez