Aeotec Smart Switch 7 (ZW175-C16) added successfully

Officially the Aeotec Smart Switch 7 is not supported by Vera yet.
I was able to add a Aeotec Smart Switch 7 to my Vera with firmware 1.7.4453. It was detected as Binary Light. But when I switched it on or off in the web interface, the device changed the state only in the web interface. The power in the smart switch was not turn on or off.

I applied the fix suggest for the FGS-223 with the second channel.

  1. Add the following variable in the device of the Aeotec Smart Switch 7 under “Advanced” and “New Service”:
    Service ID: urn:micasaverde-com:serviceId:ZWaveDevice1
    Variable: SetTargetCommandClass
    Value: 37
    Select “Reload engine”

  2. Fix the local switch change reporting and power reporting by opening up the test lua window and running the following commands one at a time, leaving 30 seconds or so between each one.

In both these commands replace ‘20’ with the Z-Wave NODE ID of your Aeotec Smart Switch (shown on the SETTINGS tab like “ID20”):

luup.call_action(‘urn:micasaverde-com:serviceId:ZWaveNetwork1’,‘SendData’,{Node=‘20’,Data=‘133 4 1 1’},1)

The above command deletes the current Association to group 1. The following command adds the multi-channel Association to group 1 that is required.

luup.call_action(‘urn:micasaverde-com:serviceId:ZWaveNetwork1’,‘SendData’,{Node=‘20’,Data=‘142 1 1 0 1 1’},1)

Kind regards,


I tried this and it didn’t work for me (with newest firmware - 7.31).

When I press button on device, status (on/off) is reported in GUI. Using switch in Vera’s GUI has no effect (in fact it can be used to operate night light mode of this switch, but not the on/off state :wink:

Could anyone test @anon8487131 workaround and can confirm that Smart Switch 7 works with Vera 7.31?

Using firmware latest version 1.7.4970 (7.31)
on Vera plus

followed this instruction

First Method -but changed the deletion of capability 38:2 to 38S:2 and it worked