Adding RTSP Cameras to eZLO Plus controller

SO has anyone gotten generic RTSP with two way audio to work in the eZLO Plus?

I got a used controller with older firmware and it worked great, it updated and now nothing I do can get it back.

Hello focusedcoder,

Adding RTSP cameras to the eZLO Plus controller should be possible, but it seems you’re experiencing some issues after a firmware update. It’s important to note that the eZLO Plus controller supports a wide range of cameras, but the specific compatibility can vary based on the camera model and the firmware version of the controller.Assuming that your camera is compatible and was working fine before the update, it’s possible that the firmware update may have caused some settings to change. Here are a few steps you can try:

  1. Check the camera settings: Make sure the RTSP settings on your camera are correctly configured. This usually involves setting the correct RTSP port and stream path.
  2. Re-add the camera: Try removing and re-adding the camera to your eZLO Plus controller. This can often resolve issues caused by firmware updates.
  3. Check the controller settings: Make sure your controller is set up to support RTSP streams. This usually involves enabling RTSP in the controller settings.

If you’re still having trouble, it might be helpful to look at the specific error messages or issues you’re encountering. This could provide more insight into what’s going wrong. As for the two-way audio, this is a feature that depends on both the camera and the controller supporting it. If it worked before the firmware update, it’s likely that it’s still supported. However, you may need to check the settings on both your camera and the eZLO Plus controller to make sure it’s enabled and configured correctly.

Where do you do this? Cant see any such related settings in the Android Vera app.

Thanks.

Just tried to add one of my Hikvision cams to an Ezlo Secure using the Android Vera app and the Generic IP camera option.

I added my cameras IP address, username and password and then the RTSP stream URL.

Test connection seemed to work although it didnt fully confirm but it didnt complain.

It added the camera but it doesnt seem to play anything its just a black screen.

Edit:

I then tried deleting and adding it this way instead, but it still doesn’t seem to play.

I can also confirm that trying to edit the cameras “Advanced” settings does not work any changes are not saved. So you do have to delete the camera and add it again to change anything in there.

@JDPC any comment ?

Thanks

Hello cw-kid.
eZLO Plus controller does not have a specific setting to enable or disable RTSP streams. The ability to handle RTSP streams is built into the controller’s firmware and cannot be manually toggled on or off, It should work without needing to adjust any RTSP-specific settings on the controller.
However, you do need to ensure that the RTSP URL for your camera is correctly configured, to do that, check settings on your camera by opening a web browser in a computer connected to the same network, typing your camera’s IP address in the address bar, and entering your login credentials when prompted (username and password).
-Find RTSP settings:
Look for the configuration section related to the RTSP Protocol. This could be in the network settings section or video settings.
-Enable RTSP:
Make sure the RTSP option is enabled. There may be a checkbox or switch to enable or disable the RTSP protocol.
-Configure RTSP Port:
Generally, the default port for RTSP is 554. However, you can configure a different port if necessary. Make sure you remember the port number you choose.
-Configure the Stream Path:
Sets the path of the RTSP stream. It can be something like /Streaming/Channels/101 or /h264/ch1/main/av_stream. The path will depend on the specific camera model, how it is configured and, firmware version, use this site to find more related info: https://www.ispyconnect.com/, firmware 5. x and higher 5.1.0, 5.1.6 y 5.2.0 could be as per manufacturer recommendation:

rtsp://USUARIO:PASSWORD@IP:PORT/(h264/MPEG-4)/ch(CANAL)/(main/sub)/av_stream
rtsp://USUARIO:PASSWORD@IP:PORT/Streaming/Channels/(CANAL)

Example:
rtsp://admin:12345@mycamaraip.dyndns.org:554/h264/ch1/main/av_stream (“main” for the mainstream, “sub” for the substream)
rtsp://admin:12345@mycamaraip.dyndns.org:554/Streaming/Channels/1 (channel 1 for the mainstream, channel 2 for the substream)
-Save Changes:
After making the necessary settings, save the changes. It may be necessary to restart the camera for the settings to take effect.
-Test RTSP Connection:
Use an RTSP-compatible media player (such as VLC) to test the connection. The connection URL should be in the format rtsp://:@<IP_address>:/<stream_path>.
Remember that these steps are general and may vary depending on the model and firmware of your Hikvision camera. Please refer to your camera’s specific documentation or contact Hikvision technical support if you encounter difficulties or need more detailed information.

Lastly, Re-add the camera to your eZLO Plus controller. Here’s a general guide on how to do this:
-Open the Vera app on your Android device.
-Tap on ‘Cameras’ in the menu.
-Tap on the ‘+’ button to add a new camera.
-Select ‘Generic IP Camera’.
-Click on Try to detect RTSP stream
-If the last step fails, refer to your specific camera’s documentation to find the correct RTSP URL and any additional parameters that may be required. Hikvision often provides detailed documentation with RTSP URL examples for different scenarios, try something like this: rtsp://[username]:[password]@[camera-ip-address]:[port]/[stream-path]
-Tap on ‘Test Connection’ to make sure the controller can connect to the camera.

If you’re still having trouble, it might be helpful to look at the specific error messages or issues you’re encountering. This could provide more insight into what’s going wrong, please send us a request at support@ezlo.com and we will get back to you as soon as possible.

OK automation enthusiast,

I see my friend is already confirming my experience!
Thanks CW Kid! You are the man!

I wanna chime in here for a minute. I will confirm that when I got this controller it was used. I put in the cameras with the correct rtsp streaming url per the manufacturer and confirmed across multiple other platforms, plug ins like alexa amcrest plug in, amcrest smart home app IP cam viewer from google play on multiple android devices. I have the ports forwarded to the web and I record it all locally using blue iris 6. MY cameras work flawlessly.

The Mios Dashboard player doesnt show, it did, even had two way audio but then, My unit was NO longer available in the home.getvera.com web relay and this was aslo broken.

Creating the camera is ok but its heavy heavy handed. Good luck typing that RTSP URL in the your phone with two fingers plus IP username and password EVERY TIME since you can NOT edit.

The mobile app? pick the one we are discussing, Only the Vera Mobile application Version 7.108.1.27. The MiOS app on the same device is version 1.113.02 but crashes everytime.

During creation of my camera in Vera Mobile, when saved the app adds forward slash in front of my “RTSP” URL and it appends the port 554 in the IP address field. The stream is detected and saved but NO details are allowed to be “edited” so… START OVER!

whatever is broken is probably the way the app puts the URL in the frame to render it. probably and syntax parsing error somewhere but yeah that’s been my experience with apps that intersect in the cloud.

I was advised to “RESET” the camera despite the app/editing problems.

I went 200 miles got the controller and cameras from my granddaughter and factory reset the eZLO Plus controller and the camera. I re-created the camera and I used the same ports since I all of my other apps/devices use those ports for this camera and they work fine locally and beyond the fire wall. (no cloud relay need for this)

As of today, it does not work and there is no progress on this issue that I believe I can “fix”.

I have a ticket open on the playback that worked and is now blank and a ticket about the app not allowing edits but thats just the Vera Mobile app. MIos app can not create a camera on any of my devices that run MiOS on Android. The app will crash adding generic IP camera. SO evidence again, we are parsing something or calling something wrong.

I have this machine in my hands and want it deployed soon or I scrape up an old vera or whatever.

I am waiting on support to let me know what else I can do and my opinions on the parsing should be investigated.

I was looking at this today and in the MiOS webpage, I look at my camera > settings and I get this
Screenshot 2023-11-27 103535

That is definitely not the URL that will pull the stream and that URL has no similarity to what is showing I created in the vera mobile app, something in that wizard goes wrong.

I think I found my problem but I can not fix this. That aint the PORT and that aint the syntax. ITs not even the IP address.

it should be

rtsp://username:password@192.168.1.136:2020/cam/realmonitor?channel=1&subtype=01

Not whatever this is-
rtsp://192.168.1.142:5554/6563729bf62fa814ce5412c9

this is a bug

Update: since this post now when I add camera the dashboard on the web shows this.
Screenshot 2023-11-27 133514

I have a video of me testing the RTSP stream.

It used to work. (see David C. Id #296724) Same camera, same all that but now it does not work. I encountered this and documented it with technical support. I even uploaded this video to show them it was working but the app did not allow edits. I shared the exact RTSP URL at the time. Later that controller “updated” after I relocated it. Now the ticket is closed and merged with a closed ticket.

Note Firmware Version 1.65.2 with Dashboard 1.1.17 is working in the video.

now Firmware Version 1.66.1 with Dashboard 1.1.19 it does not work.

Can I roll back?

I think this is somewhat expected behaviour, certainly for Ezlo VistaCam branded cameras, not sure for 3rd party IP cams however.

That other camera stream url you are seeing there is the proxied url that the controller creates.

I assume 192.168.1.142 is the IP address of your Ezlo controller.

With the VistaCams you can use that proxied URL to access the rtsp stream of the camera as hosted on the controller.

Or by looking in a particular log file, forget the name, you can see the direct rtsp url of the VistaCam camera and use that in say a 3rd party app.

Regarding 3rd party cameras which is what we are trying to use in this thread, I suspect its doing the same by the looks of it and creating a proxied url using the controllers own IP address.

I will check mine later and have a look…

EDIT: A product manager just told me that “yes it should be only for Ezlo cams” meaning that a controller based proxied RTSP Url should not be created for 3rd party cams.

@JDPC I am definitely using correct and known to be working rtsp urls for my Hikvision cams but for whatever reason they just dont play in your system/ apps.

They do play fine in VLC, TinyCam Pro, Blue Iris apps.

I just checked my Hikvision cams under Device Settings in Ezlogic web UI and mine look the same saying “No Stream”

@focusedcoder What version of the Vera mobile app are you using?

Android or iOS?

and what is the version number? Can be found under Settings - Customer Care area I think.

I just tried adding an Ezviz camera instead and that works OK and I was able to play its video feed in the Vera mobile app and Ezlogic dashboard.

But my other Hikvision cameras did not work for some reason.

@focusedcoder What is the make and model number of the IP cam you are trying to add ?

I think I found where the problem was laying with my Hikvision cams. I was using the Sub Stream /102 when adding them into the Vera mobile app and they were not playing.

I just tried using the Main Stream /101 instead and that worked and now the camera is playing OK in the Vera mobile app.

I think the difference between 101 and 102 streams is I have the 102 stream set to MJPEG Video Decoding. Where as 101 is set to H.264


And this was the correct way to add my camera in the Vera mobile app:

1 Like

I can also confirm that the Ezlo controller does actually still create a proxied RTSP stream URL using its own IP address and that URL does play in 3rd party apps like VLC.

image

a proxied RTSP stream URL, so thats normal… good to know.

These are amcrest adc2w model cameras. in my system they were added with no changes to the encoding. I believe its h.264. I also tried changing one to substream and set the camera to mjpeg but still nothing.

can you try h.264 or double check if it works with h.264 ?

Yes its works when its set to H.264 on my cameras settings, then in the Vera app the camera then plays.

It should probably be set to H.264 or H.265 rather than MJPEG.

I think the reason I had my sub streams set to MJPEG was for a legacy dashboard app to access the cams, that didn’t support the other video codecs etc.