Adding HA02 to Veraplus does not work

This should just work, but I can’t seem to add my HA02’s to my Veraplus. I have excluded them from the original Intermatic controller but that do not seem to add to the Veraplus. I must be doing something silly here.

To add one I select “Add Device” from the Devices screen, then I select “Generic Z-wave”. I click next a couple of times and it starts counting down 60 seconds. The Zwave led is blinking slowly on the Vera at this point. If I hit the button on the HA02 once or twice the ZWave led appears to flash a bit faster momentarily then it goes out and does not come back on until I click Exit from the Add Device screen.

The HA02 does not appear on the devices screen but it looks like there is some recognition of the device because the ZWave led goes out.

Any ideas how to get this to work?


Ok, I figured it out. Having the HA02 4 ft from the VeraPlus was too far away. I got an extension cord and put the HA02 right next to the VeraPlus and I was able to add the HA02 as a generic ZWave device with no problem. Same steps as above, the only change was to put the ZWave device closer to the VeraPlus.


Hello Jim, am happy to see that you have this worked out.
Indeed sometimes, bringing it a little closer to gateway might do miracles. If you need any advice on the spot our tech team is at hand as well(see my signature)

used jasco wall receptacle in switches and dimmers and it worked like a champ…intermatic HA01 on Vera Plus version 1.7.4453