AD2USB to Ademco Vista Panel

I just moved to Vera Plus and had trouble getting my alarm setup from Vera Lite/UI5 working. Threads spanning over 10 years and thousands of posts wasn’t very helpful.

I eventually got it working with parity to UI5 so here is a document that outlines the steps so you might avoid a lot of the trial and error and forum searching I had to do.

Alarm Interface to Vera Plus March 2020.pdf (744.6 KB)

Dear curiousB,

I am so glad I found your post after 3 days of trying to get this plug in working with customer services help. I can report with your powerpoint I have achieved success.

A couple of points to add. This wiki article makes it clear to configure your serial port before you download the Honeywell Ademco Vista Alarm Panels via AD2USB Plugin. This makes configuring your serial port a two step process 1) at this point to set the baud rate to 115200 and 2) as you show in your powerpoint selecting the Honeywell Ademco Vista Alarm Panels via AD2USB for the Used by Device field. See this wiki for steps http://code.mios.com/trac/mios_vista-alarm-panel-ad2usb

The second point is on your slide 7 showing the keypadaddress. It would help the readers is you noted the AD2USB default keypadaddress is 18. Then it ties to the AD2USB literature and Youtubes.

Regards,

Kh

Hoping you guys can give me some advice. Customer service has fallen off a cliff lately. I had to replace my AD2USB, it’s wired and communicating fine with the panel as confirmed by the tech from the Alarm Decoder Store working with my through desktop sharing. The problem now is configuring the serial port. The options no longer appear under the Dev Apps/Serial Port Config. It simply shows a SAVE button. I finally was able to speak with a “tech” at Vera and all they can suggest is a bad USB cable LOL I tried a different cable, nothing. She said the panel must be bad. Again, I can talk to the panel just fine through the AD2USB device. In the past, the serial port options were visible as shown in the PP slides. They have turned it off now in the software. I have 4 UI7 controllers on my network. She suggested the USB port is bad on the controller. I mentioned it doesn’t appear on any of the 4 controllers anymore. She then said it only shows once the device is connected. Ultimately, all the tech could offer is I have a bad usb cable LOL Even after swapping the cable with another cable. Zero support on the Vera side, hoping the community can pull it off once again?

Any help would be greatly appreciated!!

Serial port config is found under:

         Vera/Apps/Develop apps/Serial Port configuration

The pdf I posted above shows the proper settings.

The problem is, the option or fields to complete do not appear? Please check the photo. Thank!

Have you tried power cycling your panel with the Vera controller connected. That includes removing mains and backup battery. I don’t own a Vista but clearly the controller doesn’t recognise that a panel is attached. You may have to power cycle the Vera controller too. Are you using a USB hub on the Vera controller to make the connection between the panel and the
controller . If so is it powered.

I don’t think you don’t need anything plugged into the port to configure it. Unplug USB and see if the config field comes up.If so set it up then plug in usb.

You’re not running a USB hub and several USB devices are you? ie memory stick and AD2USB? Not sure the software can understand multiple concurrent USB devices.

The serial port settings will only appear and populate when the controller detects some form of serial connection. This can be confirmed by connecting a loop back plug on the DB9 connection.

A passive usb hub will not suffice as the controller does not have the overhead required to power one. I use a powered hub connected to the Vera controller USB port to drive three separate serial to usb devices and all three are recognised and work perfectly.

The usb cable can indeed be unplugged from the Vera controller but Luup needs to be reloaded for it have any effect.

No USB Hub, just directly to the Adapter from the Vera Plus. I tried cycling the Vera many times, also removed power from the alarm panel, including the backup battery and the transformer at the same time. Left it down for about 5 min. No results.

@peterxbmc (can I just call you Kodi?) Are you suggesting that I use a powered USB Hub to tickle the Vera and that might get me the serial port config I need?

Once you have only one serial to usb connection directly connected to your VP I see no reason why it doesn’t work. A powered hub shouldn’t make any difference in this case.

Just a couple of questions. Do you know what caused the failure of your NuTech unit. Did the failure continue down along your cable to your VP USB port.

Could you plug in just your serial to usb cable to your VP, reload Luup and see what’s reported in your Serial Configuration. It should show up either FTDI or Prolific chipset

If the first cable doesn’t report anything try a different cable.

If you can ssh into your VP try the following commands with everything connected and after rebooting your VP. These should confirm what is recognised as connected to your VP

l /dev/tty*

cat usbserial

Sorry for the late reply. After trying everything, I figured I’d try process of elimination on the hardware. Since I had already replaced the AD2 and successfully have it communicating with the panel, replaced the USB cable twice, the only thing left was the controller. Ordered one from Amazon, it just arrived. After the initial setup out of the box, I skipped the Setup Wizard and went straight for the serial port config. Ta-Da, the config fields appear as usual. I’m guessing the USB port on the Vera Controller was taken out at the same time the AD2USB device was taken out. Did a backup from the damaged controller and uploaded it to the new controller. Was able to configure the serial port and all is well.

Thanks very much for all your effort!!!

Yes I was wondering what happened with you. Thats why I asked earlier what caused the failure of the AD2USB and how far down the line did this damage occur. You rarely get away with one hardware failure on power surge/lightening strike. Bear in mind the serial to usb cable has its own electronics built in so replace that too before tying down your installation, a cheap replacement in the long run.

It’s very difficult to fault find remotely when you have no access to the hardware so I was purely feeling my way in the dark. At least it’s now all ended on a good note.

1 Like

The joys of living in FL:
Main board on LR TV (My first time trying that myself, was a breeze - saved thousands)
2 8 port POE Network Switches
CGFI Outlet at gate (SO LUCKY it stopped there)
2 Security Cams
Comcast Modem
AD2USB Device
and the cherry on top… My Vera Plus lost it’s USB :stuck_out_tongue:

It could always be worse… No structure fires :slight_smile:

Neighbors lost a lot of the same… one lost his well pump, ouch!

Your Benjamin Franklin moment :joy: Time for lightening protection in your area by the sounds of it.

Spent my share of Benjamin’s, that’s for sure!! I have 3 meters at the house, all have Whole House Surge at the meters. HDMI In-line surge protection, all electronics are on separate UPS backups. The TV was even running through a power strip with surge from our power company, then into a UPS. It’s just crazy out here in the sticks of FL. So much of it is static discharge in the air, doesn’t even come down the line. For example, there are two different gates, two different houses in our neighborhood that open about 1 sec before big thunder or lightning hits. Totally different brands, it’s so weird. All our power is buried. One of the gates runs off solar, not even connected to power. FL is a head scratcher when it comes to surge and lightning. Do all you can and hope for the best!!

Dry air lightening. Your biggest enemy :+1:

1 Like

Folks,

Just a heads up. When you download UI7 version 1.7.5186 (7.31) it resets the Vera USB port baud rate back to the default 9600 baud. You will have to go into APPS/Develop Apps/Serial Port Configuration and reset your baud rate to 115200 for your Vera controller to start talking to your Nutech AD2USB device again.

KH