Ad2usb Cant detect device after ui7 upgrade

i recently upgraded my veralite to ui7.
After this, i have been noticing a “cant detect device” on the ademco vista panel that comes and goes.
The ademco partition is working fine
i am able to arm and disarm the panel perfectly fine in Vera.
im attaching my current settings

any suggestions?

If it makes you feel any better, I am still using ui5 and my ad2usb connection down will appear every day or so. Sometime more than once in a day. As in your situation, it doesn’t seem to impact my connectivity to the alarm or at least not when I finally notice it. Perhaps it actually lost connectivity for a while and now it has returned. Mostly mentioning it because of the ui5 vs ui7 environment.

Just wanted to chime in that this is happening to me as well.

Everything seems to be 100% functional with the plugin. I can disarm, arm, etc, and get proper sensor statuses. It even works over reboots and reloads.

However that error remains there all the time. I haven’t cared much cause it’s functionally working, but I would obviously love to have it go away too.

Kevin from Nu Tech/AlarmDecoder here:

To get the device to detect as a serial port please follow these instructions:

Hi Thanks for the reply, but I am lost. Where do we type in those commands? Do I open a terminal session into the Veralite? Sorry if I’m missing something obvious…

ssh to your vera and enter them at the command line as root - tools such at putty can help

Thanks, That’s what I thought. Made the changes suggested (on my Veralite) and I still have the error. It all worked on UI5, but UI7 give me the error. Unlike one of the above posters, I am non-functional since I cannot add zones to my partisans.


Also, after some more research, found that these steps will work in UI5 and NOT UI7. Must have missed that…

Hi all,
I’m new to Vera and just got my AD2USB working on UI7 using the instruction sent my Kevin - initially the USB port was not detecting the AD2USB. Thanks! It required a little bit of research to find the password to SSH into the VeraLite.
However I have the same problem mentioned in this thread: partition is fine, but the plugin says it “Can’t Detect Device” for the panel. I think that happened just after I added my first zone in the cheat sheet.
If anyway has an idea to fix I, let me know:)
Also when I added a zone, it didn’t appear immediately, I had to reboot the VeraLite to see it.

1.Kevin, will your instructions work for a older ad2usb that was working fine on a ui5?

  1. It seems that the cheat sheet zones do not work when connection is down.
    i have some scenes based on ademco motion sensors that are not running due to the connection being down.
    im assuming the sensors are not communicating with vera. i could be wrong.


It should work, but shouldn’t need to be done with an older ad2usb - though if it works on a PC and you are having trouble with the Vera it can’t hurt.

Hello, I am having the same trouble with my Vera3, using UI7. I cannot assign zones in the cheat sheet due to the Can’t Detect Device error message. Is there a resolution or work around to this yet? Frank Sisic

Any resolution on the “Can’t Detect Device” for the Panel. I have the same issue as previous posters on a new install. The partition is fine, but the plugin says it “Can’t Detect Device” for the Panel. I can Arm/Disarm the system via the partition but the Panel device doesn’t work. I can still Add Zones to the Panel but it shows as disconnected?

Just seems to be how the plugin was written - you control from the partition rather than the “panel” itself… partition detects device… strange but at least it works for arming/disarming. I’ve been digging through the driver code a bit here over at Nu Tech, hopefully have something to submit to mcv to address some of these issues.

I’m having similar problems with AD2USB after the UI7 upgrade from UI5. I get “Can’t Detect Device” messages about the alarm panel but the Alarm Panel Partition still seems to work, i.e I can arm/disarm and still get notifications about those events.

I’ve noticed that the Plugin Version is at 2.45 and the current app is at 3.10. Don’t know if that is part of my problem.

I’ve tried turning on auto-update for the plugin but that doesn’t seem to work and the setting doesn’t stick. Its there anyway to update aside from uninstalling the AD2USB app and all of it’s devices and reinstalling the new version and setting everything up again.

Thanks - David

I also have app v 3.10 and plugin 2.45. It was fresh installed recently, so I think the version difference is expected.

After I got everything installed, I had the “can’t detect device” for a few days (yet everything worked fine), and the message mysteriously went away on its own. Can’t say what it was that fixed it, I don’t remember doing anything in particular. I fixed a similar issue on my Foscam by setting a CommFailure value to 0 (as recommended on another thread), but I wonder whether that’s the equivalent of sweeping a bigger issue under the carpet. Since it works, I’m hesitant to poke at it.

Any news o the “Device Not Found” error? Thanks

I am seeing the can’t detect device message, as well. This is with UI 7 on a new Vera Edge. My Partition 1 is working, but the Alarm Panel device is showing the error. Anything new on this?

add me to the list of people seeing this error… Any one find a fix?

I have the same error - UI7 1.7.569

No Ideas?