"Aborted; no/invalid response from 192..."

Thank you Patrik for the app :slight_smile:
Installed Sonos 2.0 and it went well. Also installed the UPnP plugin and its running. I can see the Sonos speaker on the network with a Network scanner. But when I discover it states “Completed. No new devices found” and when I manually set the IP than I get “Aborted; no/invalid response from 192…”. Then I realized that the Vera and the Sonos was under two different sub-nets, 192.168.0… and 192.168.1… That is probably something I should have thought of or I should fiddle with the router. On the same sub-net it works well. Just for anyone else to consider if you have different nets.

1 Like

Yeah, at a minimum, if you’ve firewalled between, you’d need port 1400 open in both directions between the two subnets. I’m sure there’s more, but it’s not something I’m going to chase or test at the moment.

Neither do I, I have a router with more ports in the mail right now so that I can have everything on the same net.

Hmmm… all you really need is an Ethernet switch to plug in to the router you have… likely cheaper and easier to configure (likely no configuration at all)?

Yes I know :slight_smile: but I wanted a managed router from Ubiqity with enough ports for my complete apartment, so this was my solution to solve it all. But you are right …

Ahh… control… visibility… I get it.

1 Like

I do have the same error: Aborted; no/invalid response.
Both Vera and Sonos are in the same network. Upnp plugin is running. Do not know how to solve this anymore. I have tried everything. Reinstalling, deleting, etc. Still the same results. ‘Offline’ …

That usually means the IP address of the player is not what you think it is, or the player is otherwise somehow unreachable, or… it’s not a Sonos device at all. You don’t say what kind of device you are working with. So the first level of troubleshooting here is for you to go in to the Sonos app on your mobile device, go into Settings, then System, then About My System, and there you will find listed each of your Sonos devices and their current IP address. Make sure that’s the address you are using. If it’s different, use what the app is telling you (or go fix why it’s different from what you expect–DHCP reservation problem?). If it’s the same, reply here with your Sonos model name and I’ll give you further instructions. Also give me all of the information shown for that device in the About My System display above.

Hi rigpapa, I’m already pleased there is someone to help me in this. The apps on my phone and PC are working fine, no problems with them. I have Sonos beam and Play 1. They get a DHCP fixed address.

Right, so are the addresses the app shows the ones you are using? You only need to get one to start. The plugin will find the remaining devices.

Well… that’s what I thought too… It sees two zones. But strangely it doesn’t show the name, but the serial number of the Sonos… And still offline. It just cant detect the devices.

OK. Please request this URL in a browser, putting in the IP address of one of your Sonos zone players in where indicated. Then PM the output to me here. You may need to ZIP it, if the output is larger than the max post length.


By the way, I note that your zone players are running the S2 OS… it may be that. I’m still on S1, as I have one really old (almost original) Sonos zone player.

Yes well… I’m not living alone… :slight_smile:
My wife uses the app, and when it says ‘Update now…’ :smiley:

After several PM follow-ups with OP, the problem appears to have been Netgear Armor blocking access through a Nighthawk router.

1 Like

Thought to let everybody know who’s interested: After fixing the problem with Netgear Armor, I faced several other connection problems between Vera and other devices.
I had contact with Netgear, and they said it is the problem of SIP ALG. They advised me to turn it off in the router. It influences the firewall, normally it causes problems using VOIP. Anyway, after turning off this service everything is working again.
I really don’t know if other Router brands have this problem.