7.32 Vera Firmware - Beta Release

As I discovered the broken beta link, I just followed the logic from previous official fw links and it works…
7.32 is installed on 2 machines without problems. Even when you reset to factory settings, the 7.32 is installed.


The links for the download at the top don’t work
i.e. https://dl.mios.com/rl/732/mt7621_Luup_ui7-1.7.5364-en-mios.squashfs

I’ve asked the team. A new set of builds are coming this week.


We’ve released a new beta version.

UI7 - Vera Firmware Update (Open Beta 2)

Firmware versions:
VeraEdge: https://dl.mios.com/rl/732/mt7620a_Luup_ui7-1.7.5372-en-mios.squashfs
VeraPlus: https://dl.mios.com/rl/732/mt7621_Luup_ui7-1.7.5373-en-mios.squashfs
VeraSecure: https://dl.mios.com/rl/732/mt7621s_Luup_ui7-1.7.5374-en-mios.squashfs


  1. Fixed the issue with broken schedule after editing a scene based on “After/Before Sunrise/Sunset”
  2. Fixed the issues with empty device pairing wizards for Honeywell T6 Pro Thermostat, RCS Technology Thermostat TBZ500 Lux Thermostat KONOse and Lux Thermostat KONOzw
  3. Fixed the issues about negative values in “Device Options” not being displayed correctly. Negative values can be set from “Advanced”->“Variables”->“VariablesSet” but there is still an known issue about not being able to set it from “Device Options”.

@edward Noticed on Edge (5372), install with factory reset:

  • The mios_fix_time script, which is broken and I thought you said you were going to remove, is still present and now linked twice (once with a .sh suffix and once without) in /etc/rc.d
  • In fact, it looks like there are a handful of scripts in /etc/rc.d/ that are now double-linked, once with .sh suffix and once without, and this will cause them BOTH to run at boot; I’m not sure this is a good idea, may have unintended consequences/side-effects. List:
lrwxrwxrwx    1 110      1003            26 Apr 21 12:09 K95-mios_fix_time -> ../init.d/mios_fix_time.sh
lrwxrwxrwx    1 root     root            26 Apr 21 12:12 K95-mios_fix_time.sh -> ../init.d/mios_fix_time.sh
lrwxrwxrwx    1 110      1003            26 Apr 21 12:09 S021-platform_init -> ../init.d/platform_init.sh
lrwxrwxrwx    1 root     root            26 Apr 21 12:12 S021-platform_init.sh -> ../init.d/platform_init.sh
lrwxrwxrwx    1 110      1003            27 Apr 21 12:09 S03-backup-restore -> ../init.d/backup-restore.sh
lrwxrwxrwx    1 root     root            27 Apr 21 12:12 S03-backup-restore.sh -> ../init.d/backup-restore.sh
lrwxrwxrwx    1 110      1003            26 Apr 21 12:09 S115-mios_fix_time -> ../init.d/mios_fix_time.sh
lrwxrwxrwx    1 root     root            26 Apr 21 12:12 S115-mios_fix_time.sh -> ../init.d/mios_fix_time.sh
lrwxrwxrwx    1 110      1003            30 Apr 21 12:09 S47-backup-restore-nc -> ../init.d/backup-restore-nc.sh
lrwxrwxrwx    1 root     root            30 Apr 21 12:12 S47-backup-restore-nc.sh -> ../init.d/backup-restore-nc.sh
lrwxrwxrwx    1 110      1003            27 Apr 21 12:09 S480-provision_vera -> ../init.d/provision_vera.sh
lrwxrwxrwx    1 root     root            27 Apr 21 12:12 S480-provision_vera.sh -> ../init.d/provision_vera.sh
1 Like

In light of this revelation, am now adopting an even stricter “wait and see, and then wait some more” stance on installing beta (really, any) firmware onto daily driver Vera.

1 Like

I’ve updated to the latest beta and it’s working ok for me, but I’m decoupled and I’ve removed the scripts mentioned by @rigpapa anyway. I’ll report back in case of errors.

1 Like

@rigpapa thanks for catching this. We know where the issue is and are working on a fix.


is only the “Edge” affected?

Edge and Plus versions are affected.

Any news on the progress?

We’ve released a new beta version.

UI7 - Vera Firmware Update (Open Beta 3)

Firmware versions:
Vera Edge: https://dl.mios.com/rl/732/mt7620a_Luup_ui7-1.7.5379-en-mios.squashfs
Vera Plus: https://dl.mios.com/rl/732/mt7621_Luup_ui7-1.7.5380-en-mios.squashfs
Vera Secure: https://dl.mios.com/rl/732/mt7621s_Luup_ui7-1.7.5381-en-mios.squashfs

Fixed the issue with duplicate init scripts


Hi @edward

The init scripts now look as expected.

Cheers Rene

1 Like

@edward Indeed the multiple init scripts issue seems to be fixed. The mios_fix_time script is still linked (at least, on Edge).

To recap on that, this script relies on a mechanism that isn’t implemented properly on Plus or Edge, so it malfunctions on these platforms and its effect on “fixing” time during a restart without Internet is actually worse than what OpenWrt itself does in its own script that runs earlier (so fix_mios_time is even undoing something more useful). Either the mechanism needs to be made to work properly on these platforms, or the script should be removed/unlinked entirely.

1 Like

I intend to wait on installing any further revisions of 7.32b until this and any other long-known issues get worked out. Thanks again for the heads up.

@edward I think I found an additional issue new to these two Beta releases…

The problem is that arming/disarming of Door Sensors, specifically, is not performing as expected when changing house modes. Motion sensors work as before, it only seems to be Door Sensors with a behavior change. Consider the following configuration:

In this configuration, Virtual Motion will arm when the house mode is changed to Away or Vacation, as expected, and will disarm when the mode is Home or Night, again as expected.

Virtual Door 1 and 2, however, become ARMED in all house modes other than Home. No changes to the configuration in “My Modes” or the ModeSettings state variable repairs this. So even in house modes where the device is set to be disarmed, it becomes armed. Based on the configuration above, I would expect “Virtual Door 1” to arm identically to “Virtual Motion” (armed only in Away and Vacation modes), and “Virtual Door 2” to never arm in any mode. But this is not the case.

This is reproducible as shown (tested on Edge), and applies to both this latest Beta build and the prior one. It looks like something changed between 5350 and these Betas.


yesterday I wanted to add my first zigbee device to VeraPlus v7.31 but nothing worked, Bitron video AV2010 / 25 in generic zigbee.
Are you having kind of problem with this version?

She looked for the device without finding it while the ezloplus found it without any problem …

I have 2 Securifi ZigBee sensors, which were working on my previous 7.31 Vera Plus. I could not get them to pair on new box, but have not investigated yet whether that was due to replacing the plus or upgrading to 7.32 open beta.

Vera hubs never worked properly with Zigbee devices, it was always hit and miss.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules