7.32 Vera Firmware - Beta Release

did this fix the google home issue?

Good question I’d forgot about this.

Can anyone confirm?

It wasn’t working last time I tried it, should test it again I guess.

I just updated my lab Vera Edge to version 1.7.5379.

However I cannot select / tick any devices from my Vera Edge to expose to Google Home because of this new problem here “You cannot select more than 300 devices”. I have 80 devices and scenes currently selected not 300 so its a bug.

Its one thing after another with Vera :angry:

And they still haven’t fixed the voice assistant portal pages as described here and here.

And on going issues with Alexa and “Device is unresponsive” here.

@melih who is in charge of the voice assistant portal web pages ? Things are very broken now !

I’ve deleted some devices off my lab Vera Edge to get me below this 300 “devices” limit bug.

I then tried to select just one device from my lab Vera Edge to expose that device to Google Home etc.

First attempt I got this after pressing the Save button


I then refreshed the web page and tried to save again and the second time it seemed to work.

I then asked Google Home to “update devices” and my new device from the Vera Edge was added in to the Google Home app.

I then found this “Test Bulb” in the Google Home app and it does seem to be working now, I can turn it on and off OK, either via the Google Home app or via a voice command.

It no longer says “Not Responding” for this device in the Google Home app like it did when I tested this previously on the last 7.32 firmware version.

So tentatively I am going to say they have fixed it.

However there remains many problems all round with voice assistants and Vera and Ezlo firmware hubs as I just stated in the post above and I don’t know about you guys but I am fed up with it.

Here is the Jira ticket for the voice assistants portal pages mess:


Can we have an update on this please ???

Another bug here for Ezlo hubs and Alexa, just tested it again and its still not fixed.

Jira ticket for it here:


1 Like

Is a third beta version available for trial at this time and is there a revised timeline for go-live at this time?

Thanks much


Would be nice to see some feedback from the project management team on the status of this release.

Agreed. It’s been stone silent around here lately.


Not any of the links to beta versions works. Is there any new versions in the horizon?

Are these links correct? I am trying to upgrade and I am getting the message Failed to download the Firmware Url!!! When testing the address it returns 404 Not Found.

Something tells me the entire staff of ezlo are on vacation… Zzzz

1 Like

I lodged a support ticket as suggested in another thread.

Support was unable to fix the issue via remote access, asked for a phone call to troubleshoot.

Never responded to first suggested time for the call.

Second time was agreed to, never called at agreed time.

I sent a follow up email, and find that the address I had previously been using to communicate with support now no longer exists (support@getvera.com)

Is their entire infrastructure down, or is this some sort of bizarre scam ??

Email address seems to work OK for me in terms of it sent me back an instant auto reply stating:

Your request (250100) has been received and is being reviewed by our support staff.

Did you get an error or bounce back message?

@Leonardo_Soto Please can you look at @gmsithsa support ticket.


It bounced (I tried twice):

Address not found

Your message wasn’t delivered to support@getvera.com because the address couldn’t be found, or is unable to receive mail.
The response was:

550 5.1.1 The email account that you tried to reach does not exist. Please try double-checking the recipient’s email address for typos or unnecessary spaces. Learn more at https://support.google.com/mail/?p=NoSuchUser p3sor577298plq.34 - gsmtp

Support ticket was 249392

Maybe there was a temporary mail server issue. I just emailed that same email address as I said and it worked for me just then.

I just checked ticket 249392 and it has been replied to this morning by Oscar. Please check your email’s inbox and spam folders. Apologies for the inconvenience.

We’ve released a new beta version.

UI7 - Vera Firmware Update (Open Beta 4)

Firmware versions:
Vera Edge: https://dl.mios.com/rl/732/mt7620a_Luup_ui7-1.7.5385-en-mios.squashfs
Vera Plus: https://dl.mios.com/rl/732/mt7621_Luup_ui7-1.7.5386-en-mios.squashfs
Vera Secure: https://dl.mios.com/rl/732/mt7621s_Luup_ui7-1.7.5387-en-mios.squashfs

Removed mios_fix_time script.


@edward Door sensors are still not honoring their ModeSettings value as previously described here: 7.32 Vera Firmware - Beta Release - #78 by rigpapa


I am having many problems of devices (mainly Fibaro door/window sensor FGW-002) becoming offline/online frequently. It seems that it could be one of the problems fixed by this beta version, is it?

But, at the same time I see that many other users are still having problems with this beta version, then my question is: If I upgraded to this new 7.32 beta version, using the backup procedures of course, in the case I would have new problems, would I be able to return to my current 7.31 version using the restore procedure?

My main current problem is that the sensor doesn’t report a door open/closed situation, I did an unpair in my VERA Edge controller, it did it, but when I tried to pair back it again, it gave the message “Successfully Exchanged Security Keys”, but later on it gave “Device failed ti configure” message and it stayed at “waiting for wakeup” and, even if I tried it to wakeup clicking its button, it didn’t.


Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules