7.32 Vera Firmware - Beta Release

I can confirm that on my Vera Edge running FW 7.32 where I exposed a single bulb device to Google Home.

I can now ask a Google Home speaker to turn that bulb on or off and it does work.

That is the extent of my testing.

Before this would not work as I previously reported.

This lends some credence to the theory that the Google Assistant problem stemmed from a backend server config and not Vera firmware per se. Which I take as a good sign.

Any other potential showstoppers out there to report, gents?

LOL, took me 9 days to figure out what “DPW” means… “Device pairing wizard”!!

Finally took the plunge upgrading from 7.31, and am happy to report a stable system thus far. More notably, 7.32 improved my Vera Plus’ “Available Memory” stat from 192k to 202k, which I consider a welcome improvement (since memory shortage is known to lead to restarts).

On the other hand, resting CPU usage seems to have increased significantly from around 0.06 to 0.20 and I’m at a loss to explain why or what Vera’s doing.

DAY TWO UPDATE: Happy to report that Vera has settled back down to her old nominal resting rate of 0.06 CPU usage, which is fine by me. Still maintaining a solid 201k of Memory Available, more than adequate for any purpose.

Any timeline for the final release?

Installed the beta fw. No problems so far.

VeraPlus bricked :confused:

Backed up, used firmware link from Sorin’s initial post and went through the usual process. 15 minutes later… countdown is at zero, but box is still inaccessible via web or ssh. Vera WiFi networks are both (2.5GHz & 5GHz) discoverable, but not connectable. Unplugged/replugged. Status light comes on; no other lights; then status blinks rapidly. It has been like that for a few hours now. Tried the factory-reset process (6 presses of reset in 6 seconds); no change. Called the support line and left a message. Hopefully I’ll get a call back soon :thinking:

EDIT: several hours later…
Well, no call back yet. Surprise, surprise.

But, the good news is, I no longer need it. VeraPlus is back online, running the beta firmware! Its all thanks to the information found here: Can the veraplus be UNBRICKED? - #25 by alangraph

A lucky escape, for sure!


Still a little bummed that there was no attempt to fix the “replace a faulty device” path, so that you can easily replace a device with a like device without doing ID rename gymnastics.

Has that ever worked?

Yes it was working just fine until it was broken 2-3 firmwares ago (it was broken with that big update that remapped the drive layout). Now when you try it, it just does a normal include.

1 Like

I just noticed an unexpected Administrator Account on my (7.32 beta) Vera Plus called ‘LinuxTest’ which I never knowingly created or authorized (edit: I authorized it for a different controller… see EDIT below).

Should I be worried? Does anyone else see the same thing under Settings > User and Account Info > Other Users? And is it safe to remove?

EDIT: Someone explained that this was a legit account created by ezlo staff while helping with a problem on a different controller (beta test ezlo Plus); it just happens to appear on all of my controllers due to how accounts are stored at the User Account level.

FYI, I don’t see that account on my Vera Plus (7.32).

1 Like

Turns out it was related to an admin account created by ezlo staff on an entirely different controller (beta testing ezlo Plus unit). I had not realized that these User Accounts would appear on every controller, and only then because they get created at the “account” level rather than the “controller” level.


still waiting for an answer or plan to plublish…


sorry, but very dissapointed after years of use - no answer at all to my question. Still testing the 7.32 on 1 VERA Plus - no problems. I have 3 other PLUS and wait for some sort of roadmap for roll out.

1 Like

The link in the first post is not longer valid:

I found a new link - maybe the fw is released now?


1 Like

Curious to know how you “found” such a link? lol
I’ve gotta say 7.32 (beta) has been rock solid for me this past month, so I’ll happily jump on board the official release.

Once @Oscar.Morales , @Sorin et al say it’s official. :slight_smile:

As I discovered the broken beta link, I just followed the logic from previous official fw links and it works…
7.32 is installed on 2 machines without problems. Even when you reset to factory settings, the 7.32 is installed.


The links for the download at the top don’t work
i.e. [broken link removed]

I’ve asked the team. A new set of builds are coming this week.


We’ve released a new beta version.

UI7 - Vera Firmware Update (Open Beta 2)

Firmware versions:
VeraEdge: [deprecated link]
VeraPlus: [deprecated link]
VeraSecure: [deprecated link]


  1. Fixed the issue with broken schedule after editing a scene based on “After/Before Sunrise/Sunset”
  2. Fixed the issues with empty device pairing wizards for Honeywell T6 Pro Thermostat, RCS Technology Thermostat TBZ500 Lux Thermostat KONOse and Lux Thermostat KONOzw
  3. Fixed the issues about negative values in “Device Options” not being displayed correctly. Negative values can be set from “Advanced”->“Variables”->“VariablesSet” but there is still an known issue about not being able to set it from “Device Options”.