7.32 Vera Firmware - Beta Release

We are thinking about continuing to do updates on Vera Firmware so that there will be a path to upgrade to new Ezlo platform.

The context is to create a path for upgrading to newer EZLO hardware.


The latest Beta FW should be supported the Fibaro Walli Switch FGWDSEU-221 (see the improvement list : Added DPW to DB for Fibaro Walli Switch FGWDSEU-221). The Device could be paired and also controlled via GUI. If I press the manually the first Button (Child E1) on the switch (in the wall), the switch status in the GUI is updated immeiatedly, so as expected. If I press the 2nd Button manually on the switch in the wall, the switch status in the GUI is follwing the real state only after the Deviced was polled.
Is this switch is only implemented as 50? I’ll believe, from what does I’ve read, that there is an issue with the association groups. But uncomfortable I’ve no idea to fix this one by hand.

This 7.32 beta 4 has made my Sensative Strips Drip completely unusable. After the upgrade I noticed it was the one device that didn’t look right - it was waiting for wake-up to configure, and I am pretty sure it was assigned a different device ID during the upgrade. Upon wake-up it not only completely reconfigures itself, it gets added as a new device. So after trying the process that allowed the Strips Drip to work great under 7.30 and previous versions several times, I ended up with it being named “Pet Fountain Leak 1 1 1 1” - the 1 added each time it reconfigured and re-added itself. On my final attempt I added the configuration options before I changed the device type and files, it all looked good - and then upon a Vera reload it was back to waiting for wake-up to blow away everything I had done.

Now I risk hardwood floor damage, but hopefully the Mongoose upgrade was worth going to the final code version.

That might just be the best decision you’ll ever make in tempting the remaining die-hard Vera lovers like me (along with your other MIOS customers) make the switch over to Ezlo at a later date…:wink:


That would be great but too late for me, for example, I’m now deep into Hubitat. I waited for a few months for any definitive news for a migration path to no avail, the Vera app and sluggishness and overall unreliability and associated reduced WAF was killing me.

There’s just these two last Fibaro Switch 2s that stubbornly refuse to let themselves be reset to be included in Hubitat. Think I will get rid of them… Never liked them anyway.


I hope so! I’ve really, really had enough of my Vera and wouldn’t mind upgrading to an Ezlo device, but I really don’t want to have to set up my entire network from scratch.


+1 for an easy upgrade path for vera to ezlo. I have been a vera user for about 10 years , upgraded from vera 2 to vera 3 to vera plus and do not want to have to repair all my inwall/inceiling zwave devices


How do you like the Hubitat system so far?

I have a problem with my vera plus.
All my devices is gone and the dayly backup does not bring them back, so I asked suport for help.
I had a internet breakdown at that time.
Suport seems not to understand the problem.
Or maybe does not care ??
Sory, suport has always been great.
Is suport closing ?

As ezlo is not in Europe I think I will go to Fibaro and wait to see what Ezlo will come up with in Europe some day.

we start shipping in June hopefully.

Hi, Melih, this could be good news for some people, BUT, is there any answer regarding the responsiveness (or not the usual responsiveness they used to have) of support related to the “traditional” Vera controllers?

I have to jump in here and share that sadly support seems to have dropped off a cliff…

I’ve had to re-enable remote access multiple times due to how long it has taken the team to get to my ticket; access has expired again :frowning: ………


Sorry for the long delay in my reply - the cams are h.264.

And you are using the correct rtsp URL for the cams? Test it in VLC first by trying to play a network stream and enter the URL etc. If it works in VLC then you know you have the right URL.

Then in Vidoo add the camera, you need to omit the rtsp:// part of the URL however in the Vidoo dialogue box.

Please - make the Schlage lock fix a priority. I have literally been waiting years for this fix.

-Issue with being unable to set weekly restrictions on Schlage BE469ZP and BE468ZP locks

1 Like

Continuing my push for Vera to be recognised as a ‘Community Edition’ :slight_smile:

I recall seeing it mentioned somewhere on this forum that you can modify KitDevice and KitDevice_Variable files as you like to support new z-wave products.

I’ve never looked at it myself, plus after a firmware upgrade both would be replaced with the ones generated from their system/database. (although that’s perhaps no longer an issue with Vera, if support/firmware updates have finished)

Update: Found it…

Found it in /www/cmh/kit - I’ve spun off a focussed thread on this to have a look - KitDevice.json and KitDevice_Variable.json

Reading through this entire thing (which was not only time consuming but frustrating). Frustrating because this firmware seems all but abandoned, though it seems more like the hardware is abandoned. I tried the Linux upgrade (had to work with support because it had some issues allowing me to use the device) but then was recommended I downgrade as they are no longer going to support the ezlo software on vera hardware. But then they wont support the vera hardware with its own firmware so kind of stuck.

More disappointing is nothing in this thread mentions any remediation for the use of Adobe Flash in the UI. I get the focus has been on the mobile app which is the same for both brands of devices, but this can be a real issue. Cameras and Energy monitoring (the terrible ERGY app which hasn’t worked right in years) both use flash, which frankly isn’t an option anymore. The Ezlo devices have an energy display in the mobile app but Vera devices don’t, and the vera devices don’t have a replacement option for one that was abandoned years ago and now can’t even load. While Ezlo could redirect vera devices to the same energy reporting as their own devices, they choose the ez-low-blow and have done nothing, as typical it seems. I guess at least cameras work in the mobile app. I could re-upgrade to the not supported linux upgrade where I would then have no web interface as they are not going to support vera hardware with it, at least then I would have some energy reporting, but managing every device from the phone kind of is a pain and not fun to type in. Maybe if they added Vera Mobile to the Amazon app store, I could use the Android subsystem for windows to do more advanced or complicated configurations using a full keyboard, but still not ideal. Not to mention they are saying devices will never move correctly during the upgrade and restores will only work with newer firmware’s that the vera hardware will never get. So I would need another gateway/hub to join and promote to primary, then upgrade and connect and make secondary, but if I am going to do that I might as well do a hardware and software upgrade to another company given how badly I have been supported both before and after the company was sold. (sorry rant over.)

Fact is we need a stable firmware, which we haven’t had since UI7 came out. And we need to be able to use the functions we were sold (not even new ones though that would be nice) that doesn’t require me to run an outdated Windows VM with an old web browser using flash.


Hi I am still using the old VERA Plus and it is solid pretty much. Any chance for the FW final release?

Lots of reported fixes that it just doesn’t seem like Vera users are going to get. It’s been 18 months since the links were posted for the Beta release.


Dont expect any official response to this thread there has been none only Tumbleweeds…