7.0.21 Broke Alexa's "Turn On" Command

With version 7.0.20 everything was working perfectly. Then my Vera Plus updated to version 7.0.21. Now the Vera Alexa Skill is broken, the “Turn On” command to be precise. “Turn Off” works just fine. What good is being able to turn something off, if you can’t turn it on in the first place?

But, it gets even more curious… curiouser and curiouser… “Turn On” seems to work for dimmer switches only, but it turns them on at there lowest power setting. Lights are very dim and fans are very slow.

Hopefully the Vera Alexa Skill team gets this fixed soon, or I might have to get off the couch to turn on the lights. Has anyone else experienced this?

Consider yourself lucky, it looks like I have lost everything on my system except for Z wave devices. Scenes, plegs , apps gone.

I restored a backup and got almost averything back. My 3 way switches no longer work, the associations are still there they just don’t do anything. I deleted and paired one and it started working but what a hassle. The update also created an array of ghost devices.

What is at version 7 anything? I am trying to figure out how to get Alexa to work with Vera and I can’t get anything to work. Am I missing a secret plugin or something???

@mlurie, I am having the exact same issue, even went back to the backup i made previous to the upgrade and it still doesn’t work.

Same here/ I finally got my missing scenes back but now they won’t turn on.
To make matters worse my vera failed the upgrade and it sitting at a blinking green/red led. :frowning: I can’t even SSH into it…

Same here too. I found that the ‘generic on/off devices’ I.e devices created by plugins don’t work either.

so odd that some people have issues when others don’t.
i did the upgrade this evening. no issues. and my “turn on” with alexa still works fine.

Received a message today that the new Vera - Alexa Beta 7.0.21 version was available so I upgraded. I have been using Vera - Alexa successfully for several months but since I installed 7.0.21, I have run into a significant problem.

As succinctly as possible here is my problem: Asking Alexa to turn on devices which do not have an associated dimmer no longer works, AND with devices which do have a dimmer while the command “Alexa turn on yyy” does not work, the statement “Alexa Set yyy to 40%” works fine. Unfortunately the statement “Alexa Set XXX [the non dimmable device] to 100%” is met with the response “XXX doesn’t support that”.

Here is an example: I have a lamp called “Pewter” - it is plugged into a simple zwave on/off outlet (or a ZWave screw-in on/off receptacle). “Pewter” is also included in a scene which I call “Normal” with several other devices. If I say “Alexa, turn on Normal” it works perfectly and all devices, including “Pewter” turn on fine - as does the scene to turn off all of these devices. SO SCENES WORK FINE. Even when I want to turn off that single device called “Pewter”, I can say “Alexa, Turn OFF Pewter” and THAT WORKS FINE. What does not work is if I say “Alexa Turn ON Pewter” - and even though she says “OK”, the lamp remains off. Note that I can still control “Pewter” both on and off, with the Vera App as well as with logging on to the website = and “Pewter” still turns on when the device is activated independently in a preprogrammed scene.

I have logged into Alexa and under the smart home tab, have disabled Vera, and removed all of the scenes and devices I then re-enabled and re-discovered all devices and scenes - but still no success. I called Amazon and spoke with an Alexa rep and they pointed me to Mi Casa Verde - I called support there - waiting for a call back …

Will let you know the progress …

UPDATE: ALL FIXED - see my post below.

Same issue here. Dimmers/Fans work to lowest setting. Can adjust by saying “set to 100%”. No “on” command works, “off” works fine.


For the guys having problems with the turn on command (especially for dimmers): could you please try to trigger a manual upgrade for the “Alexa helper” plugin?

Steps to do that are:
Apps → My Apps → Alexa Helper → Update App

It seems that due to the high load, most plugin updates was not done on time and this causes the “1%” problem.
As Vera now supports setting dimmers to the previous level of the device, the plugin should have been updated, as this is a backwards compatibility limitation.
E.g. I set the a bulb to 70%, turn off, then on turn on, the light will go to the last value (e.g. 70% in this case) instead of going to full brightness.
The plugin is also set to update itself based on a 24h check, but updating it manually should speed up the process.

@BOFH - really sorry to hear about your issue (also btw - we really appreciate your contribution on the forum)
Saw that you have issues with your Vera3 - this might sound like a generic message, but please contact support, the guys might be able to help you.
Also the migration to another vera controller can be done via a z-wave backup - that might save a lot of time for you.

I had the “turn on” problem after the upgrade also.

Doing the manual upgrade as suggested seems to have cured the problem. More testing today.



That worked for me. Thanks!

One question, with this update will I be able to “dimm” my window covering devices?

I know that the keywords open and close are not available for the plug-in but couldn’t it be done with the Set command? something like, set kitchen window to 20%

I noticed the app version was depreciated. I updated it and will verify that it works when I get home. But I expect, given the success of the others, that this will fix the problem.

I’ve been so happy with Vera/Alexa and this weekend we were having company (read: tons of grandchildren) come to visit. The anticipation of their excitement at seeing everything working was only dampened by the specter of its not working properly. Thank you MCV for your instructions they were spot on. The manual update worked like a charm!!

Worked for me too. Thanks!

Related to the dimming command.
Currently this is what we support:

The Smart Home Skill API currently supports lights, switches, smart plugs and thermostats, including turning devices on and off, dimming lights, and thermostat controls. Today, you can: Turn your devices on or off: ?Alexa, turn on/off the kitchen light.? or ?Alexa, turn on/off the heat.? Turn your scenes on: "Alexa, turn on Good Night." Brighten or dim your lights: ?Alexa, brighten the kitchen light.? or ?Alexa, dim the kitchen light.? Set lights or temperature: ?Alexa, set the kitchen light to 50%.? or ?Alexa, set the heat to 72 degrees.? Increase or decrease temperature on thermostats: "Alexa, increase Living Room Thermostat by 5 degrees.? or ?Alexa, decrease Living Room Thermostat by 5 degrees.? Ask the status of a thermostat to find out the current temperature: "Alexa, what is Thermostat?s temperature?", or ask what the Mode and Setpoint is set to: "Alexa, what is Office Thermostat set to?" Ask the status of your devices: "Alexa, is the door locked?" Lock your door (due to security reasons you can only Lock, but you cannot UNLock a door): "Alexa, lock the door"
Reference from http://support.getvera.com/customer/portal/articles/2648086

So, currently no, we don’t support it, that was obvious, but we cannot implement it easily either.
Why? Basically Amazon is really quite strict with what we add, it wants everything to act in very, very specific ways - and we are trying to get the app certified and into the store.
While I’m sure that you’ve already considered this, I recommend you to use scenes for some predefined values for now (off/25/50/75) (again, I understand that this is not (at all) ideal).

I noticed my door lock now shows up as a device. Nice to be able to check the status and lock it. I’m vary happy Alexa can’t unlock it.

Thanks Vera for the quick resolution. Updating the helper app worked for me too. Also, I appreciate the email notification as many folks don’t actively check the boards

Yesterday I manually updated the app on the vera per the instructions and last night it still didn’t work. I also noticed that I now have two skills on my alexa app for vera. One says beta and the other doesn’t. Should I disable the beta?

OK, so now I can’t say Alexa turn on xxx any more and expect it to turn on full. It turns on to the last setting. To me, not intuitive, but that is the way it is.

So, what is the easiest way to say 100% in the quickest and easiest way. I tried Alexa turn on xxx full, but that did not work.

I understand that I could write a scene to do it, but I don’t want to have to write a scene for every light.

What is the easiest way to say “turn on 100%”?

Thank you, Bob