[14]: Startup Lua Failed

Hi guys,

When I log in to the dashboard I receive an error “[14]: Startup Lua Failed”. See attached screenshot. Anyone got a clue what it can be or where to check?

Try unplugging Vera and letting her reboot.

What were you doing before this happened? What firmware are you running?

I have seen similiar problems in earlier versions of Vera, which were caused by syntax errors in the LUA code. It seems that syntax errors will prevent LUA from loading.

Check for syntax errors, especially in code recently added.

I have UI4 and firmware version 1.1.1047. A reboot didn’t make any different.

I have not make any changes in the LUA code, not what I’m aware of. Don’t actually know anything about LUA/luup. Is there a log or something to check for errors?

I have just submitted a ticket for the same message. However, I got it overnight as a consequence of Vera spontaneously rebooting.

No syntax errors reported on earlier code changes. Everything was running normally up to the reboot.

What’s really weird is that when I clicked “Go” from the Edit Startup Lua tab and then saved it booted OK. It’s been up for 12 hours now with no problems.

It’s likely an issue, but just for grins try this: Click on the MIOS developers icon and select the Edit Startup Lua. If you’ve made no customizations for start up then the code area should be blank. Add one line of code:

return true

click the Go button, close the window out, click “Save” (under the clock) and see if the same issue occurs.

If you do have code in the Startup Lua then you have a programming error. If you are not up for debugging it, I suggest posting whatever is in the Startup Lua and let others help debug it for you.

By default, empty code areas as well as code with no return statement are supposed to return true; however, I’ve found that doesn’t always seem to be the case (not sure if its something I did wrong or not).

I didn’t had any code there. Tried to enter just one line (return true) as Guard described but still no luck. Should I send a ticket or is there anything I can check before? Really appreciate your help here!

Some suggestions:

[ul][li]Check all Luup windows for syntactically incorrect Lua code (scene → ‘Luup’, scene → ‘Events’ tab → ‘Luup events’). Post the code to the forum or use Web Lua to check the code for syntax errors.[/li]

[li]Open a support ticket.[/li]

[li]Add a feature request to http://bugs.micasaverde.com: Vera should tell the user where the problem is …[/li][/ul]

Just wanted to add to this post that I had the same error message this morning for two of my devices, both of which share the same D_xml, I_xml, L_Lua & S_xml files. (BTW - which were the latest Sonos PlugIn files I had been using and tested successfully the night before)

What i did (if it helps anyone else is) I reloaded an earlier version of these same files and it looks to have gone away. I then re-uploaded the original ones and it seems to be working ok now.

I’m running UI5

Seems I spoke too soon :frowning:

it seems the “startup lua failed” seen against my recently updated Sonos devices has returned again, I can except a blip that is resolved but this is becoming too frequent for my liking. I’ve tried the following.

A Reboot via the UI
A Restart Of Luup via the UI
A Reload via the UI
Browser refresh via the UI

Does anyone know how I can find out exactly what has failed and why?

Going back to any earlier version of the plugin seems to fix it, so does this suggest the associated new Lua file is at fault?

Found it ! It seems the IP address of the Sonos had changed, updating the device config the error stops. Why such a simple thing could not be made more obvious to a novice is dissapointing - hence I am updating this thread again just incase someone finds this of help too.