0 good routes out of 0


I little bit of a newbie when it comes to faults and anything out of the ordinary so was looking for some help.

Everything has been working fine on my veralite but all of a sudden things aren’t behaving as they should. when i do a heal process i get 0 good routs out of 0 for everything. the last report i got had no stars for any of points like they all had rubbish signals but it was OK and as i said nothing has changed. Any suggestions would be welcome



0 routes for all devices? That doesn’t sound good. I’m just shooting in the dark here, but it sounds like a hardware problem. Possibly the Z-wave antenna or Z-wave chip?

Sorry, I know that’s not much help.

Thanks for the reply, I had wondered the same but it will still turn things on and off??

Restoring from backup with the restore with Z-Wave option often fixes this type of a problem.

But it assumes you made a Z-Wave backup of your current Z-Wave setup.
Don’t do it unless you have made a Z-Wave backup before the problem started.
If you have not explicitly made a Z-Wave backup then a MCV ticket may be in order.

In the future … create a Z-Wave backup 1 day after adding any new device.
Enough time for the Z-Wave network to stabilize with the addition of the new device to the mesh network.

Has anyone been successful at automatically performing a backup and sending it (with scp?) to a local server?

Backups are done automatically every night (Not a Z-wave backup) by default.

You can also initiate a backup as follows:


This URL will return a newly created backup file.

Thanks @RTS

As I have a CIFS support set up on Vera, would you be able to help me with the code that could be set up to run the back up and move/copy the files over to a mapped/share - called /nas/ ?

You can use wget/curl from a PC, RasPi, Linux box or Vera itself to get the file and put it on your storage server.

Unfortunately, I have this problem too. But everything seems to work ok, so I have ignored it. As a result, I don’t really know when it started.

Despite the messages and the 0 stars, things work as if routing is still taking place. My front porch light, when first installed, was barely within range of the vera. Remotely turning it on and off was very spotty. Shortly afterwards I installed a deadbolt and a floor lamp module. Operation of these devices became very reliable. Now that I have the “0 good routes out of 0” messages, I would think it would go back to spotty operation, but all these devices still operate perfectly fine. So routing seems to still be taking place.

Ok, so first of all I turned off Vera routing. Saved. Then I went through and opened the devices and clicked “Update neighbor nodes” under Device Options. Still no love. Then I went and did a z-wave repair for each node 1 at a time. Suddenly I started getting stars. This worked well for everything except my deadbolt. I guess technically it worked for that too, but it caused other problems. I am now getting “Failed at: Getting secure classes” and it only has 2 stars.

My battery powered door sensor is the last one to configure. It takes a while to wake up, so no data on that one. Otherwise, this method seems to get the stars to re-appear, but may cause problems for deadbolts.

Edit: So this only fixed the displaying of stars. I still get “0 good routes out of 0” and now my deadbolt doesn’t work :). So I do not recommend doing this if you are having this problem… learn from my mistakes!

Is it possible that this message is because all of these devices have a strong signal point to point with the vera? Also I noticed that as it is doing a repair, the devices will say “Configuring node 11” on the device that is node 10, etc. It is fairly consistent that all the nodes report a node number that doesn’t match their own. Maybe this is what it is supposed to look like? Or maybe its a clue as to the problem?

I see the same when I try a repair. 0 good routes out of 0. and all my stars are white so I assume that means no stars.

It sound like this is not normal. Things seem to be working for the most part though.

[quote=“rinconmike, post:11, topic:180147”]I see the same when I try a repair. 0 good routes out of 0. and all my stars are white so I assume that means no stars.

It sound like this is not normal. Things seem to be working for the most part though.[/quote]

Hi –

Sorry to break the news but this is normal. The only way I have been able to get the “strength” of the connection (e.g., stars) is to reconfigure the node. Doing z-wave repairs has worked fine, although I also get 0 good routes out of 0 as I do the repair. You can go to settings to see how many neighbors you have for routing.