Yale Lock Pin Codes Not Reporting

I want to be able to trigger a scene when my Yale lock is opened by pin code(Pin Code is entered event). It lets me add all of the pertinent information and every thing appears fine, but when the pin is entered the trigger is not receiving the notification that the pin was entered and the lock was unlocked. I tried some different events in the trigger that are available for the lock and the only one that seems to work is the one that notifies that the door lock status is changed (either to lock or to unlock, unfortunately the same event for both and it is activated twice). Has anyone seen this before and figured out a fix? I am running the latest firmware 1.5.622.

Have you tried to set a notification (outside of creating a trigger) to see if you get the notification when code is entered (and/or setup a notification if a bad code is entered)? This may help debugging the problem. If you get the notification then there may be something wrong with how you built the trigger. If you do not get it, then the issue would be what you suspect - Vera is not getting the notification from the lock. I have a Schlage lock so I am not going to be any help there other than to confirm that the feature does work from Vera’s standpoint (currently working with my lock).

I added the notification directly on the Pin number. When my wife get s home she will trigger it. (I’m at work now) Has anyone else had issues with the Yale Lock not seeing Pin Events? I really like this lock and I was thinking about getting a second one, but I will not if I can’t get this to work.

Mine has worked ok. I’ve got notifications tied to several of the pin codes I use. I have received all the notifications aok.

Does anyone think that deleting the lock and re-adding it will help?

is there a large distance between your vera and the lock? if so, Can you temporarily move them closer together and try testing the notifications?

My door lock has the exact same issue on this firmware…excluding and really including did not resolve the issue…and the lock was within a metre of my vera3

What model lock do you have? And what firmware is your vera on?

I have the touch screen lever lock. I am on firmware 1.5.622

I have a keypad Yale Real Living Deadbolt. I did get it working tonight. First I excluded/deleted the unit from my Vera 3. I then followed the instructions for a full factory reset on the Yale lock. Take out the batteries and remove the unit from the door to access the reset button. Hold the button in as you put in the batteries. Remove the batteries again and remount the unit, put batteries back in. I then moved my Vera to right by the door and hit the include button on the front. Then entered the code on the keypad to set the lock in include mode (use default Master pin: 12345678#, 7# 1#). It then shows up and every feature was working. I did a quick test with a trigger for the master code and it worked. Now after a bunch of programming of scenes and such it does exactly what I want. I did manually change the master pin using the built in instructions for the lock and the keypad. All of the other pins were then added back in using the Vera UI. What I think was different was when I first got the lock I added a bunch of pin codes before including the lock and also changed the master pin. THese codes showed in the UI, but never worked properly.I did not do that this time and believe it made all the difference.

Glad you got it working. When I spoke to Yale and to MCV, there seemed to be a consensus to have the network module in and other than setting the master pin, do everything else after the lock is joined to the network and initially configured via Vera. I should have mentioned that, but did not recall it until you detailed what you did. Just glad it’s working for you:-)


Have you had any issues with this lock since you got it working? I recently bought this lock and I’m experiencing the same problem you were where the PINs were not showing in the notifications and so I can’t create triggers/scenes. I had the lock working besides that part and I was able to save PINs to the device with no issues (and they were working). I originally set up the lock by only adding the master code then adding it to the Vera3.

I tried the instructions you posted that resolved the issue for you (thanks by the way) but even though I did it a couple of times I was never able to get the PINs to show. To top it off I have some how managed to make it so I can’t even add the lock to my Vera3. Just wondering if you or anyone else had any advise for me to try.



Ok, this is embarrassing but I thought I’d post my solution anyway… in case someone can’t read like me. So it turns out my ultimate problem for not getting the PIN notifications to work was because I was entering the PIN in the “What PIN code INDEX number?” field instead of the INDEX. Yes, I know, it’s in all caps. As soon as I entered 1 instead of the PIN the notifications worked like a charm.

I too have the Yale Real Living deadbolt. But your procedure doesn’t work for me. I successfully excluded the deadbolt using the Vera3. I successfully did a factory reset of the deadbolt. I held the Vera3 in battery mode a few inches next to the deadbolt and pressed the z-wave button so that it flashed.

However, after the factor reset, I have no option to use default master PIN 12345678#. Instead, the deadbolt immediately prompts me to set a master PIN, which I then do, as I must. After that, I enter my master PIN followed by 7#1# and the deadbolt says that it successfully enters the network.

Unfortunately, the deadbolt didn’t successfully enter the network. When I hook the Vera3 back up to the LAN, I cannot find the lock in UI5. I have to do the remote high power inclusion process (7#1# again on the lock). Then it is included and programmable through UI5.

However, there is no change in the failure of notifications to issue. Just as before, the only notifications the Vera3 sends regarding the deadbolt are the failure to operate notifications.

Anyone have any other suggestions?

Wondering if you got this fixed? I am having the same issue; did a full reset and was immediately prompted to enter new master code. Included in the network and waited till it was set to add new codes but still not getting notification working. I did, however, have it work the first time I put a code in, but then it didn’t work after that. I am on veralite UI5. Hoping there is a fix for this - would like to get pin code verification!