Won't recognise USB Stick to setup :(

I’ve read through a few other posts mentioning USB issues but I don’t seem to be able to find anything that fixes my issue.

I installed Datamine 2 on my Vera Plus and when I open the UI, it wants me to select a USB but nothing shows.

When I look at statistics is says that there is a storage area (or at least I think it does)

Disk Space Total (kb)9472
Disk Space Used (kb)6244
Disk Space Free (kb)322866

I assume the above is actually internal memory or something.

The USB stick is a simple 4GB stick formatted to Fat32 in a windows machine. If I enable Vera lopggin it find the stick and enables logging, so I know the stick works, I then disabled logging, manually formatted the stick again and tried once more. Still no joy getting datamine2 to see the USB.

Are there any tips for getting the USB recognised? I tried filling in /dev/sda1 in advance variables and also set SetManualMount to 1, when I do that the error goes away but I don’t know if that is working or not? I don;t see any data and the stats for disk space don’t change so I’m a little confused.

Any help would be very much appreciated!


Here’s my log in case it’s of any use

1004/27/16 10:48:04.133XXX-UpdateSystemMessagesTasks StartupTask #11 = 4 OK / dataMine 2 graphing and logging plugin[210] <0x76db2520>
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/mtdblock10 on /storage type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-firmware type jffs2 (rw,relatime)
/dev/mtdblock10 on /etc/cmh-backup type jffs2 (rw,relatime)
/dev/mtdblock9 on /mios type squashfs (ro,relatime)
SetMountUUID    -
SetMountPoint   -
SetManualMount  -0

SetDataDirectory /dataMine/

SetMountUUID (create the name of USB , when formatting.Then type it manually here)

SetMountPoint dev/sda1

That what i did,
hope it helps…

Unfortunately, there are a few boxes out there (notably VeraEdge) which do not support some needed commands for the USB mounting to work as intended. You can tell that this is the case with your box as sections 2 and 4 of your debug output are empty.

To overcome this you need to do a manual mount by setting SetMountPoint to /dev/sda1. Note the slash at the beginning. When doing a manual mount there is no need to put anything in SetMountUUID.

Usually, I would say that you also need to set SetManualMount to 1 for a manual mount to work, but there is a bug in that part of the code which is fixed in the next release, so keep that to 0 for now.