Will Vera work with a z-troller?

The RF range on my Vera 3 is much worse than on my Vera 1 (which is presently “upgraded” with a z-stick v2 plugged into it).

I’m confident that the RF on a z-troller would have much better range than my Vera 3 has.

Will a z-troller work (via an RS232 to FTDI USB adapter) as a primary interface if I were to plug it into one of the USB ports on the Vera 3? Would I need to first disable the z-wave built into the Vera 3 to accomplish that? Would I need to do anything else to get the z-troller to work on a Vera 3?

Has anyone ever gotten a z-troller to work with a Vera 3? Has anyone even tried?

Before going that route, try searching for the antenna modification thread.

Vera3/Lite models can have this done and greatly improve range/consistency over the internal antenna.

Good idea. Before attempting an antenna mod, however, I would still like to know whether a z-troller would be a fallback option.

Would I need a special driver loaded into Vera to get the USB-to-serial interface to work? Or, since it’s FTDI based, maybe I don’t. In the PC world, FTDI seems to be the gold standard for USB. I have no idea what kind of USB driver is already in Vera (does anybody know or could possibly point me to which Linux directory in Vera would have Vera’s USB driver?), but if I did know, it would be easy enough to buy a USB-to-serial converter that’s compatible with the USB driver Vera already has. From there, I expect the z-troller setup would possibly work.

Vera supports a bunch of standard USB-Serial devices, the most common being FTDI and PL2303. There’s a list on the wiki of the ones the folks here have tested and found to work (they tend to be the single port ones)

Folks have also used alternative ZWave dongles on Vera, the type that directly attach to the USB port (like the Aeon ones). I haven’t specifically seen anyone try this with a ZTroller though, so you’d to try that out.

The list I was referring to is here:

I just now tried using a z-troller with a “Vera 1” in place of a z-stick. The Vera 1 doesn’t recognize it.

When folks have used “alternative” Z-Wave sticks, they’ve also had to reconfigure Vera away from the Default “/dev/ttyS0” that it would normally use to chat with the ZWave module.

There’s a UI for changing this on a Vera3 unit that you’ll need to change (assuming the Troller speaks the same language)

/Setup/Z-Wave Settings/Options
[tt] Port [/dev/ttyS0][/tt]

Thanks for pointing that out.

However, change it to what? /dev/ttyusb0?

On the Vera 3, is ttyusb0 the upper USB port and ttyusb1 the lower USB port, or is it visa versa?

OK, from what I’ve read, ttyusb0 is the lower USB port.

I would guess that on a VeraLite, since there is just one USB port, it’s ttyusb0 and not ttyusb1?

[quote=“neverdie”]OK, from what I’ve read, ttyusb0 is the lower USB port.

I would guess that on a VeraLite, since there is just one USB port, it’s ttyusb0 and not ttyusb1?[/quote]
See details here

OK, I was able to get a Vera 3 to use a z-stick v2 in the upper USB port (which, for the record, is /dev/ttyUSB0).

However, if I remove the z-stick and insert a z-troller through a usb-to-serial cable, I get an error message that the “LUUP engine is taking longer to reload.” The two options are “try again” or “reboot”. Regardless of which I choose, I ultimately get the same error message about the LUUP engine taking longer to reload.

Any suggestions on what to try next?

Unless there is something very specific you want from the ZTroller, adding an external antenna will go a LONG way to improving typical ZWave connectivity.

I have a larger (12-13" long) antenna out the back of my Vera 3. It’s ugly, but now many more devices are reachable, and respond quickly (I have a tight mesh, and there were still issues)