WDHA-12 and IU7

Other posts on this device seemed pretty old and pre-UI7. I’ve followed the directions several others have posted on older UI versions, and I haven’t been able to get this thing to work.

I get it paired with the Vera OK. I created a new device on Vera, pressed the copy then scene 1 buttons on the device until a new node was created by Vera. I created a new Vera scene, and set up the trigger to be the scene activation from button 1 on the device. But the scene never gets initiated upon button press.

Anyone have this thing working on UI7 and have any hints?

I’m in pretty much the same boat. I had this working perfectly for about six months. Then I upgraded the vera to the latest firmware and haven’t been able to get it working since. I’ve tried the same steps I followed previously and had no luck. I’ve also reset the WDHA to factory defaults. It adds but then is unable to confirm security and unable to transfer any scenes. >:(

I’ve had the same problems trying to get WDHA-12 to work with Vera3/UI7 (latest firmware). I’m able to INCLUDE the scene controller, but nothing works after that.

I opened up a support case with Vera Support team. After some troubleshooting, they confirmed that the Vera is not receiving any information when buttons are being pressed on WDHA-12. They forwarded my issue to development team who might include a fix in a later firmware version.

I encourage you to also open a support case if you have WDHA-12 / UI7. More noise from the customer base will drive a greater priority to eventually seeing a fix.



Were you able to resolve? Seems I have a similar issue.


This is still unresolved and I inquired about it in January. Not cool that it works fine in UI5 but doesn’t work at all in UI7. I miss mine a lot and have been patiently waiting. I hear the same thing, that the development team is looking into it and it may be included in a future release.

Bummer - I just got one figuring I’d give it a shot and same result - I can pair it, setup a scene, but the buttons don’t seem to do anything. I’d really like to replicate what I used to have setup with X10 lighting control via HomeLink on my Zwave network…