VRCPG primary + Vera secondary

Hi. I am having problems resetting my network.
I basically was running Vera as secondary to my Leviton VRCPG.
I recently updated the firmware on the VRCPG and reset my entire system to factory defaults.
Using the Vizia RF+ installer tool, and the VRCPG, I rebuilt my system (about 31(total) dimmers, switches, a lamp module, a receptacle and a few 4-zone controller) ((PS: thanks TimAlls for the installer tool tip, naming dimmers with the remote is a PITA).

I upgraded my Vera 2 to UI5 and 3.2 as well. Then I included my Kwikset door lock (since I can’t do this on the VRCPG).
Hopefully it will work.

The problem I am having in copying my data to Vera 2 from VRCPG to make vera a secondary. I want to do this so my iphone remote app will work.

I followed these instructions from the Wiki:

[i]"How to make Vera the secondary controller to Leviton Vizia RF+ (VRCPG)?

To do this you will need to follow these steps:

  1. First you will need to change the Z-Wave firmware to 2.78:
    Setup -> Z-Wave Settings -> Options -> uncheck the option ‘Use Z-Wave version 3.20 instead of 2.78’ and Save.
  2. After you check that the version is 2.78 and not 3.20, you will need to change the Vera unit to be secondary. To do this bring the Leviton controller near the Vera unit, less than 5 feet and on the Vera unit go to:
    Setup -> Z-Wave Settings -> Advanced -> click Go next to ‘Copy Z-Wave network from a master controller’
  3. Then, on the remote controller you must go to:
    ‘Menu - System Setup - Advanced - Yes - Network - Primary utils - Send primary data’
    When the Vera unit is secondary, you will need to go to:
    Setup -> Z-Wave Settings -> Options -> uncheck the options ‘By default Vera should automatically configure devices’ and ‘Use Vera routing instead of Z-Wave (requires 4.5)’."[/i]

(incidently, I tried a go at in in 3.2 first without any luck before downgrading to 2.78)

It basically times out without capturing any information.
Ive powered vera down and back up several times without success.

I read somewhere that I may need to include my Vera 2 as a controller in the VRCPG. I can’t find out how to do this.
I don’t know how to put Vera in programming mode to include it.

These are my current z-wave settings:

Version 2.78 L:1
Suc SIS:YES PRI:YES

Any help would be much appreciated. :-[

Instead of doing [tt]Send Data[/tt] on the VRCPG, do a regular [tt]Include Node[/tt].

(Vera 2 @ 1.5.346, Z-Wave 2.78)

What button do I push on vera 2 or what do I in UI5to “include node”?
Sorry, I don’t understand.
I’ve tried to “Copy Z-Wave network from a master controller” in UI5 and “include node” on VRCPG without success.

I’m confused ???

currently both devices are Primary, which may be the issue…I don’t know.
I guess I could try to make the VRCPG a secondary in the Vera or shift primary to Vera, but this would erase all my data in the VRCPG.
Then I would have to shift primary back to VRCPG and redo my whole network.
Seems painful. Hope there is another way. Not even sure if that would work.

Mmm; ok, I will try it again and detail the steps; there must be a difference between your and my attempt somewhere.

Thanks for your help. :slight_smile:

YES!!! it worked! Thanks oTi, I was able to include vera into my VRCPG by “including node” as you suggested. I reset my vera2 again. and followed the instructions to Make vera 2 the secondary controller to Leviton Vizia RF+ (VRCPG), but instead of “sending data” from my controller, I “included node”. This time it worked!!!

I did use the “include node” from the “Advanced install” instead of the “install Checklist” this time. Not sure if that made a difference. Just wanted to document my steps in the forum.

Now I have to try to add vera as a secondary…

I’ll let you know how it goes.

:stuck_out_tongue:

retried this"“How to make Vera the secondary controller to Leviton Vizia RF+ (VRCPG)?” step by step.
No luck. :stuck_out_tongue:

However, I updated controllers on the VRCPG (system->advanced->yes->advanced install->update controller)
on vera UI5 i went to (z-wave settings->advanced->copy z-wave network from master controller) and it worked!!

Yea, now I have all my devices in Vera, and Vera is no longer primary.

Unfortunately, the labels didn’t cross over, so I have to rename everything. However, a step closer to being able to control my network again from my iphone.

Thanks, everyone. :slight_smile:

everything is good, except my Kwikset door lock. ;D
I included it in vera before I made vera secondary hoping it would survive the transfer. No such luck. :stuck_out_tongue:

I don’t think that I can include it with the VRCPG.
Can I include it with the VRUSB and installer tool?

I’m not sure what I can do with this without making vera primary.

Any ideas? ???

[quote=“Urodoc, post:1, topic:172722”]I followed these instructions from the Wiki:

How to make Vera the secondary controller to Leviton Vizia RF+ (VRCPG)?[/quote]

I have been unable to locate this article in the wiki …

Q: Can someone please provide a reference to this article in the (which?) wiki?

Michael

http://faq.mios.com/content/1/48/en/how-to-make-unit_name-the-secondary-controller-to-leviton-vizia-rf-vrcpg.html?highlight=unit_name

Well I finally bit the bullet and switched Vera to primary.
So far everything is working fine. ;D

Essentially, I have an all Leviton system.
My favorite feature of the Leviton system is the 4-button zone controllers (VRCZ4-1LX-the old ones). I have 5 different lights in my kitchen, so it’s nice to be able to turn them on with one button. I could never get them to work properly with Vera, so I set them up with the Leviton Handheld (VRCPG), and had Vera as secondary. They work perfectly with the Leviton controller.

However, I need Vera for my iphone interface (iVera). My wife and I like to be able to turn lights on and off with our iphones.

The only problem with this setup is that I cannot include my Kwikset lock in the Leviton system. I added a VRUSB and the Installer Tool, only to find that this didn’t fix the problem either. It did, however, make me more comfortable switching primary control from the VRCPG to the VRUSB and back again.

Anyways, after configuring everything with the VRCPG (i.e. 4-button zone controllers), I have switched Vera to primary now. Under Z-wave settings I unchecked “By default Vera should automatically configure devices”, so Vera doesn’t mess up my 4-button zone controllers. Incidently, I am using UI5 and version 2.78.

Here are the instructions for shifting the primary role to Vera or the Installer Tool (IT):

To shift primary role to IT:
Vera: Setup > Z-Wave Settings > Advanced > Controller shift
IT: Join Existing Network

To shift primary role to Vera:
Vera: Setup > Z-Wave Settings > Advanced > Copy Z-Wave network from a master controller
IT: Transfer Primary Role

The process is the same if you use the VRCPG instead of the IT as I did.

When you have Vera in secondary and you “update controller” or “shift it to primary” it resets all the device names to default. >:( So I had to rename all my devices and put them back in the appropriate rooms. Ugh. Fortunately, the Installer Tool has all the node numbers and device names correct, so it wasn’t too difficult figuring out what each device was. I simply clicked the wrench, clicked the settings tab, found the “ID” number, compared it to the device number in the Installer tool, and renamed the switch, dimmer or controller.

Last step is to add my kwikset lock to Vera and then hopefully all will be well in the universe. ::slight_smile:

I switched briefly to Vera a primary to get my Kwikset lock to work. Everything was great until a “heal” wreaked havoc on the network and reconfigured all my Leviton controllers into nonfunctioning wall art. >:(
Back to VRCPG as primary. :stuck_out_tongue:

Were you able to get your Kwikset lock working with the VRUSB or VRCPG as primary? I’m having the same issue - I use the Leviton USB as my primary controller, but I can’t get the door lock info to transfer over to the Vera correctly, I keep getting the “Failed at getting secure classes” error when I try to configure the lock in the Vera.

I’m very hesitant to switch the Vera to primary, since the Vera was never able to consistently exclude/include devices, but I can’t figure out how to get the Kwikset lock working when just transferring the configuration info from the Installer Tool to the Vera. If you were able to get it working, I’d appreciate any tips you have. Thanks!

Only with Vera as primary. :frowning: