Vista 20p, with 2 partitions...but AD2USB not operating correctly...

Hey All - I need some help :confused:

I have a 20p, 2 partitions (House and Garage) but only one main keypad (#16) and the AD2USB (#18).And a Vera lite with Plugin v 2.45, with auto-update checked. (shouldn’t it be v3 now?)

I’ve had it all working, it’s just not working 100% correctly, and I’m sick of it!

So I have the NumPartitions listed as 2, and that generated 2 devices…and then I’ve tried every combo of the Keypad numbers
I’ve tried 16 only for P1, and 18 Only for P2, then tried 16,18 for P1, and 18 for P2, and 16,18 for both…
I can actually arm and disarm both accordingly, but the vera UI5 continuously flicks back and fourth from ARM/DISARMED - and even thou the garage stays armed - it quite often shows unarmed on Ui5 etc - when I’m travelling, it’s causing me anxiety not knowing if it’s reset after a false alarm or similar!

Help? Thoughts? - Ideally I want the AD2USB to be able to control both my partitions…I’m assuming it CAN - but can someone help sort this out