VeraEdge UI7 Thermostat - No "Energy" Mode

On my Vera Lite, I would use the energy savings mode when I was considered away from home. I am not seeing that functionality available here in UI5. Am I missing something? Is this functionality that will get added back? Any workarounds at this point that I can get tips on how to implement?

It is still there, just not visible on the graphic.

You need to set the variable EnergyModeTarget from Normal to EnergySavingsMode and vice versa. It can be done on a Scene. Works well for me.

Interesting, because when I query the device these are the only things that I see that are available:

luup.variable_get(“urn:upnp-org:serviceId:HVAC_UserOperatingMode1”, “ModeStatus”,88)
luup.variable_get(“urn:upnp-org:serviceId:TemperatureSetpoint1”, “CurrentSetpoint”,88)

luup.call_action(“urn:upnp-org:serviceId:HVAC_UserOperatingMode1”, “SetModeTarget”, {NewModeTarget = “Off | CoolOn | HeatOn”},88)
luup.call_action(“urn:upnp-org:serviceId:TemperatureSetpoint1”, “SetCurrentSetpoint”, {NewCurrentSetpoint = “”},88)

It seems that a couple of different options have been taken away from the UI and the results that get returned in user_data. Thanks for the tip - it definitely helped!