VeraEdge and Popp 4 button key fob


I’m not sure if anyone has used a 4 button keyfob with the VeraEdge??

I recently grabbed one of these:

as I wanted to use it as a scenario controller however, it seems to be a little tricky to setup??

The guides I’ve studied so far are:

and of course the product manual:

Since the VeraEdge is Z-wave Plus capable I thought using the parameter code of 8 would work for variables 11-14??

I have also tried 4 and 5 too. With a value of 4 the buttons seem to control the Scene I told the Vera to use for the 4th button, but when I push any button it seems to activate it??

So describing what I’ve done so far is this:

Created 4 Scenes to turn lights on (this is just as test for now as ideally I would like to also turn them off too but still learning about the Vera :slight_smile: )

In the Scenarios as trigger I setup the keyfob buttons 1 through 4 for each Scene then as output told the Vera to turn the relevant lights On.

The keyfob itself has been paired with the VeraEdge and is happily reporting status back.

I believe I have put the keyfob into Secondary Controller mode but the guides from seem to suggest different things??

For the Vera-Lite it says to go to Management Mode on the fob then press button 2, while for the Vera it says to push button 1??

Would anyone know a way in which I could get this device to function as a Scenario controller with the VeraEdge as I’m sure it’s possible it’s probably just me not understanding 100% of how…

Many Thanks.

So, I’ve found out something interesting…

The buttons aren’t actually triggering between 1 - 4. Instead I am using 2 - 4 to control scenes which seem to correlate to buttons 1 - 3.

Also I have found setting the parameter for variables 11 - 14 to 5 enables the Scenes to trigger properly.

Slight strangeness with the Fibaro RGBW dimmer I’m using… to turn my strip lights on I am having to set the Brightness to 100% as ‘triggered event’ in the scene creation.

…more strangeness is when trying to turn off as I have attempted to set the Brightness to 0% [Off] and associate with button 5 (which should be button 4 on the fob considering the previous values). Anyhow, this at present does not seem to work as I have yet to be able to get Button 4 on the Fob triggering the Scene.

It looks like we’re edging near the solution but still finding the last hurdle to overcome :-S


Did you get a solutions for button 4 to work?


Hi there…

Sorry for late response - yep I did!

Go to Devices → Keyfob settings in web UI then click on “Scenes” and associate the desired scenes with the device (don’t forget to create them first :wink: )

Then use the key combination on the keyfob to wake it up and it should pull the associations in directly and that’s it :slight_smile: :slight_smile:

Hope that helps!


I tried that and I can get button 1 - 3 to work, but the 4th button doesn’t activate the scene.
Do you have specific device options set? How do you wake-up the device? I press the 4 buttons and then press 2.
My device options are: parameter 1, 2 set to value 0 and 11-14 set to value 5.

In my config I have these variables set:

Under Device Options:


All are 1 byte decimal.

Let me know if that works for you?


Oops just read through your response properly and you mentioned the above!!

Is your keyfob in Primary or Secondary controller mode? It should be set to Secondary as the Vera will be your primary…

Taken from the manual: Reset to Default, then push button 1 for about a second (red/green blink) will add keyfob as Secondary Controller

I have tried for 2 weekends now getting it to work but I dont get the 4th button to work
Have tried numerous resets but it never work :frowning:

Hmm… that’s a difficult one!

Normally what I do after adding a scene to a button is do a forced wake up on the device afterwards otherwise it takes forever till the next sync as to save battery I set the Wake Up interval very long.

Have you tried this too??

Also have you checked the Vera log files??

SSH into the box and they are under: /var/log/cmh if I remember correctly… all UNIX based system logs go into /var/log normally so the path should be correct.