Vera2 SSH / Smartphone plugin

I just upgraded to a vera2, took most of the night to get everything migrated over and then I had a number of issues with the having javascript errors, which prevented me from changing the vera2 into switch mode so I could easily access it on my local network. (which is behind a firewall)

I have a few issues remaining:

  1. I can’t SSH into the box. I can connect to port 22. I have tried user: root password: wifi key on the bottom of the vera2. I have even tried changing the wifi key (I don’t use vera’s wifi) and still no luck. Any more thoughts on how to get into it!!!

  2. The reason I wanted to ssh into the box is I am trying to install the smartphone plugin. Unfortunately it appears that the old plugin carried over with the restore from the vera1, and now no matter what i do, I am stuck with version 0.65 of the plugin. even though the marketplace clearly shows a higher number. i also tried to upload the lua file from the svn repository. still no luck. I read in a post that I would need to go in and delete the old files, hence my need to ssh in.

  3. advanced configuration link: The advanced configuration link in UI4 goes to cgi-bin/webif/ but just gives a 500 internal server error. any thoughts on that one?

i’m running 1.1.1047

#3. My initial thought is to try another browser. But it could be your firewall.
#2. Cant you delete / remove the plugin and download again?
#1. I’m pretty sure you have to telnet in first and create the root PW before you can SSH in.


#3 I had the same issue (Internal error)
#1 Try using the Home ID on the bottom of your Vera2 as your initial ssh password

RE: #2
I have the old .65 Smartphone plugin also. I have deleted it and re-added it several times expecting to see 1.019. I have also not been able to update the Generic IP Camera plugin from .61 to .90. Removing the Camera plugin deleted all of my cameras. Any suggestions on how I should update these?

I too am getting the “internal server error” when using the advanced link to open up web ssh.

It is not a browser issue as it allows me to web ssh into another VERA without incident.

The difference between the two Vera2 configurations:

  1. Using ETH1 as WAN interface for VERA to which i can use web ssh. this Vera is running 1.1.1062
  2. Using the wireless as client/bridge to be WAN interface on the VERA that does NOT allow me to web ssh. this Vera is running 1.1.1047

I can ssh directly on port 22 w/o issue on BOTH veras.

Any ideas what might cause this? the WAN interface? The Firmware version?