vera will reload to validate the changes...

Hi Guys,

I had my somfy blinds working great but when I did a update of the vera firmware I managed to lose all connectivity (DOH) I’ve tried redoing all the steps I originally did to connect up my somfy blinds via RFXtrx but it seems to be getting stuck on the add device stage. I get the vera will reload to validate the changes notification but then noting. I reload the page manually and no devices have been added.

Any Idea what i’m doing wrong, or is there a bug in the plugin?


Just to mention I’m running vera firmware 1.7.3232 and version 1.22 of the plugin.

If everything was working with version 1.22 of the plugin before upgrading the Vera firmware it’s tough to imagine what the problem could be. None of the plugin code having to do with Somfy blinds has been modified. Have you tried to look at the Vera log files?

If you have MS Excel, the easiest way to retrieve and explore log files is to use the ELVira Excel Log Viewer. Check this posting:,30265.0.html

Thanks for the heads up, you have given me a good reason NOT to upgrade. The last upgrade gave me grief but now if the blinds don’t work then it looses it’s WAF.

What type (typ1, typ2, ext, ext2) and version of firmware is installed in the transceiver?

I have this issue as well after upgrading to newest firmware on Vera Edge.
I can’t manually add a new device for the RFXtrx or start to auto creation mode. Tried to flash newest ext2 firmware to my RFXtrx as well but same issue.

Using the RFXtrx433E

Same issue for me…

None of the changes i do in the RFXTRX controller plugin does anything in vera… I tried to delete some auto generated motion sensors, and it just stops with the message in the topic here…

I’d like to prevent auto generation on these ID’s (probably my neighbours), but i can’t now…

OK, I upgraded to the latest version of the Vera firmware on 11 Oct. I hadn’t attempted to do anything in the way of adding or removing RFXtrx devices since then. Tried AutoCreate just now and I can see that although clicking on the Automatic creation radio button changes its state, the state variable never gets updated. I’ll try to look into this sometime today.

That would be fantastic. Its a real shame not having my blinds connected and automated like they used to be!

I’ve tried contacting vera support too and they also seem baffled. They did however, give me some instructions to downgrade:

In order to downgrade your Vera unit, you will need to access the Settings tab → Firmware → Copy the following line in the ?URL for custom Vera firmware:? field → Download → Use the option to Keep the current settings and configuration → Wait about 20 minutes until the firmware downgrade is done → Once the unit is up and running, you will need to restore a backup (With the option to restore z-wave network) from before the upgrade.
Here is the link that you will need to enter:

I’ve spent some time trying to find out the source of this problem. No luck so far but I have some suggestions for possible work-arounds. To enable or disable AutoCreate, change the setting in the variables for the RFXtrx transceiver device. You can do this in the Advanced tab page the device by selecting the Variables tab. Click on the Edit link (this is new in the latest Vera firmware) for the AutoCreate variable. Set it to 1 to enable AutoCreate or to 0 to disable it.
Deleting device from the RFXtrx Managed Devices page doesn’t work but you can delete them individually from the Vera Devices page. For each device click on the ‘>’ to show the device details and at the lower right click on the Delete Device button.
I’ll continue to look into these problems as time permits. Right now doing some work on my house that I have to finish before the cold weather sets in.

Same issue for me, cannot add new devices after firmware upgrade.

FWIW, the request for saving returns 404 not found from my vera controller so that is probably why it borks out:

I’m seeing the same thing for the request URL (404 not found).


Thank you for contacting Vera Support.

The plugin which is controlling the behavior of your RFX gateway is using a port ( 49451 ) which has been blocked on the latest firmware version. This is why you are not able to add new devices and unfortunately I can not do nothing to unblock that because one the customer care department we do not have access to the source code of the software engine driving the unit.

It has been reported to our development team. They are working on it, but I don?t have an exact ETA for this, but more details to be announced through our official channels and on our release notes as they are being published with every new update:

Thanks for the FYI. I don’t have any idea where that port number comes from. I’ll look elsewhere. It’s not in any of the plugin code and the ports used by an ajax.request are beyond my experience.

Any news on this?

Can’t create devices, can’t delete devices (through “Managed devices”), can’t edit the “managed devices” list what so ever… Hope this issue has some priority at vera!

Well, as I said before this is an area in which I have little experience but I installed nmap on my PC and using the Zenmap GUI I ran a scan against my Vera Plus. Looks like to port is open for tcp but blocked for udp:

49451/tcp open upnp Portable SDK for UPnP devices 1.6.6 (Linux 3.10.14; UPnP 1.0)
49451/udp closed unknown

I would think that a fix for this would be a straightforward use of iptables.

The RFXtrx plugin requests the url from Vera using "command_url’ (the Javascropt API function now being getCommandURL() ), If Vera replies with the port that should be used then I’m surprised that they also block the port.

Hello guys,

49451 port block is part of the upcoming upnp revamping and securing.

I just downgraded to the previous using this link:

Everything is fine now, don’t think i need many of the improvements in 3232 now, so i’ll hold til the next one.

Just thinking
Where this port is defined?

Maybe it is possible to change it in the plugin configuration?