Vera Lite refuses to save changes

Whenever I make simple changes to any device (e.g. changing the device name) pressing the Save button does not commit the changes. Everything appears to work after pressing Save, in that the usual startup messages and Continue button are displayed, but when I look at the device again the changes have not been saved.

I’ve tried Ctrl-F5 and also tried making changes with 3 different browsers (Chrome, Firefox, IE), and on different PCs. All produce the same problem. The only work round is to reboot or power cycle Vera and then try again. This usually works temporarily, and I can save things for the next few hours or up to a day at most. This is very frustrating, as there is never any warning that this behaviour has started happening again. I’m currently on version 1.5.622, but I was also getting the same behaviour on 1.5.408.

Does anyone have any thoughts as to what could be causing this, or should I open a ticket with MCV? Thanks.

strange behavior. sometimes you may need to press reload (top-right) if changes do not reflect immediately. I would contact MCV support if the issue persists.

This sounds like it might be a storage issue where your device is running out of storage space. Things that could cause such a situation include:

[ul][li]A lot of devices, scenes, and plugins (dozens). [/li]
[li]Verbose logging is enabled.[/li]
[li]Store logs on USB device, but device has been removed[/li][/ul]

You may also want to watch the live log at http://veraip/cgi-bin/cmh/ while the save is failing to see if it reports any errors.

I agree with z-waver check that your vera is not running out of storage.

  • Garrett

Thanks everyone for the quick replies.
I looked at the logs as z-waver suggested. I’m not sure what I’m looking for, but this log fragment does look suspiciously like a space issue:

[tt]01 05/06/13 15:05:42.604 UserData::WriteUserData failed File Size: 87813 save size 0 <0x2c0f1680>

01 05/06/13 15:05:44.545 UserData::WriteUserData failed File Size: 88007 save size 0 <0x2b9be000>
01 05/06/13 15:05:44.547 Mongoose XXX-mg_stop1 0xe988b8 1 4 <0x2b9be000>
01 05/06/13 15:05:46.559 Mongoose XXX-mg_stop2 0xe988b8 2 4 <0x2b9be000>
01 05/06/13 15:05:46.559 Mongoose XXX-mg_stop3 0xe988b8 2 4 <0x2b9be000>
01 05/06/13 15:05:46.559 Mongoose XXX-mg_stop4 0xe988b8 11171872 4 <0x2b9be000>

2013-05-06 15:05:46 - LuaUPnP Terminated with Exit Code: 250

2013-05-06 15:05:46 - LuaUPnP crash

01 2013-5-6 15:5:46 caught signal 6 <0x2c6f1680>

I have a memory stick I could use for the logs, but the Vera Lite only has one USB port. I already have a powered USB hub that I’m connecting RFXcom USB and a Current Cost USB. Will there be an issues putting the logs on a USB stick if going via a powered USB hub?

Also, is there any monitoring I can do on the Storage? I do have a lot of devices from various plugins. Ideally it would be good if Vera can send me a notification (via Prowl) when Storage is getting low.

Each Z-Wave Device and Plugin Instance (not counting child devices …) uses about 4MB of memory. If you do not have a USB disk for the logs … then the logs are stored in memory as well.

Might be time to put your Vera on a diet!
Remember the Heisemburg Uncertainty Principle … if you try to add a plugin to monitor the state of Vera, you will be consuming the precious memory your are trying to monitor.

I suggest you login to the machine via SSH and
check the results from the unix command free and df

:smiley: Good point.

[tt]root@MiOS_00000000:~# free
total used free shared buffers
Mem: 62480 55896 6584 0 0
Swap: 0 0 0
Total: 62480 55896 6584

root@MiOS_00000000:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 4608 4608 0 100% /rom
tmpfs 31240 2968 28272 10% /tmp
tmpfs 512 0 512 0% /dev
/dev/mtdblock7 11264 2028 9236 18% /overlay
overlayfs:/overlay 11264 2028 9236 18% /
/dev/mtdblock8 4480 4480 0 100% /mios

Looks like Swap is zero and /dev/root is zero. I assume that is bad? I shall reboot and take a new reading. I don’t know what a normal or safe range would be like.

[quote=“jtmoore, post:7, topic:175274”]01 05/06/13 15:05:42.604 UserData::WriteUserData failed File Size: 87813 save size 0 <0x2c0f1680>

[tt]/dev/mtdblock7 11264 2028 9236 18% /overlay
overlayfs:/overlay 11264 2028 9236 18% /[/tt][/quote]
The error indicates that there was insufficient space to save the file and that LuaPnP crashed. While it seems that this file should fit, I might be interpreting the units incorrectly. Free some “disk” space by:

[li]Turn down/off the logging[/li]
[li]Insert a USB stick and configure it to log there[/li][/ul]

There is no swap on Vera.

You never said how many devices, plugins etc. you have.

Vera should be able to find a flash drive on the USB hub.

From memory size I guess this is a Vera Lite, it has 1/2 the memory of a Vera 3.
Also I see you have NO USB disk initialized … Get a cheap 512MB USB stick and insert it into your Vera.
Then goto Setup -> Logs
Then check Store Logs on USB device
This will keep the logs from eating up memory.
The other thing you can do is to start reducing the number of devices.
How many, and of what type do you have ?

Also /dev/root is the ROM (Read Only Memory) which contains the downloaded software from MCV. The fact that there is 0 bytes of free bytes is normal … it’s read-only!

Vera is not configured for Swap … this is a way to extend the perception of more memory … but at significant performance cost. You could try to add Swap if you had some plugins that are not actively used … but you have to test the performance implications. You could format the USB stick to have part Swap and part used for Log File … but you will need to be familiar with Linux to do this.

I’ve now added USB storage (512MB) for logs. New readings are:

[tt]root@MiOS_00000000:~# free
total used free shared buffers
Mem: 62480 58016 4464 0 436
Swap: 0 0 0
Total: 62480 58016 4464

root@MiOS_00000000:~# df
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 4608 4608 0 100% /rom
tmpfs 31240 500 30740 2% /tmp
tmpfs 512 0 512 0% /dev
/dev/mtdblock7 11264 1948 9316 17% /overlay
overlayfs:/overlay 11264 1948 9316 17% /
/dev/sda1 485118 16837 443234 4% /tmp/log/cmh
/dev/mtdblock8 4480 4480 0 100% /mios

Initially I still had same problems saving any changes (including deletes). Power cycled and rebooted several times and I have now been able to delete some unused Scenes and one unused PLTS device. Now simple changes to device names is working, but for how long this will last I am unsure.

I have 158 devices in Vera (I’m not sure how to get an accurate inventory or device types etc.). I estimate that 40% of these are z-wave devices and 60% are from the 14 plugins I have installed. I admit that I have quite a lot of plugins, but not sure how I could live without most of them. I’ve been trying to use PLEG and PLTS to reduce the number of separate Countdown Timers and Combination Switches, in the hope that this may reduce the memory overhead (i.e. put Vera on a diet).

The increase in the amount of available free space in /overlay (/) is disappointing. I had hoped for more.

This sounds like a lot for a Vera lite. That the problem went away after deleting a few says it all.

You will either have to limit your devices or get yourself a Vera3 with more memory.

Edit: I’d hold out on replacing the Vera lite if I could until MCV releases their new devices, there may be a better alternative to Vera 3 for you.

Scenes do not consume much memory.

A PLTS and a Countdown Timer use the same amount of memory.
However if you also need a Countdown Timer and a couple of Combination Plugins to perform some automation, then the PLTS will save you memory.

A single PLEG can replace a lot of other plugins. But I would not go over board … You should group similar tasks … other wise it can become too complicated.

I am facing the same issue (unable to save any edits). Is this resolved without a restore , if yes what solution is applied ?

I am also unable to delete any devices either via UI (http://:3480/data_request?id=device&action=delete&device=) or by doing an SSH and going to folder /etc/cmh-ludl. The devices delete temporarily, but upon reboot comes back again !! (very strange), If I ssh and remove some devices using rm /etc/chm-ludl/<device file name) it deletes but upon reboot i see it is created again !!

I have also attached a USB drive for logs after reading the forums, but it did not help much. Any help in resolving this issue would be appreciated. I have a large installation (150+ Vera devices incl. ~40 real Z-Wave devices). I can’t make any updates at all , and I have a number of changes to make !!

here is my df and top outputs

Filesystem 1K-blocks Used Available Use% Mounted on
/dev/root 4608 4608 0 100% /rom
tmpfs 31240 868 30372 3% /tmp
tmpfs 512 0 512 0% /dev
/dev/mtdblock7 11264 2748 8516 24% /overlay
overlayfs:/overlay 11264 2748 8516 24% /
/dev/sda1 518692 29500 462844 6% /tmp/log/cmh
/dev/mtdblock8 4480 4480 0 100% /mios

Mem: 58304K used, 4176K free, 0K shrd, 2016K buff, 12976K cached
CPU: 58% usr 41% sys 0% nic 0% idle 0% io 0% irq 0% sirq
Load average: 0.43 0.31 0.26 2/128 31656
22275 3017 root S 7008 11% 8% /usr/bin/NetworkMonitor
31639 12858 root R 1676 3% 8% top
30546 2918 root S 169m 277% 0% /usr/bin/LuaUPnP
3091 1 root S 4340 7% 0% lighttpd -f /etc/lighttpd.conf
438 1 root S 1928 3% 0% syslogd -C256
3044 1 root S 1792 3% 0% /bin/ash /usr/bin/
31646 22275 root R 1792 3% 0% /bin/ash /usr/bin/
29997 29924 root S 1780 3% 0% /bin/ash /usr/bin/SetupRemoteAccess.s
29924 1 root S 1780 3% 0% /bin/ash /usr/bin/SetupRemoteAccess.s
2691 1 root S 1696 3% 0% crond -c /etc/crontabs -l 5
2918 1 root S 1688 3% 0% /bin/ash /usr/bin/
1 0 root S 1684 3% 0% init
12858 12642 root S 1684 3% 0% -ash
403 1 root S 1684 3% 0% init
2858 1 root S 1680 3% 0% watchdog -t 5 /dev/watchdog
3017 1 root S 1680 3% 0% /bin/ash /usr/bin/Start_NetworkMonito
2941 2918 root S 1676 3% 0% /bin/ash /usr/bin/
440 1 root S 1672 3% 0% klogd
31599 29997 root S 1668 3% 0% sleep 10
^C702 3044 root S 1668 3% 0% sleep 60

My configuration :
Vera Light
Firmware : 1.5.622
Devices : ~150 (incl ~40 real z-wave devices)
Have SQ Blaster and HEM in the devices as well.

I had also raised a ticket with MiOS. They have downlowded a backup and monitoring the same now.


The following should give a clue:

30546 2918 root S 169m 277% 0% /usr/bin/LuaUPnP

Your way out of memory!

It also shows you are using 58MB of memory out of the 64MB.

  • Garrett

Bahh!! This is happening to me to now since I installed the netatmo plugin. Can?t change anything anymore. Guess it is time to clean out everything I’m not using to free up some memory. It would be nice to get some kind of warning before this happens so one can take action.

I still have a support ticket open for this issue for many weeks now. Latest advice from MCV was to wipe and restore, but the restore isn’t working for me :frowning:
This is the 2nd time this year that Vera has got into this bad situation. I really wish that MCV would tell me what has caused this, and how to prevent a re-occurrence ???
When MCV finally do get Vera working again, I will still be taking a big risk every time I add a new device or plugin, with no way for me to reverse the situation…

You have exceeded your memory on the Vera Lite.

You need to upgrade to a Vera 3 … twice as much memory.

Hopefully you have your own recent backup (Not on the MCV Servers) that includes and up to date Z-Wave backup.

You can use it to upgrade your new Vera 3 to your existing configuration.

OR you can start deleting things … if you can get back to a version that will allow an update.

Thanks for the advice. I’ll try a much earlier backup.
I have taken a few backups over several months and saved to my PC, but I can’t remember which ones included the Z-Wave backup. If I extract the .tgz file, what should I look in here that tells me that backup set included the Z-Wave too? Thanks.