Vera IP Address keeps changing.

Not sure if this is Vera or my Router, however, Vera’s IP address has been altering/changing between to by itself over the past 4 months.

Most frustrating, especially when I try to log in locally only to find Vera no longer exists on it’s last address.

Any ideas why ? ???

Most likely due to dhcp. Either add a manual dhcp address lease in your router for Vera or configure your Vera with a static ip address.

  • Garrett

Thanks Garrat,
Unfortunately, being pretty computer illiterate I have no idea how to do either, is there a “configure your Vera with a static ip address for dummies” or 'configure your xxxx with a static ip address" writeup available somewhere?

Similarly, “manual dhcp address lease” is way above my head. I have no idea what renting has to do with Vera. ;D

Your best bet would probably be to use the static IP address for your Vera route. In order to do this you will need to set your vera to a static IP (Most likely you should use as your router will be at then you will need to adjust the DHCP settings in your router so that it will not hand out the to anything else. Unfortunately this procedure will vary from router to router but the gist of it is that you will need to login to your router (instructions in your router’s manual or online) and find the DHCP settings. There will be a lease start number listed and it will probably default to You will need to change this to at least but I normally go to or higher so that I have some other static numbers available. Hope this helps!


Can you confirm what model Vera you have and firmware?

First look at Setting > Net…Wifi > under the option it is currently set to Automatic. Select Manual and change DCHP to Static.

[quote=“Brientim, post:5, topic:177351”]Zedrally,

Can you confirm what model Vera you have and firmware?[/quote]

VeraLite, ver. 1.5.622

All solved.

Now trained in reserving IP address’s… thanks to all for the encouragement.

[quote=“zedrally, post:7, topic:177351”]All solved.

Now trained in reserving IP address’s… thanks to all for the encouragement.[/quote]

Glad to hear it!

There are 3 correct solutions and 1 problem solution … which did you choose:

  1. Leave Vera with DHCP requested address, but have router return a reserved DHCP Address.
  2. Vera has a static IP Address outside the DHCP address range of the router … No Router Reservation is needed. But you need to make sure that all of your static IP addresses are distinct.
  3. Vera has a static IP Address witch is the same as the DHCP Reservation on the router. Here the reservation list is your list of statically assigned IP addresses. And by adding a reservation … you make sure the router will never hand out that IP address.

And the wrong way to do it:
4) Vera has a static IP Address and NO DHCP reservation … and the IP address is in the range of possible DHCP addresses for the router.

The latter can cause periodic network problems if you have other devices requesting DHCP addresses.

I use option 1 for all devices in the house … most come pre-configured to request a DHCP address. I just make sure the router always gives that device the same address.

One of the reason I asked for the Vera model was relate to Vera 2 which would use it multiple MAC addresses. Dependant on configuration and at restart it may switch between them and hence option 1 as listed above was not always effective. I also prefer to manage IP address centrally.

RTS, I believe I used your solution #1.

The router is a Netgear DGN 2200.
I had to search around in the settings to find LAN setup and from that I could “click” and set the reserved IP address’s (see Screen shot). If it’s wrong can someone pls advise…

@ zedrally

That looks good.

Thx, this also solved an ongoing freezing problem I had with the WDTV.