Vera extroot

and we can recover it if it bricks :sweat_smile:

1 Like

Yep, I just did a forced downgrade of the kernel to try extrooting the edge. Somehow this time, it did not pop the vera4lite error when upgrading to 7.0.29… weird.

Success! Same script for the vera edge now available!

As a reminder, the process is as follows:
Start from 7.0.29 before ever upgrading to 7.0.30. You may need to run a chmod +x *.sh after uploading the files on your vera either through sftp or scp. Then:

  1. extroot using the extroot script
  2. then upgrade to 7.0.30 using the upgrade script.
root@MiOS_4500XXXX:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   58.1G     85.2M     55.0G   0% /
/dev/root                 9.5M      9.5M         0 100% /rom/rom
tmpfs                    61.9M    400.0K     61.5M   1% /tmp
/dev/mtdblock6            9.4M      3.8M      5.6M  41% /rom/overlay
overlayfs:/overlay        9.4M      3.8M      5.6M  41% /rom
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock10          64.8M      9.3M     55.4M  14% /rom/storage
/dev/mtdblock10          64.8M      9.3M     55.4M  14% /rom/etc/cmh-firmware
/dev/mtdblock10          64.8M      9.3M     55.4M  14% /rom/etc/cmh-backup
/dev/sda1               487.8M      2.8M    459.5M   1% /tmp/log/cmh
/dev/mtdblock9            7.5M      7.5M         0 100% /rom/mios
/dev/sda2                58.1G     85.2M     55.0G   0% /overlay
overlayfs:/overlay       58.1G     85.2M     55.0G   0% /
1 Like

That was a tad scary

I think your scriptm needs cp -r as opposed to just cp?
Anyway ran each step manually, appeared to have a fully bricked router. (only power and wifi LEDs even after USB unplugged)

Tried to do a reset, did nothing. One more hadr boot with the USB in and it’s come back up, I assume with the new FW in place. PHEW

Looooong boot time though


Yeah I noticed that I posted a version of the script which was not the one I tested. This last one should be all good now. There is also no chance for it to brick your vera… it only edits the fstab from your main drive which defaults back to the original onboard root if it fails.

1 Like

Dunno what it was doing.

Anything I can test while I’m here? Make sure it’s all taken (although sure it has)



Try including devices if you can, As others reported that this build has some issues with it. Also with this mix of kernal and network monitor, I don’t know if the Xmas light mode is still a problem at reboot. I have not yet observed it in the short while I have run it and I did try quite a few reboots. Your firmware check page should tell you that you are on 7.30(4833) correct?

Checking if there is a newer firmware version available

You are running the latest version 1.7.4833 (7.30)

Typically my power is very stable, so reboots hopefully will be few and far.

I have (I hope) a load of stuff arriving tomorrow, so there will be inclusion (mostly of Fibaro stuff I expect)


1 Like new problem // this is all it does but ssh works

I had this too on my second vera plus. For me it had nothing to do with extroot but after a recovery, my unit was failing calibration. To get it back I had to reflash it. See my report here.

Is that the Christmas Tree mode then?


No it’s not. The Xmas light problem occurs upon reboot at what appears to be random rate to me and is the network and service lights flashing forever and at different frequency.
I just sent a note to @edward to tell him that I have not yet observed it when extrooting with this new script which makes the new firmware run on the previous kernel. It makes me suspect that the problem is also in some network changes on the new kernel.

1 Like

Fun this morning.
Not at all suggesting it’s extroot, but 7.3 has a couple of gotchas

  1. ZRC scene controllers have their buttons changed. I knew this, but forgot. So none of them worked this morning :smiley:
  2. Time decided it was gmt -8 hours despite still being set to GMT as a timezone. So a chilly start to the day.

Loads of new sensors and stuff due to arrive today. Hopefully I won’t get sucked into work issues :wink:


Huh, this is not extroot but my update script to 7.30… I got a bit lazy and I should probably improve it a little so that it doesn’t overwrite some of the files. Seems like there is some work cutout for me. After the upgrade you indeed will need to reset a few things, the time zone is one of them.

1 Like

It is what it is :slight_smile: Don’t forget I didn’t even use the script (cos it didn’t work) but did it manually.

So myself is my blame :slight_smile:


Just curious, has someone successfully extrooted a vera secure on 7.0.29? If so I could provide an extrooted upgrade script to 7.30.

My Vera Secure was extrooted on 7.0.29 - but saddely I was eager to upgrade to 7.30, so it’s not extrooted anymore. I guess that’s not to any help @rafale77 ?

Yeah unfortunately, it won’t extroot any more. You could still try to see if it will pivot the root to the external drive but in my experience, it was not possible. On top of this the new kernel , from my test results, appear to be the source of several problems we reported during the beta and is not reversible.

1 Like

Upgrade from already extrooted 7.29 (Vera Plus) went well, even timezone was preserved. Settings that I had to fix were network (static IP back, wifi off) and logging (unchecked “archive old logs on MiOS”)

Thanks @rafale77 for your great work!

UPDATE: timezone seemed to be fine at first, it was correct in the unit settings, but there was wrong time shown in the upper right corner in the UI. This was fixed by setting another timezone and then back to the correct one


any idea if we will see a 7.31 extroot?

I am back but am travelling for business this week. I should be able to get that out this weekend.