Vera extroot

Thank you so much. I may convert to the vera plus just to see if it could clean up my vera environment. I really hate to throw more money after a failing solution but right now I am desperate for any comfort that my outside motion detectors and vera alerts can provide. Obviously you have spent a ton of time helping all of us and be assured we recognize it and appreciate it.

2 Likes

I also have a Vera Edge that i tried to Extroot. Fortunately the extroot proces failed for some reason otherwise i would problably have ended up with a brick as well.
But the change from USB stick to SSD stabilized my Edge! In combination with clearing the cache every 30 min, i now have a rock solid unit.

Maybe worth a try… :slight_smile:

Thank you very much crab. I will go ahead and order the parts. If you get a moment, would it be possible for you to send me the Lua code for clearing the cache. I had thought I was clearing cash once every 24 hours but it appears that I was receiving an error I didn’t notice. I know how to schedule it, I just need the code. some people add quotes when displaying code and I can never tell if that is part of the code or not. Vera Support has been looking at my unit lately and it didn’t go down last night. Sadly, that is a big improvement.

1 Like

Clearing cache: os.execute(“echo 3 > /proc/sys/vm/drop_caches”)

You can first test the code with “Test Luup code” option in the develop apps menu, to see if it is ok.

I used to do the clearing based on the available memory with a condition in PLEG, but now i just do it every 30 min.

Like the others said, don’t use the Extroot on the Edge (guess i was lucky not to brick it in my attempt).

Good luck and i hope it works for you as well!

So you only replaced an usb stick with a SSD for a log destination? And this change stabilized your Edge? I thought this kind of move (alone) would not really help, but I stand corrected :slight_smile:

Btw, do you have a setting “Archive old logs on MiOS” enabled?

Yes, i did try the extroot script but it did not work. So I ended up only switching the USB stick with an SSD drive and using that as a logging destination. “Archive old logs on MiOS” is not enabled in my case.

(My Vera was experiencing many reboots a day because of very high CPU load. After the change to SSD those dropped to normal and made my Vera very stable again).

Here you can read about my Reboot Battle

1 Like

A little update here. My problem was the vera edge going offline at least once a day. I found this page thinking it would give me some ideas. The two ideas that I got were, NOT to exroot an edge, and to swap out memory stick for an SSD hard drive to improve performance. At the same time, I created a service ticket and Jose picked it up and started working on my unit. He was able to stabilize it but didn’t let me know anything about what he changed. The main thing that I noticed was that he disabled logging to the memory stick. About this time, my ssd arrived so I hooked it up and enabled the logging to the SSD. Almost immediately, my edge started going offline again. So, I have disabled logging to any external drive and so far the unit is stable again. Hope this helps someone.

for some reason this does not work anymore

A little more details would help. Sounds like at least you were able to SSH back into your unit…

yeah got it restored to factory, now the real work starts, I tried to restore but it didnt restore any of my extrooted settings and now i cannot tun on usb logging

Cannot restore before you extroot. You have to go through the entire extrooting process first. You may have too much data in your setup to fit in the native vera (I saw that you have a lot of plugins)

ok cool, how can i get usb logging on … it just wont turn on

You’ve got something plugged in to the USB port? Stupid question I know, but I’ve done dafter things…

C

yeah its just wont read the ssd now

It should format it first. Try plugging it into another machine, torch the partition table and start again?
I had something very odd when the USB <> SATA adapter went punk during an update and killed the Veraplus at every opportunity. Wasn’t clear until I plugged it into a laptop and another converter cable.

C

And that’s all it does?

C

yup – it does format the drive but doesnt read it

Filesystem Size Used Available Use% Mounted on
rootfs 8.6M 5.1M 3.6M 59% /
/dev/root 10.0M 10.0M 0 100% /rom
tmpfs 124.8M 404.0K 124.4M 0% /tmp
/dev/mtdblock7 8.6M 5.1M 3.6M 59% /overlay
overlayfs:/overlay 8.6M 5.1M 3.6M 59% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/sda1 493.6M 6.1M 451.3M 1% /tmp/log/cmh
/dev/sda2 109.4G 104.8M 103.7G 0% /mnt/sda2
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /storage
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /etc/cmh-firmware
/dev/mtdblock10 50.0M 1.4M 48.6M 3% /etc/cmh-backup
/dev/mtdblock9 9.8M 9.8M 0 100% /mios

root@MiOS_$$$$$$$$:/# block mount
block: mounting /dev/mtdblock6 (squashfs) as /mnt/mtdblock6 failed (-1) - Unknown error -1
block: /dev/mtdblock9 is already mounted
block: /dev/sda1 is already mounted
block: /dev/sda2 is already mounted