Vera causes other LAN and WIFI devices to not connect

Just wondering if anyone else has had this issue? My Wifi Thermostat would not connect to my WIFI/LAN network until I unplugged the CAT5e cable that goes from the WAN port on Vera3 to my LAN. Also my media streaming device (Roku3) would not connect via LAN or WIFI either until my Vera3 was disconnected from the LAN. Tried different Cat5e cables. I have other devices on my LAN but they are not affected. Here’s what I’m going to try:

  1. Upgrade to latest UI7 (1.7.919) (running 2nd or 3rd latest firmware right now)
  2. Try changing IP address of Vera (currently a static IP)
  3. Uninstall apps (Don’t have very many at this time, upgraded to UI7 months ago and haven’t installed apps back in. Only apps installed are PLEG, PLC, PTLS, MyQGateway, Virtual On/Off Switch)
  4. Restore Vera to factory
  5. Get a different and newer version of Vera

Solved it already. Changing from Static IP on Vera to automatic (DHCP) on Vera fixed it. Don’t know why. IP, subnet and gateway were correct.

Perhaps Vera was acting as the DHCP server. I have mine set to dynamically get an IP from the router, but reserved the MAC address to an IP to ensure it keeps the same one. In fact, I have done that with many devices to make sure the IP does not change (cameras, Plex server, Blue Iris, etc.)

For best stability on Vera Plus Settings -> Network

Turn OFF the WIFI
Turn OFF the DHCP server
Turn Off Auto detect devices on my home network

I have my router reserve the IP address for the MAC address of the Vera
You can then either leave DHCP served address on or you can can statically assign the IP.
When you do a factory reset … it’s going to go back to the DHCP served address … so I leave it there.

Well, still having trouble. If I do the following in network settings:
Set to Automatically configure (recommended)
then all other network devices function but wifi on Vera is automatically turned on with no password (open wifi).

If I do the following instead:
Manually configure
Turn off Wifi
Turn off Firewall
Turn Off Auto detect devices
Use a static IP or Use DHCP for vera
Then all other network devices have issues

Its like the “Turn Off Auto detect” doesn’t work when I manually configure the network settings on vera. From reading other posts it seems like the turn off auto detect solves a lot of network issues.

I’m fine with leaving Vera set to auto configure if there was a way to disable wifi through the shell or something like that. I can assign an IP to my Vera’s mac address on my router.

Think I got it now. Set my Vera network settings to manual as in my previous post. Then I went to vera’s info.sh (veraip/cgi-bin/webif/info.sh), logged in, went to
Network–DHCP and DNS–General Settings–
And unchecked “This is the only DHCP in the local network”
And seems to solve the issue with my other network devices not being able to connect to my router. I just happened to notice that this was unchecked when Vera was set to auto-configure network settings.