Vera 2 (UI4) unresponsive

After working (mostly) without problems for about 8 months, my Vera 2 now will not respond to iVera on my iPhone, and presents a blank screen when I try to access it via my web browser. I have had a USB flash drive installed on USB2 for log files, but powering down and removing it hasn’t made any difference. I’ve power-cycled the unit several times, with no effect. I can SSH to it, but being unfamiliar with the file structure, I’m not sure what to check there.

The front panel lights appear normal without the flash drive installed–Power, ETH1, and ZWave are lit. When I reinstall the flash drive, though, only USB1 is lit, though it’s installed in USB2.

Not sure what to check from here–any suggestions would be appreciated.

Maybe try a new flash drive? I had one wear out completely after a similar amount of time!

If you fit a new one then you may have to wait a while for it to reformat and remount etc (if they have the smarts in place to do this?)

If it doesn’t work after an 30 mins or so then I would raise a ticket!

I think your USB log files should be in /tmp/log/cmh. They can become very large and depending on the USB size may have max out.

Also have a look at this string,5305.0.html

Wow, it’s been a while since I posted this. Things got busy for a while, and the Vera was also being unpredictable. After some testing, though, a power cycle seems to fix it for a few hours, and then it becomes unresponsive again. I cycled it this morning, and it worked fine, but by early afternoon the web UP was dead. Here’s some info from an SSH session:

root@MiOS_14259:~# uptime 09:48:38 up 1:58, load average: 0.04, 0.07, 0.07 root@MiOS_14259:~# uptime 11:23:45 up 3:33, load average: 0.07, 0.08, 0.08 root@MiOS_14259:~# uptime 14:58:50 up 7:08, load average: 2.03, 1.90, 1.99 root@MiOS_14259:~# free total used free shared buffers Mem: 30540 29580 960 0 408 Swap: 0 0 0 Total: 30540 29580 960 root@MiOS_14259:~# mount rootfs on / type rootfs (rw) /dev/root on /rom type squashfs (ro) none on /dev type devfs (rw) none on /proc type proc (rw) tmpfs on /tmp type tmpfs (rw,nosuid,nodev) devpts on /dev/pts type devpts (rw) /dev/mtdblock/4 on /overlay type jffs2 (rw) mini_fo:/overlay on / type mini_fo (rw) /dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/log/cmh type ext3 (rw,noatime,nodiratime) /dev/loop/0 on /mios type squashfs (ro) none on /proc/bus/usb type usbfs (rw) root@MiOS_14259:~# df Filesystem 1K-blocks Used Available Use% Mounted on /dev/root 6464 6464 0 100% /rom tmpfs 15268 15268 0 100% /tmp /dev/mtdblock/4 9088 4976 4112 55% /overlay mini_fo:/overlay 6464 6464 0 100% / /dev/scsi/host0/bus0/target0/lun0/part1 516024 45880 443912 9% /tmp/log/cmh /dev/loop/0 3072 3072 0 100% /mios root@MiOS_14259:~# root@MiOS_14259:~# ps aux PID USER VSZ STAT COMMAND 1 root 1444 S init 2 root 0 SW [keventd] 3 root 0 RWN [ksoftirqd_CPU0] 4 root 0 SW [kswapd] 5 root 0 SW [bdflush] 6 root 0 SW [kupdated] 8 root 0 SW [mtdblockd] 95 root 0 SWN [jffs2_gcd_mtd4] 117 root 1444 S init 157 root 1692 S syslogd -C256 159 root 1436 S klogd 172 root 708 S /sbin/hotplug2 --override --persistent --set-worker /lib/hotplug2/ --set-rules-file /etc/hot 350 root 0 SW [khubd] 623 root 0 SW [usb-storage-0] 624 root 0 SW [scsi_eh_0] 739 root 0 SW [kjournald] 774 root 0 SW [loop0] 2221 root 888 S /usr/sbin/nas -P /var/run/ -H 34954 -l br-lan -i wl0 -A -m 128 -w 4 -s vera_14259 -g 3600 -k so 2604 root 1452 S crond -c /etc/crontabs -l 5 2635 root 1120 S /usr/sbin/dropbear -p 22 -P /var/run/ 2672 root 1360 S /usr/sbin/ntpd -g -p /var/run/ 2688 root 1456 S /bin/ash /usr/bin/ 2708 root 1440 S /bin/ash /usr/bin/ 2723 root 1440 S /bin/ash /usr/bin/ 2781 root 1516 S /bin/ash /usr/bin/ 2822 root 1228 S ssh -p 232 -T -y -i /etc/cmh-ra/keys/cmh-ra-key.priv -R 28630: 2824 root 3728 S lighttpd -f /etc/lighttpd.conf 3026 nobody 864 S /usr/sbin/dnsmasq -D -y -Z -b -E -s lan -S /lan/ -l /tmp/dhcp.leases -r /tmp/ --dhcp-range 3029 root 1448 S udhcpc -S -t 0 -i eth0.1 -b -p /var/run/ -O rootpath -R 9873 root 1184 S /usr/sbin/dropbear -p 22 -P /var/run/ 9884 root 1444 S -ash 18514 root 1428 S sleep 60 20297 root 1440 R ps aux

Obviously the load average is up quite a bit since the first few hours of operation, and I’d expect that’s related to the problems I’m having, but I’m not sure what’s causing that to be the case.

You’re running out of memory. 960 kB isn’t enough to keep the Luup engine happy. I had exactly the same issue on my Vera2. on the Veralite, with twice the RAM, not a problem.

You need to find ways to reduce memory usage. There might be a plugin that hogs RAM. Try disabling them one by one until the situation improves. Or you might just have a lot of devices. Try removing some. Offloading the logs to an external drive might work; I never tried.

Other than that, the Vera2 might just not be up to the job. Might be time to upgrade.

Hmmm. I only have a handful of devices (less than 10), very few plugins (the Google weather is, I think, the only one), and the logs are offloaded to another device (which has plenty of space free). This also started rather suddenly, after several months of problem-free operation, and with no device changes immediately preceding the problems.

Attempted to submit a ticket, and that failed:

Reporting issue from ap: 14xxx
Collecting logs…
. Network…
. System…
. Kernel…
. Zwave Status…
Compressing logs…
Compressed /etc/config /etc/firewall.user /etc/lighttpd /etc/lighttpd.conf /etc/lighttpd.users /etc/cmh /etc/cmh-ra /etc/cmh-lu /tmp/log /tmp/log.LuaUPnP /tmp/log.NetworkTroubleshoot /tmp/log.Provision /tmp/log.RA-handler /tmp/log.Report_AP /tmp/log.Rotate_Logs /tmp/log.RouterMode /tmp/log.SetupRemoteAccess /tmp/log.StartLuaUPnP /tmp/log.StartNetworkMonitor /tmp/log.check_internet /tmp/log.cmh-ra-daemon /tmp/log.cmh-ra-keepalive /tmp/log.dmesg /tmp/log.fix_datetime /tmp/log.freshinstall /tmp/log.lighttpd_error /tmp/log.logread /tmp/log.mios_firmware /tmp/log.no_internet /tmp/log.platform_init /tmp/ /tmp/log.trouble_report /tmp/log.trouble_report_response /tmp/log.upgrade /tmp/logrotate_timestamp /tmp/log/cmh in /tmp/14xxx_troublereport.tar.gz
Submitting trouble report…
ERROR:Wrong response from server:
Notice: Undefined variable: categoryCustomFields in /var/www/vhosts/ on line 142

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 8650707 bytes) in /var/www/vhosts/ on line 710

Done. [/code]

Left an e-mail using their contact form; hopefully they’ll be able to figure something out…

I had the same problem after running perfect for almost a year, VERA 2 has stopped working with devices. The battery Icons have a “?” mark inside of them and have turned yellow?

Customer Service has not been able to help.

Installed a 2Gig ZStat C30 6 weeks ago and paired to Vera. It is hard wired to 24 volt wire to heat pump and installed new batteries. Everything has worked properly for 6 weeks. Yesterday I noticed from the MIOS Dash that battery Icon had a (?) inside and was now yellow. Tried to change the temp setting and nothing worked.

I ran the "heal"system command and now all battery icons look yellow with the “?” inside.
The Vera system dash will not show status of any device on my system.

I also rebooted my system from the advance tab with no luck of correcting anything.

Called tech support and they could not help. Can anyone point me in the right direction? :cry: