v1.90 beta (with UI6 support) posted in Testflight

I’ve posted a beta version of HomeWave to TestFlight; beta testers please have at it! If you have a device on UI6, please let me know your experiences (good & bad) below.

The other notable change is that the app’s settings have been moved from the (well hidden) Settings app, into HomeWave itself.

Added features:

  • Support for remote access to UI6 / 1.6.x. Configuring Veras on UI6 is the same as for UI5, but be sure to turn the “UI5” toggle off in settings.

  • App settings have been moved from the Settings app to an in-app screen, accessed by clicking the (i) button on the Home screen. You will find all app settings there, as well as all functions previously accessed from the Info screen.

  • Support for the Multiswitch plugin (can be added as a single control for all buttons, or use a standard on/off control linked to one of the buttons on the Multiswitch)

  • Improved connection time to Vera when re-opening the app while on LAN.

  • The list of Vera devices is sorted by room name, and room names have Vera’s name (if set) or ID added for easy identification.

  • Added option to clear the app configuration (“factory reset”)

  • Passwords are now stored in encrypted form on the iPhone

I really appreciate the continuous development effort you put into your fantastic App.
Testflight 1.79 working well with UI5 so far. I especially like the fast reconnect on LAN.
I don’t have UI6, so can’t test that aspect.

Same here UI5, LAN speed improvements are great. Thanks for all your work.

I would really like to test the new release on my UI6 Vera together with my IOS 7 iphones and ipads.
Any change you could send me an invite for test flight?

I installed last night on my iPhone 4s and am now able to gain access to both my UI6 and UI5 units remotely as I was before I upgraded. Seems like the login is a little longer to connect now, though this might not be anything, have not used it long enough to figure it out yet. But it is very cool to have access to Vera again when away from the house.

So, so far so good!

Logging in remotely does take a little longer sometimes when you are working remotely. The reason is that on remote connections, the app will now always issue a new discovery message first, in order to check if the phone is back on local WiFi. The older version sometimes had trouble switching back to local connections.

Google for iOS reachability demo. It’s a good way to determine programmatically if the device is on wifi or cellular. Even better is to perform 2 connections, one to the relay server and one to the local ip and use whatever connection connects first.

Sent from my iPhone using Tapatalk

First of all… I love this app!!
When using homewave you are almost only limited to your imagination.

V.179 feedback after a few days of testing:

  • remote connection does not always seem to work

    • When i grab my iphone whilst away from the home WIFI network, sometimes the remote connection does not connect or takes a really long time. Since i work for a Telco i had the opportunity to test this on GPRS/EDGE/3G and 4G. all behave similar.
      During these tests i also connected to the home webserver using the same iPhone which connects instantly. This gave me to think that the connection “issue” has to do something with the MCV relay servers.
  • Multiswitch support

    • I mis pincode support for the multiswitch. I would be great to have the app ask for a pincode whenever a button on the multiswitch is selected. Is use multiswitch to set my home security status…

    *I would prefer the multiswitch layout to be similar to “alarm sensor” or “scene” buttons. So round with configurable color of status en etc.

    • Have the option to remove empty/unused buttons from the multiswitch to save space on the screen.

    • It sometimes takes a long time for the multiswitch in homewave to reflect the status of multiswitch in Vera. If it happens at all. Even when connected to WIFI. Only way to update the switch status is to actually switch status 1 or 2 times.

    • Perhaps it would be possible to add a field somewhere that shows the timestamp of last successful communication between homewave and Vera?

Thats it for now… i will happily continue testing :slight_smile:



Multiswitch will support PIN. I’ll look into removing empty buttons, however the MultiState plugin doesn’t seem to report which buttons are unused. The option to display it as a round control will not be available; at the moment, the “rose” control type isn’t really suitable to be used for a MultiSwitch

I can’t reproduce the update issue of the MultiSwitch; HomeWave seems to follow along just fine. I found one bug causing a switch that was turned off to still show up as “on”.

There is an issue with the UI6 net code that sometimes prevents the app from connecting. Still looking into this.

I am seeing some longer than usual (a minute or more) access to my camera feeds with the new update (v1.79 #3).

I have 2 devices running the latest beta, and 2 devices running the production version. My 2 devices running the beta show long delays when viewing the camera feeds, but the 2 devices running v1.78 display the camera feeds as expected.

The camera settings in the app (Camera Refersh, etc) are identical on the 2 separate baselines.

I have tried removing and re-adding one of the cameras, but the delay persists.

My cameras are all Foscam, and are operating normally outside of the HomeWave app.

Any thoughts?

Not sure what’s up with that… The networking code has been changed a lot in the beta. Having a few camera feeds going at once can sometimes flood the network, and the current version recovers differently from that.

What are your settings at the moment?

  • Nr of cameras
  • Watching full screen feed and/or mini views
  • On LAN or Internet
  • Camera reload interval
  • Local reload interval
  • Local Timeout setting

In general, loading camera images through Vera has always been a bit iffy. Better would be to use the direct URL when on LAN.

Any chance I can test out the beta? I’m using ur app on one vera on UI5 but upgraded another and sadly it can’t use ur legacy app

Sent from my iPhone using Tapatalk

I am not sure what you did, but it is fixed in the build you released today (v1.79 #4). I confirmed by upgrading one to #4 and seeing no problems while leaving one device on #3 and still seeing the issue.

Both my devices are now on the #4 build and working.

Thank you for the quick turnaround.

Mine seems fine now as well. Are you using the cams remotely as well?
I made a small change to the network queue thingy, but I’m still not fully happy with it. Version after the next I will revisit the cam code and move them to a separate queue, and add local connectivity too.

Stolow, unfortunately I can’t add more beta testers, Apple only lets me add so many.

Yes I use the cams remotely (through Vera via HomeWave) and they are operating fine on 1.79 #4.

Overall the connection speed is much faster with the latest update. I noticed if the app is open in the background, it doesn’t seem to force a network connect when you open the app. That seems beneficial.

Any updates on releasing this from beta to production? Thanks.

This version was submitted to the App store today.

Woohoo! Great news!

Sent from my iPad using Tapatalk

Great, I look forward to trying the new version. Thank you