USB UIRT working not constantly


I have my USB UIRT connect to my Vera and it is working.

It works maybe for a day then after some scenes or command is not working anymore until I restart my Vera.

Do you have any idea how to solve this issue?

I use the USB UIRT to start my hifi every monring, but it works only the first day.

Thank you


Not a solution, but a workaround:

Use a scene with a timer to reboot your Vera. Add

os.execute( 'reboot' )

to the Luup tab.

Hi ap15e,

Thank you for the great tips, but there is a small problem.

The system restart with your command, but the usbirt is not working after.

It is working only if I click the refresh button in the ui4, top right.

There is a command to do this execution?

Thank you for the support

UPnP action Reload, service urn:micasaverde-com:HomeAutomationGateway1 might do the trick. Use luup.call_action to invoke the action.

Thank you!!

Sorry I’m still new with this code.

Should I write:

luup.call_action(service urn:micasaverde-com:HomeAutomationGateway1)



[tt]luup.call_action( “urn:micasaverde-com:serviceId:HomeAutomationGateway1”, “Reload”, {}, 0 )[/tt]

thanks it works great!!!


My USB UIRT worked fine for months, but now does not respond to SendProntoCode anymore.

The led flashes when It detects an IR command sent from another remote (so it’s alive), and I get a “Message sent Successful” when sending a comand via Test Luup Code (Lua), but nothing happpens (no led confirmation, no error message, no reaction from the controlled device).

USB Uirt shows correctly under Add Remove devices tab.

As my projector spent 3 weeks at the technical assistance, I’m not sure if this issue started when I upgraded Vera to 1.1.1338 (and the Z-Wave chip as well) or more recently.

Any clue ? How can I perform a clean remove of USB Uirt so I can try to re-install it ?



Sorry to insist, but could anyone out there pls help me to uninstall USB-UIRT ?

Thanks !

Hi Ap15e,

Should I just add the code "luup.call_action( “urn:micasaverde-com:serviceId:HomeAutomationGateway1”, “Reload”, {}, 0 ) " under the tab Luup of the scene? I tried it but the scene will only work one time after every reboot. TIA

According to the Wiki pages there are only six(!) devices whose compatibility with Vera is documented by MCV:

USB UIRT, three Insteon devices, one USB serial device, one sensor …

Please open an support ticket and refer to


Still with the original problem as you.

Atterra reboot it works once than no more in code.

Nobody can help us?

Thank you!!!

alexlui do you solve your problem?

by me always there, the USB dirt is just worked for few minutes and then stop working!!

[quote=“alexlui, post:10, topic:169204”]Hi Ap15e,

Should I just add the code "luup.call_action( “urn:micasaverde-com:serviceId:HomeAutomationGateway1”, “Reload”, {}, 0 ) " under the tab Luup of the scene? I tried it but the scene will only work one time after every reboot. TIA[/quote]

Hi Matteo,

I couldn’t find any support ticket from you. Did you submit any?

Hi mcvflorin,

I opened more then one also some weeks ago.

This is the last one 31667 of this week.

Can you help me?

Thank you