URGENT: VERA Cannot Access Internet?

Disclaimer: I’m new to VERA and so far have managed to configure about a dozen switches and controls on scheduled events that all work fine, until …

This morning for some reason my VeraLite has decided it can’t talk to the Internet.

As of about 6:30AM I received a PushOver notification that a scheduled event had occurred as expected. About 9:00 i tried logging in to Vera and received an error message from “Notification” saying it cannot connect to the Internet and I should manually configure my connection. I tried accessing my account and it was unable to log in there either.

I CAN talk to the VERA over my LAN, and I CAN access the Internet from other devices on the LAN so there is nothing wrong with the Internet access. However I am unable to do ANYTHING with VERA that requires external access.

I am able to PING the two MIOS servers “fwd1” and “fwd2” from the LAN and have perfect connectivity for everything EXCEPT VERA. I’ve restored from the last backup that was made yesterday to no avail.

I have my VERA configured for a static IP on my LAN and until about 9:00AM this morning everything was working fine. There have been NO changes since the last backup and 9:00AM today and as I said at 6:30 I received the PushOver notification as expected. I am unable to send a PushOver test message as of right now.

VERA appears to be working but any VERA function that involves an external connection fails. Any SCE?NE that involves a PushOver or SMS notification eventually executes but with significant delay while the notification module times out.

I’ve tried accessing from my Android phone and it works on the LAN but if I turn off WiFi and use the 4G network it is unable to connect.

Any ideas

I am suspecting that it is either a DNS issue or a problem with the MiOS server you are connected to.
Did you:

  1. Power Cycle the Vera.

  2. Run a network troubleshooting report. Setup → Network & Wi-fi → Troubleshoot Network.

Vera3 or VeraLite?

If you gave Vera a static ip, do you have any other device (router) giving out ip addresses that might have clobbered Vera’s ?

VERA Lite

The problem was not on my network, I had no trouble accessing the Internet. I suspect there is a logical bug in VERA. It needs to talk to a server somewhere and when it can’t it says there is an Internet access problem. I’ve done this kind of development before and were I designing the code I’d have it ping several other addresses such as known, fixed NTP servers or something to verify that it is not an actual access problem before reporting it the way it does. It sent me looking for a LAN/Router problem when it had nothing to do with access.

In this particular case VERA was trying to initialize the PushOver Plugin. Because it was having a problem accessing one of the MIOS.COM servers it talks to it assumed that it could not access the Internet rather than testing the access to the PushOver server which it already knows to verify that the network was indeed up or down

Anyway, after about two hours the problem cleared by itself but not before much gnashing of teeth fiddling on my part. Tech support subsequently accessed my VERA and confirmed that indeed there is nothing wrong with it.