URGENT HELP ! OH **** PLEG just died

I just want to thank every one that posted the possible temporary solutions and I will be working through those restores of the older versions now that I have read all of the comments.

And my most heartfelt thanks to Richard for his assistance and all respect for how wonderful PLEG has been for my Vera life. Stuff happens and I still love and admire Richard.

1 Like

Sorry, one more note. I will never forget back when Richard started a pay model and his comment was that ‘Hey, basically you are buying me a beer’. Richard, I wish I could buy you a beer right now. I may buy another license just so I can do that. Thank you for everything.

I agree @pentium The value Richard provides with PLEG is WAY more than the onetime $5.50 price. I’d be willing to pay $12/year for this program.

I see Vera is showing PLEG 9.5 available today. Yesterday it was showing 9.1. Is 9.5 the resolution to this issue?

1 Like

Presumably yes. I will update my test Vera Edge to 9.5 and let you know.

The 9.5 update only appears to be on the “Program Logic Event Generator (PLEG)” app.

The Core app “Program Logic Core” doesn’t show any update to 9.5 the latest for that is still showing as 9.1.

Anyway I updated them both with “Program Logic Event Generator (PLEG)” now being version 9.5 and “Program Logic Core” now being 9.1.

And…

I then reloaded the Luup Engine and the one PLEG device I have, I was able to open it and see my rules OK.

I didn’t get the “Error Reading Data” message.

I then rebooted the Vera Edge

And…

It still works OK so looks like Richard has fixed it.

I’d still like to see a change log if he keeps one?

@Sorin @melih

Whats going on with the Vera support desk these days?

I emailed in a support request ticket number (235391) on the 29th of October. Its now the 3rd of November and I never received any response.

Vera Control Ltd support was excellent I couldn’t fault it and they always fixed my serious issues that I was unable to fix myself.

The quality of the support given was one of the main reasons I kept on buying Vera controllers and stayed with Vera as long as I have.

Sadly since Ezlo took over my experience with the support desk has rapidly gone down hill and I am lucky to get any response at all.

They should know when I say its affecting everyone in the community or large numbers and that it needs escalating, I’d expect an even faster response and for it to be escalated.

The last time I contacted support, ticket number (230553) which was escalated, after a problematic Vera Edge firmware update and that issue was wide spread, I got a response 24hrs later. Can we see your SLA’s anywhere?

I personally was left with no devices and scenes all gone and I had to contact the support desk again and was told sorry he had a problem with his computer and was unable to restore a backup after he’d updated the OpenWRT version.

I wasn’t informed of this and wasn’t asked to enable again support access to the box. I was just left to see all my devices and scenes had vanished and me wondering why and I had to chase him up for a reason why.

Must do better.

Thanks

Hey there, I’m sorry.

Not sure why is it taking this long but I gave a heads-up to our CC team about this message.

Hello @cw-kid the ticket submitted has already been answered through our support platform.

Thank you for your patience.

Thanks Leonardo

I will do what you suggested next time I want to raise a support ticket for wide spread issues.

I realise in this instance that this was a 3rd party app issue, however as it was likely to affect a large number of users, I wanted to inform Vera support and make you aware and hopefully help expedite any publishing times for the plugin fixes the developer released.

However as I said generally speaking support response times appear to me to be taking much longer than what we have been use to in previous years.

Thanks.

@cw-kid did the PLEG upgrade fix the icons so they work now? Or are they still broken (not going to upgrade unless the fix has value :slight_smile:

I think that might be a yes. On the updated Pleg on the Vera Edge I see the PLEG icon on the device.

On my production Vera Plus running the 8.X version, I don’t see any icon for the Pleg devices.

Cool, I believe Richard mentioned that was what he was fixing with the update (just getting all the icon redirection in that broke with the latest Vera Firmware). If the bug he had was only in the Core component it would be pretty normal for him to only update the one package.

I’ve noticed on other forums similar “jumping up and down” demanding attention behaviour.

Guys, we are living in a strange new world at the moment. It isn’t ideal but that’s the way it is.

Many in product support are working remotely away from a team setting. Of course this will have an adverse effect on response times but instead of the offensive approach maybe users could adopt a little more passive approach and let those who are charged with this task to get on with it.

The infernal tagging of support staff and possibly other users is quite annoying for other users.

Just because other users are not “dancing up and down” doesn’t mean they are any more or less satisfied with support. It probably means they are just a little more patient and understanding of the current circumstances.

As promised Richard has provided a solution to the PLEG issue so maybe it’s time to top up his bar tab again :+1:

1 Like

I was referring to Vera support and not Richard in anyway shape of form.

And their support response times have been going down hill for a lot longer than COVID-19 has been about.

1 Like

I know who you were referring to and my comments still stand. We are all equal here as users. Nobody gets preference over anyone else.

Constant bombardment of support actually has the opposite effect and lends itself to rushed and possibly ineffective solutions.

I’ve watched the progress here since the acquisition of Vera and while progress has not always been a smooth path roadmaps will be made, reviewed and possibly rewritten but at the end of the day Ezlo know what’s needed to survive and thrive. They don’t need to be constantly reminded.

Likewise I doubt that Richard will be buying his next Ferrari on the proceeds of PLEG so users should bear this in mind too.

I wasn’t specifically referring to you in my post rather the general attitude of early posters who ploughed straight in demanding attention and any others who followed after.

I don’t expect priority support attention for my own personal support requests.

However when I contact support and report a wide spread issue that is affecting multiple users such as the last firmware update that didn’t go well for everyone due to issues with the OpenWRT version on the boxes, then I do expect to be given a priority response, so I can advise users asking those questions in the forum more quickly.

Sometimes my requests go straight to 2nd line support in those situations, sometimes they do not and I never hear anything back from them.

I rarely contact support for my own issues anyway as I can normally fix things myself or you other guys on the forum might have an answer.

3 Likes

That’s fine.

As far as I’m aware the community forum is a platform for users to exchange ideas and experiences and share their different application of the technology.

While some users are more proficient in the technology behind Vera and do come up with some eloquent solutions to automation needs it’s not incumbent upon any single user to represent the user base as a collective to the owners of Vera.

I’ve no doubt that a number of users appreciate your input here but I for one don’t appreciate anyone having a swipe at Ezlo on my behalf.

I’ve made my point at this stage so I’d rather see a more clam approach to any issues arising with the use of Vera products as I feel it’s a more productive approach and keeps everyone on a level playing field.

Without getting in this discussion specifically I’m generally frustrated with a seeming positioning of Vera as a low cost, very affordable, geek hobby platform which is not very stable, with hardware which is not state of the art, with relatively low serviceability. My system is rather complex with over 100 real devices and many apps and plug ins. My entire house is run by this “hobby level” equipment and sometimes my family is suffering from this instability and I have to explain how forward thinking and experimental this whole thing is. I’m using Vera since 2014 and had to replace many faulty Veras (2 Vera3, 2 VeraEdge, VeraPlus and now Vera Secure where it turned out today that the Zwave chip can not include devices as it has a hardware fail after about 25 months of operation). I personally would have been happier to pay a bit more (although Vera Secure is not so cheap) and even a monthly insurance to know this thing is running well and better supported. My impression following the acquisition of Vera is that they are looking for even less expensive hardware and I’m concerned about a possible interest not to continue developing stronger Veras but maybe to migrate the captive market to a different platform (Ezio?). I’m not happy with the current positioning which to me is not serious enough to run my place but I have to live with this after an extensive investment in tailoring it to my needs.

2 Likes

Well not sure if I should be posting in an old thread but this exact same thing just happened to me again, I believe some time yesterday. I had turned off auto update, so my PLEG is still on PLC8.23 and PLEG8.11 since I never got around to updating to the latest versions.

In the advanced page, the variables all seem present, but upon clicking the edit button I get the error reading data message. I had made some fresh backups last time this happened, so I tried restoring one to no avail. Once again, the data seems present on the variables tab but error reading data on the edit page.

I’ve done several Vera reboots, several LUUP reloads, and several CTL+F5 refreshes along the way as I checked settings and tried the restore. Not sure where to go from here to get my 3 PLEG devices back online…

Best Home Automation shopping experience. Shop at getvera!

© 2021 Ezlo Innovation, All Rights Reserved. Terms of Use | Privacy Policy | Forum Rules