Upgraded my UZB to 6.81.05/6.81.06. Testing on vera plus firmware

The ticket I opened with support was pushed up the line with the experts still out on why this has happened. So far there has been fiddling with the "sand pit vera’ and no acceptance of the fact that there is a primary bug with the FW which has carried over since the commencement of Vera.
I’m waiting with baited breath for the next chapter of the open ticket and will keep you updated…:slight_smile:

Just discovered a new page on the silabs website.

And 6.81.05 is no longer available for download… The SDK has reverted to 6.81.03 and 6.81.06 just got released a few days ago.

1 Like

Fascinating… I just decided to try an inclusion while my vera shows SUC/SIS: YES and PRI: NO
and it succeeded. So technically the dongle is still a primary. I looked it up on the silabs PC Controller and it is missing the RealPrimary flag but also does not have the Secondary flag. After attempting a controller shift, the secondary flag showed up. So the vera not showing PRI: YES, does not mean that it isn’t a primary…

I just got 6.81.06 on the vera and it seems a lot better than 6.81.05. Reading through the release notes, there was a change in the handling of bad frames. I will see how this goes.

Just loaded the FW on as well.
Vera hangs on Setting User Config (Red Flag).
Switches alright, wonder if it might be a Security thing as I noticed that when pairing there was no swapping of Security Keys?

Not sure what you did. I did not do any pairing. I just upgraded my dongle. Have not seen any problem so far.

This is a new device, won’t Include correctly.

I see, you mean you tried pairing it to your vera?

Yes, still have the same problem pairing new devices.

how big is your network? This might have nothing to do with the zwave firmware but rather security key exchanges related to large network?

This is not a production Vera, just a sandpit with only 1 device which doesn’t pair with the 6.06 Lib.
The device will pair in Homeseer or if I downgrade to 6.1

Are you sure it is repeatable?
To be clear, the device includes fine but configuration on the vera fails? Setting user config is a configuration step. Technically not part of the inclusion process. You can actually go back and hit configure now to restart that process. If the secure class key exchange failed then that could do it… So it is back to the same problem as above but in my case, I never saw this related to the dongle firmware.

In case of a secure class key exchange failure, you should see a message stating so.

When I go back to reconfigure, Vera loses the 2 child devices ( the test device is a double relay).

That’s unfortunately the normal process. When re-configuring, the vera removes all the child devices since it recreates them afterwards.

And there is the problem, it doesn’t recreate them.

Just tried mine and did not have any inclusion problem. I also did a configure of a secure class device and it exchanged secure key just fine…

It’s possible that it is the device, it’s one of the first GEN5 relays, I have a new shipment arriving Tuesday and will check it against newer device FW.

Just added a Hank outlet plug to that stick and it went easy and smooth. The PRI: NO indicates that the “trueprimary” flag is off and I haven’t figured out how to change it but it has not prevented the vera from including devices. The SUC flag should supersede the trueprimary flag in terms of capability. The ZWay controller I added to the network came up as true primary but not being the SUC, it has no ability to disable or assign SUC/SIS roles. It is strange that the silabs PC controller (newer version of the old zensys tool) has the ability to assign SIS role but not to disable it unlike Zway.

Just tinkering… I noticed that silabs provided the firmware 6.81.06 for the zm5304 which is the zwave chip on the vera so upgraded one of my test vera plus. It seems to work fine just like my usb dongle. Just had to pick the bridge controller version of the firmware.

Finding it interesting that my external UZB dongle SD3503 reports version 6.07 L:1 when the internal ZM5304 reports 6.7 L:7. And also that with the upgrade I lost the primary state of the controller.

Thanks for that, did you use the OTA FW Upgrade in the Z-wave PC Controller or somehow upgraded using the Programmer?