Upgrade to 7.47 broke my PLEGs

I’m on UI5 with a VeraLite. PLEG seems to insist on upgrading itself without me doing anything. I’m on the latest version and haven’t touched my Vera in a couple of months - last time I did everything was working just fine. Now I can’t view any of the parameters for any of my PLEG plugins (the UI just gets stuck on ‘Opening pleg_Inputs’ or whatever I’m trying to look at). The automation still seems to work, but I’d like to make some changes and can’t do so.

Any help please?

I should mention, I’ve hit the reload button, refreshed in the browser, and tried several different browsers (including on devices that have never connected to Vera before). I also unplugged the Vera and plugged it back in. No luck so far.

Version 7.47 was released on July 11 … I have not made any releases since then.

DO NOT DELETE the plugins … or you will have to re-create your PLEG devices after you re-install.

You have two options:

  1. Restore from a Vera Backup when things were working.
  2. Try to upgrade the Plugins manually. See:
    http://forum.micasaverde.com/index.php/topic,14446.0.html

No luck - Vera backups only go back a few weeks so I can’t restore to prior to July 11. I restored my August 15 backup but this exhibits the same problem.

Tried the manual upgrade and it’s still not working.

Any other suggestions?

Managed to get it to work by editing the Actions under the Advanced tab. I just wanted to change a temperature value so I found the appropriate action and adjusted the value manually in the text. After saving and reloading the Vera all the PLEGs were working correctly.

adding to this thread as noticed somethign weird, I was trying to downgrade from 7.11, no matter how many version went back, still did not get the format of pleg right, the (inputs, actions on top bar)

what I found was I had to go back to a backup from august as the current backup I had was not working, now here is weird part and I have repeated this multiple times, so repeatable

firmware UI7 7.0.5 ( 1.7.1018 ) VeraEdge

loaded backup (everything works)
PLEG CORE Current Version: 7.47 on backup
PLEG Current Version: 7.47 on backup

so at this point everything works,

then I update PLEG CORE, everything still works
then I update PLEG and it breaks (inputs, actions no longer on top bar)

but the weird part is

it updated to same versions (but was broke after update runs)
PLEG CORE Current Version: 7.47
PLEG Current Version: 7.47

how I upgraded below

PLEG CORE
http://192.168.1.151:3480/data_request?id=update_plugin&Plugin=3086

PLEG
http://192.168.1.151:3480/data_request?id=update_plugin&Plugin=3066

I am working fine as reloaded backup and disabled auto-updates for now, but think something might be wrong with the update process now or file maybe corrupt there… as it worked in past obviously as same version

anyway just posting this in case it helps someone

just to add to the above, I re-upgaded to 7.11 (1.7.1419) and got the same results after loading same backup, pleg works until upgrade of pleg

.

see on release thread Richard said a fix is coming out already, just needs to be approved by vera

You need:

PLEG CORE Current Version: 7.48

[quote=“RichardTSchaefer, post:9, topic:188614”]You need:

PLEG CORE Current Version: 7.48[/quote]

just tried that, got same results, even tried to uninstall core and pleg and and reinstall, still the (inputs, actions no longer on top bar) are not on the top bar anymore

reloading backup now to get back to norm

when I updated 7.47 core to 7.48 still worked, when updated 7.47 pleg to 7.47 it breaks again

I disabled auto-updates for now and will leave as is as it is working as long as do not try to do a update on pleg

the core fix did fix the undefined though… this seems to be a different issue

Did you follow the instructions ?

The order to restore ?
Wait for each to complete before starting the next ?

A Final Reload of Vera and REFRESH the browser ?

[quote=“RichardTSchaefer, post:11, topic:188614”]Did you follow the instructions ?

The order to restore ?
Wait for each to complete before starting the next ?

A Final Reload of Vera and REFRESH the browser ?[/quote]

doing it again, just noticed your notes say do core last

got same thing

did this

To Update Program Logic Event Generator
http://YourVeraIP:3480/data_request?id=update_plugin&Plugin=3066

To Update Program Logic Core
http://YourVeraIP:3480/data_request?id=update_plugin&Plugin=3086

f5

and no longer see inputs, ect… on top tab

if no one else is seeing this, can wait till the next release of pleg, see if have same issue there as works fine as long as do not update pleg

and what about the Vera Two strep on the end

  1. reload Vera
  2. refresh your browser (F5) ?

They are important !

[quote=“RichardTSchaefer, post:13, topic:188614”]and what about the Vera Two strep on the end

  1. reload Vera
  2. refresh your browser (F5) ?

They are important ![/quote]

[s]just re-updated both and then tried that too, no go

I can set up a admin userid and pm it to you if want to take a look while it has the issue[/s]

never-mind, it’s back, turned out to be a missing input on one of my plegs I think, trying again from scratch

I upgraded to nest and removed my ct100, I removed it before but forgot to remove it after the load of backup

.

yep, that was definitely it, reloaded vera backup, deleted that pleg with the old ct100 inputs, then ran update as per above and everything works

sorry to waste your time on this one, I should of caught that, hopefully this thread will help someone else catch the same issue if they have it I guess :slight_smile:

thanks again for the help…

John