UI7 ▾ Vera Software Update ▾ 7.0.30 - Nov 20, 2019

UI7 - Vera Software Update - VeraProtect - Version 7.0.30 (1.7.4832/1.7.4833/1.7.4834) - November 20th, 2019

VeraEdge - 1.7.4832
VeraPlus - 1.7.4833
VeraSecure - 1.7.4834

New Features:


  • Reactivation of the VeraProtect Professional Security monitoring service with subscription through the Stripe payment platform.


  • VeraProtect’s availability is limited to the United States, where the service is available in most of the states, with the exception of UT (Utah), TN (Tennessee), AL (Alabama), VA (Virginia), MD (Maryland), CA (California), TX (Texas), and FL (Florida).
  • All new customers will enjoy a free 30-day trial.
  • If you’re a customer already enrolled for the Annual VeraProtect, you will see the details of your active legacy plan in the MyAccount section. Your plan will be active until the expiration date, unless you should choose early termination of the plan. Automatic reactivation is not possible. To continue to enjoy the monitoring service, after the legacy plan is terminated you must reenroll for the VeraProtect service, according to the new subscription flow. Upon reenrollment, you will have the benefit of a free 30-day trial as well, just like new customers.
  • For the purposes of testing VeraProtect, your controller needs to be running the corresponding firmware, as specified below. Please note that these are intended for Beta testing only.


  • Implementation of Google Home Authentication


  • Addressed the firmware storage issues tied to the Firmware upgrade process for Vera Plus and Vera Secure by:
    • tweaking the space occupied by /overlay and the OpenWRT image size
    • reducing the number of symlinks from /www
    • having Bluetooth disabled from the operating system (OpenWRT) by default. Users can get Bluetooth working on their units by manually installing the appropriate packages.
    • discarding rdate(Time protocol)(The Time Protocol is generally considered obsolete and has been replaced by the Network Time Protocol (NTP))
    • Improving IO management related to UserData (improved the lifetime of the flash memory by reducing the amount of IO to ensure increased reliability of the data in the event of crashes)
    • adding kernel support for the NFS and CIFS network file systems.
  • Improved the communication with Z-Wave Gen3 devices (Switch/Dimmer).
  • Improved Z-Wave communication with RGBW devices.
  • Reduced the Luup Engine startup time.
  • Made some performance improvements in the context of setting up multiple pin code restrictions on a door lock.
  • Added support on Vera Plus and Vera Secure to automatically reconnect to a 5 GHz wireless access point in case of a change of channel (works only with standard 5GHz channel).
  • Added Nightly Heal Maintenance parameters (enabled, what time) to UserData and set the NightlyHealMaintenance alarm according to user defined parameters. wiki
  • Added variable in UserData to enable/disable CORS support. wiki
  • Added support for the short version name in the LuaInterface and in the Firmware Upgrade section. wiki
  • Added support for the model ID in the LuaInterface. wiki
  • Added a method of removing device messages. wiki
  • Added a method of saving the UserData to the flash memory manually. wiki
  • Added support to enable/disable at ARR/NNU commands at wakeup (default enabled).
  • Remotec ZRC-90 - added support for long-press capability.
  • Fixed binary lights issue involving the “Can’t detect device” message remaining on the Web UI even after the device reports back with a new status.
  • Fixed issue with the “Sorry Node Reports it’s Busy” message not being cleared unless the Luup Engine is reloaded.
  • Fixed issue relating to dimming light delays occurring when switching house modes.
  • Fixed issue with the Z-Wave version being displayed incorrectly in Z-Wave settings.
  • Fixed Aeotec NanoMote Quad issue, which failed to configure during the secure inclusion process.
  • Fixed issue related to the inability to uncheck “embedded” flag for a child device in the advanced settings tab.
  • Fixed dimmer-related issue involving the “LoadLevelStatus” variable being updated before the device has actually reported back. Said device would report intermediate states when going from ON to OFF or the other way around.
  • Fixed issue with “SetTarget” / “SetLoadLevelTarget” being sent when you edit a different house mode than the current one.
  • Fixed issues connected to window covering devices involving delays when setting the window covering module to OFF, when changing the house mode.
  • Fixed issue with the Centralite 3310 Humidity Sensor not reporting the humidity measurements.
  • Fixed issue with the 2GIG-TILT1-345 device being detected as a motion sensor instead of a door/window sensor.
  • Fixed issue with the ZTS100 thermostat when displaying the temperature measured in Celsius degrees.
  • Fixed issue with the CT101 thermostat not showing the humidity sensor value for the battery level.
  • Fixed thermostat issues where the Web UI wouldn’t update in line with mode and setpoint changes made.
  • Fixed the issue with the default name of the temperature sensor for Fibaro Flood Sensor.
  • Fixed issue involving the inability to add pin codes on Schlage gen5 door locks.
  • Fixed issue involving the inability to remove pin codes from Danalock V3 door locks.
  • Fixed issue involving the inability to fully configure new Yale locks (Yale YRD216 and Yale YRD226/246).
  • Fixed issues involving hidden pin code restrictions on Yale Door Locks not being set if the engine is reloaded before the start date of the restrictions.
  • Fixed issue with the wrong message being displayed when trying to set a restriction on a hidden pin code.
  • Fixed issue related to Yale YRD226/YRD246 door locks where the “lock button is pressed” notification was triggered by manually locking the door lock from the inside.
  • Fixed issue with Yale door locks involving PIN codes disappearing from the Web UI when multiple PINs were set at the same time.
  • Fixed scene-related issues involving the “A PIN code was removed from the lock” trigger being inoperative.
  • Fixed issues with incorrect alerts being triggered out when adding pin code restrictions on Yale door locks.
  • Fixed door lock-related issue where the PIN name wouldn’t show up in the details of the notification received upon the removal of a pin code.
  • Fixed door lock issue involving the “That PIN code cannot be used” message appearing multiple times on the device page when it should only appear once.
  • Fixed issue with the wrong message being displayed when trying to mix daily & weekly restrictions.
  • Fixed Kwikset door lock issue involving pin codes not working any more after the removal of a restriction.
  • Fixed issue involving the inability to configure the Aeotec Doorbell/Siren 6.
  • Fixed issue where the deletion of a PIN code from an offline door lock could be done but wouldn’t take effect after the said door lock was reconnected to power.
  • Now the user is informed that the door lock is offline. If the user attempts to remove a given pin code from a door lock that is offline from the Web UI, they will get a “Failed to be removed from the door lock” notification and the PIN code will not be removed.
  • Fixed issue related to the NodOn Wall switch CWS-3-1-00, where scenes wouldn’t be triggered when buttons were pressed.
  • Fixed Yale YRD226 issue where the Pin codes would be displayed as asterisks even though the “show PIN codes in clear” option appeared checked on the Web UI.
  • Fixed issue with Fibaro FGCD-001 CO sensor where a generic sensor that should be marked as ‘hidden’ was still showing up on the Web UI.
  • Fixed issue involving hidden PIN codes being made visible, i.e. ‘displayed in clear,’ when setting a restriction on them.
  • Fixed issue related to Nyce Motion Sensor child devices, where ‘Humidity’ and ‘Temperature’ would be included in the Lights category.
  • Fixed issue with the Ecolink DW sensor gen5, where the battery level wouldn’t be displayed upon inclusion.
  • Fixed issue involving the “Back” buttons in the “Extra Parameters” section having different designs.
  • Fixed issue with section name not being displayed correctly in the Web UI (the name of the device wouldn’t appear as the name of the section that the user was working in)
  • Fixed issue involving missing event type for the 3G up/down alerts.
  • Fixed issue involving a drop-down list being randomly displayed on the left side of the screen.
  • Fixed issue involving the green device status notification for the transmit command being a different color.
  • Fixed issue relating to Philio PAN15-1, where the “Off” button wouldn’t change color from white to green to indicate to the user the current state of the device.
  • Fixed issue involving the name label not being updated on the fly for the list tab.
  • Fixed issue with the report status button not working for unassigned controllers.
  • Fixed issue with the status not being updated to “On” in the “Control” tab for Philio Siren PSE02.
  • Updated the forum link with Customer Care Online Resource.

Newly Integrated devices:

  1. Aeotec Dual Nano Switch ZW132
  2. Aeotec Dual Nano Switch ZW140
  3. Aeotec LED Bulb 6 ZWA002
  4. Aeotec LED Strip ZW121
  5. Aeotec Nano Shutter ZW141
  6. Aeotec Nano Switch ZW139
  7. Aeotec NanoMote Quad ZWA003
  8. Aeotec TriSensor ZWA005
  9. Aeotec Water Sensor 6 ZW122
  10. Alfred Touchscreen Digital Deadbolt DB2
  11. August Smart Lock Pro ASL-O3
  12. Dome Door/Window Sensor DMWD1 (Added specific DPW)
  13. Eaton/Cooper Aspire RF Lamp Dimmer RFLDM
  14. Enbrighten Smart LED Bulb 39723
  15. Evolve Dimmer Module LDM-15
  16. Evolve Dual Outlet Receptacle LOM-15
  17. Evolve Relay Module LPM-15
  18. Fibaro Radiator Thermostat FGT-001
  19. Fibaro Single Switch 2 FGS-213
  20. Fibaro Wall Plug FGWPB-1x1
  21. GE Smart dimmer 1000 Watt ZW3006
  22. GE/Jasco Hinge Pin Door Sensor 32562/32563/ZW6301
  23. GE/Jasco In-Wall Fan Controller ZW4002
  24. GE/Jasco In-Wall Smart Dimmer ZW3004 (Added specific DPW)
  25. GE/Jasco In-Wall Smart Switch 12727/ZW4003 (Added specific DPW)
  26. GE/Jasco Plug-in Smart Dimmer ZW3104 (Added specific DPW)
  27. GE/Jasco Plug-in Smart Switch 14282/ZW4106
  28. GE/Jasco Plug-in Smart Switch ZW4103
  29. GE/Jasco Portable Smart Motion Sensor ZW6302
  30. GE/Jasco Smart Lighting & Appliance Control Outdoor Module ZW4201
  31. Gerber Prime Switch GPS-2000
  32. Heiman Z-Wave Carbon Monoxide Sensor HS1CA-Z GEN5
  33. Honeywell Outdoor Switch 39346/ZW4201
  34. Honeywell Plug-in Dimmer 39336/ZW3104
  35. Honeywell Plug-in Dimmer 39339/ZW3107
  36. Honeywell Plug-in Smart Switch 39337/ZW4103
  37. Honeywell Plug-in Smart Switch 39342/ZW4106
  38. Intermatic Motion Sensor CA9000
  39. Leviton Scene Capable In-Wall Receptacle VRR15
  40. MCO Home Electrical Heating Thermostat MH7
  41. NEO Coolcam Door/Window Sensor NAS-DS01Z
  42. NEO Coolcam Motion Sensor NAS-PD01Z
  43. NEO Coolcam On/Off Plug NAS-WR01Z (Added specific DPW)
  44. NEO Coolcam Water Sensor NAS-WS01Z/WS02ZU (Added specific DPW)
  45. NodOn Soft Remote CRC-3-6-0X (Added specific DPW)
  46. SWF Basic Remote Control BRZ1
  47. SWF Cellular Shade Radio Z-Wave CSZ1
  48. SWF Multi-Channel Remote Control MCZ1
  49. SWF Remote Controller VCZ1
  50. SWF Roller Shade Radio Z-Wave RSZ1
  51. Sensative Strips Door/Window Sensor MaZw
  52. Somfy Z-Wave to Digital Motor Interface (1870171)
  53. Zipato RGBW Bulb 2
  54. ZooZ Motion Sensor ZSE18
  55. Centralite 3-Series Micro Motion Sensor 3328-G (Zigbee)
  56. Centralite 3-Series Night Light Repeater 3420 (Zigbee)
  57. Centralite 3-Series Smart Outlet (Type F) 3200-Gde (Zigbee)
  58. Centralite 3-Series Smart Outlet 3200-Ggb/3200-gb (Zigbee)
  59. Centralite 3-Series Temp/Humidity 3310-G (Zigbee)
  60. Centralite 3-Series Temp/Humidity 3310-Geu (Zigbee)
  61. Centralite 3-Series Water Sensor 3315-G (Zigbee)
  62. Centralite 3-Series Water Sensor 3315-Geu (Zigbee)
  63. Centralite 4-Series Smart Outlet 4200-C (Zigbee)
  64. Centralite CentraLite Smart Outlet (Type E) 3200-Gfr (Zigbee) (Added specific DPW)
  65. Centralite CentraLite Smart Outlet (Type G) 3200-Sgb (Zigbee) (Added specific DPW)
  66. 2GIG Flood and Temperature Sensor FT6-345
  67. Hikvision DS-2CD1023G0-I camera (Added specific DPW)
  68. Hikvision DS-2CD2121 (Added specific DPW)

Is the bug with wintop RFID keypay fixed, as reported in the beta tread ?

Please remove and fix Vera Plus update. It’s making units unable to boot properly.

1 Like

Trying to upgrade one of my units, a Plus. When I log in it tells me I can upgrade
|Running Version|1.7.4783|
|Latest Version|1.7.4833|

But when I click the upgrade button, the next screen it shows says
“ERROR: Server not allowed” in red
and then below it
“Click [here ] and try again”

When I try again I just end up with the same error :frowning:

I also tried pasting the URL, but same problem. Is this an issue with this release?


For everyone attempting the upgrade read this first.

Im having the same troubles with my VP. Installed and let it be for 4 hours… wont boot. Get the 403 forbidden error. Power and blinking internet only. If you didnt install yet… dont. I have never had an issue with any updates in the last 5+ years with my vera units. Im disappointed to say the least.

Edit: Had to do a reset to get it to boot. Was then able to restore from a backup and I am back up and running. In hindsight, i should have waited a month to install this update like i usually do… but it could have been much worse. I’d still say hold off if you havent updated yet.

Agreed this update should be pulled until it’s been more thoroughly tested.

I would not recommend this update be installed by anyone who regularly experiences issues with their Internet access. I reported to engineering two weeks ago that 7.30 will completely disable itself if Internet access is lost for more than an hour. Very repeatable. Apparent changes in the Network Monitor for this release take drastic recovery actions around the one hour mark, and if Internet access continues to be unavailable through that process, the box leaves itself down with the Internet and Service lights blinking, no automations/Luup, and worse, no SSH. Only power cycling seems to recover it at this point. While I am not home to test this final build, I see no evidence in the release notes and have no other communications to indicate that this issue was addressed prior to this release. This is particularly disastrous for users with distant remote units, of course. I would hold off until it’s either confirmed that this was really addressed, or a respin with a fix is released.


Unbelievable - do the update and now the device is bricked. All I have is the power light now showing. Any ideas?

Contact Support. I “quasi-bricked” my Vera Plus with the last beta and called Support. Within 20 minutes Support called me back and with a short screen sharing session where Support reinstalled OpenWRT, I was back up and running with the latest firmware. Bottom-line, my unit was quasi-bricked for less than an hour. Kudos to Vera Support for the prompt response and remedy.

1 Like

I am extremely disapointed with this update.

Tried contacting customer support told to leave a voicemail and they will get back to me. I understand their trying to improve the product but this a failure of QA, customer service and its unacceptable.

Another Vera Plus dead from this update here. My friend did the update on a Vera Plus and it’s dead too.
I can SSH to it and browsing to it shows: 403 - Forbidden.
Any tips to come back from this? Reset procedure on a Vera Plus?


I am beyond words at this point. I don’t understand why Ezlo/mios would release a firmware without fixing the enormous critical problem found during the beta which we kindly called the “Christmas light” mode problem @rigpapa is describing and is due to the network monitor. If a firmware could have been released, it would have been the alpha we tested on the old kernel. While we could have waited for the kernel to be fully tested before release. I am really sorry for all of you who are dealing with the bricking issue. At this point try to avoid upgrading. I am even tempted to write a script to only do an upgrade on the image and not upgrade the kernel and the network monitor to help the community. It repeats the cycle I have seen in the past of beta firmware being more stable than the official release because mios makes a bunch of untested changes from the beta and ignores the beta feedbacks. I really had hoped that the Ezlo management changed this but sadly it hasn’t.


Updated an VeraEdge without problems, update took about 7 min.

Also tried to update a VeraPlus (remotely) from version 1.7.4800 to the now officially released 1.7.4833 but it has not com back online after 30min.
I will have to see what is going on when I get home in about 8h.

Vera Secure, “Xmas light” after several hours. Looks like a network monitor problem.

Amazed by the radio silence from @melih @sorin and other Vera / Ezlo members?



“Told you so”? :roll_eyes::grimacing:

This FW is total garbage!!!

I had to power cycle my VP twice to get it back and then when it did come up it’s been factory reset!

Im just doing a manual factory reset and trying again as restoring my backup after the upgrade left me with no rooms! :frowning:

This upgrade is not fully reversible so to all people… DO NOT UPGRADE at this point. Not only it will get you to a frequent Xmas lighting mode about 80% of the time after a reboot, it will also prevent extroot and will not allow you to revert the broken changes when you downgrade.

1 Like

I accepted this update last night just before going to bed when I woke this morning at 5 I still have no update and the Vera appears to be bricked. I have unplugged and replugged twice. I have not tried reset procedures. Pull this update immediately. This may cause a lot of people to rethink Vera as I will all day long while I’m at work.

I do have ssh access but I’ll have to research the password as I haven’t ssh’d into the unit in a long time.