UI5 and UPnP

Will they fix UPnP in UI5?
Seems like this was a selling point of the Vera that still does not function as advertised.

@Quixote

You mean bugs #1473 and #1487? Not until we have a stable UI5 firmware.

Mcvflorin,
I was referring to one of those bugs indirectly, but what I am really confused about is that the Vera does not show it’s devices as UPnP devices on the network. I was under the impression that it was supposed to do this with every device added to the system. I cannot see any devices with any UPnP software that I have used so far.
Am I way off here, or is there a problem there?
Thanks for your reply.

I am really confused about is that the Vera does not show it's devices as UPnP devices on the network

A well known and very old problem (search for ‘UPnP’ on the forum …). MCV doesn’t seem to care about it. IIRC, MCV blames the UPnP sniffers …

Im still wondering how this was supposed to work, if it was working. Should I be able to add my PC and e.g turn it from a Vera scene at night? Control my amplifier or have the amplifier send triggers via Vera to my lights?

I have been interested this as well. Everyone seems to be really upset this issue has not been resolved, though I only know UPnP as a way to stream media back and forth on my network.

How it is supposed to work:
Add your UPnP/DLNA compliant devices to your Vera (Add/Remove devices -> Add control over another UPnP device -> Add), setup scenes (Advanced -> Pick your device and an select an action), run the scene. That’s all - but it doesn’t work due to the aforementioned bugs. You would have to resort to some heavy stuff like UPnP via SOAP over HTTP from scratch (http://forum.micasaverde.com/index.php?topic=7707.0).

In short terms:
Vera would be an universal programmable UPnP Control Point.

One this works it seems like it would be a pretty powerful feature.

I’ve been messing around with what used to be intel’s UPnP tools (now open sources) and quite a few things on my home network are controllable from UPnP:

http://opentools.homeip.net/dev-tools-for-upnp

I was aware that you could add UPnP devices and control them with the Vera using scenes, but I was also under the impression that every device that the Vera can control could be controlled using UPnP.
Does anyone know if I’m mistaken that devices like lights should be controllable using the Vera just as we can control lights with other control points?

A long time ago I was able to control Vera’s devices via Intel’s DeviceSpy.

Have you tried with a recent firmware? I can’t see my Vera in DeviceSpy.

I think the problem might be something fairly simple. The UPnP xml file at http:///upnp/vera.xml is broken. I tried modifying it but of course I think it is on a squashfs filesystem which is read only.

I would hope it would be a simple fix once MiCasaVerde gets around to it.

Doesn’t work with recent firmwares.

I’m not going to speculate whether it is easy to fix or broken on purpose (UPnP security by obscurity) …

UPnP Inspector ([tt]http://coherence.beebits.net/wiki/UPnP-Inspector[/tt]) lists some services from my Vera V2, but doesn’t see my Vera V1. Both Veras are at the same firmware level (1.1.1338).

UPnP Inspector gets some data for my other UPnP devices wrong, so use it with caution.