u14 bricked my vera2

i just regrettably updated to u14 through the URL and instructions provided on the other forum-

it looks like i was too soon, or the upgrade process just sucks- which considering my experience with micasaverde, wouldn’t surprise me.

it appears that the firmware update was successful. i had the option to save a backup, unit came back online with normal status lights. i upgraded from U13, which was working OK.

following the new u14 instructions and using mios.com, i’m not able to add my unit to my account, it sees the unit’s serial number, and apparently an IP address of .29, but it’s not able to connect to the unit and add it to my account.

i’m also not able to hit the unit itself via the IP…

so i’m stuck with the following, along with a non-functional home-

[size=9pt]I am trying to connect to your unit using local network connection.
One moment while I try contact it on your local home network.
If you still see this message after 15 seconds, please reset your unit, wait one minute then click here

i’m extremely bummed out that i jumped the gun, and also kind of pissed that someone from Vera hasn’t posted anything about U14 advising people to upgrade or just wait for now. the posts i read in the other forum made it seem like U14 was out and that people had successfully upgraded- apparently this is not the case- and so i wish Vera would warn people not to make the same mistake i did. obviously my fault, but i would have hoped that a firmware upgrade wouldn’t brick my unit.

it’s killing me that i can’t get to the unit via it’s IP and at least set it up manually.

can anyone from Vera chime in here with some help or advice? or maybe any forum vet’s who have set up U14 or run the beta’s?

can anyone refresh my memory on how to accomplish a hard reset to factory just using the buttons on the back of a newer unit? of course the now very scant documentation that’s now wrongly published doesn’t mention this.

any help appreciated…

well, here’s more happy news- it appears the unit is completely dead right now after attempting to do a factory reset, with paperclip and two quick button pushes- now all i have is a power light, and the unit seems to not be grabbing an IP- so it appears to be truly bricked.

could someone from vera please respond? i know this is pretty hopeless, as i’ve seen issues go unanswered for weeks here-

this thing just isn’t ready for primetime if a firmware update kills it and the standard factory reset fails. i was prepared to go through some pain and set everything up again, but not have the thing go dead.

my fair and balanced review on amazon will definitely be amended to note this.

  1. It’s UI4 which means User Interface version 4, not u14
  2. The firmware is available for testing only to beta testers, it was a mistake that it was posted on the discussion forum, other tested and ready to go firmwares are posted ONLY on the “Official Announcement” thread, if you choose to upgrade the firmware to a version taken from other users on the forum or from other threads that aren’t in the official announcements you’re doing it on your own risk.
  3. Most probably help request stay unsolved for days because users don’t provide any information that we could use to debug their issue like:
  • what is your vera serial number
  • what Vera model do you have Vera 1 (it has 5 ethernet ports) or Vera 2 (it has 2 ethernet ports)
  • from what UI3 version have you upgraded
  • how did you’ve upgraded: by going to the vera2 page or by pasting and firmware url into the Advanced box
  • after you’ve “reset the unit to factory defaults” did you’ve tried to power cycle it, try again to reset it by double pressing the reset button, wait 30 seconds then power cycle it
  • if it’s Vera 1, how it’s flashing the power led, if it’s Vera 2 how it’s flashing the eth1 led?
  • how do you connect your Vera to the internet? How do you connect your PC to the internet? (ie: through another router or vera is your main router?)
  • if you connect your PC directly to your Vera unit LAN/Eth2 port, do you get an IP address? If yes, try to open a browser and access directly your gateway (by default should be, it is working?

If you’ve searched the forum for ui4 opinions, did you’ve tried searching for how to troubleshoot an unsuccessful upgrade/ unable to connect to vera or for anything that will help you troubleshooting the process that you’ve followed to upgrade your unit to an alfa firmware?
Unfortunately we don’t have enough time to help every user that tries to experiment with his Vera unit.

Right now the whole Vera experience is an experiment in itself. That users are desperately trying to get a decent device/interface should come with no surprise. I’m sorry CJ, but your tone in answering this customer is totally inappropriate.

Added to this, the post with the UI4 firmware came with no clear warning (“alpha firmware” is a technical term, and is not a warning). I find it strange that you only took time to remove the link today by editing the post, if as you say, the firmware was “only meant to beta testers” since the beginning.

I am among many customers that are hopping much from the updates and are totally understanding and patient. In the meantime, get your facts straights: your product does not deliver.
When Vera will be satisfying, and customers won’t have to go to the forums to dig in, then you can afford being stricter with actual geeky users that mess up their devices. I am sure you are on the right path, but you still have tough times ahead.

Yeah, CJ, a little harsh & snippy. I normally resist chiming in on threads like this, but I couldn’t this time.

I’m a “junior geek” when it comes to Vera, but I watch this forum very carefully, and because of that, I’m conservatively still running UI2 on Vera 1, firmware .994, because I know it works [almost perfectly, but not quite], even though I can probably dig myself out of technical messes slightly better than the average consumer. Don’t get me wrong - I know what I got myself into and I’m OK with it. But I think there’s an opportunity to be a bit more “embracing” of your early adopter community than your response below would otherwise imply.

You guys have a fantastic marketing department, and Vera is being sold as a “ready for prime time” home automation appliance, but you’ve clearly got some catching up to do. I think there’s great potential, but at the same time, I really think MCV needs to take more proactive steps to protect the average consumer or even a junior geek like myself, from getting themselves into trouble. A simple warning when you attempt to upgrade, for example, when not using a generally released production version, would probably save a lot of headaches, like that being experieced by theevaluator now.

Finally, IMHO, all of MCV’s customers are experimenting with their Veras. It’s what is providing MCV with [usually] useful input to make the product better, but until there’s a version that’s rock-solid, the whole Vera experience continues to be an experiment, so let’s not alienate the experimenters.

watch out or you too may be censored…

I doubt anyone will be censored here.
please everyone keep their posts civil and constructive.
Hopefully UI-4 will be officially released soon! and well be past all this.

Thanks Z
I’m not an employee just a moderator.

I’m a bit torn in both directions on this one. theevaluator stated he kind of knew what he was getting into by saying he jumped the gun. On the other end why isn’t there something to un-brick a V2 like there is for a V1? On that note why isn’t there a program to un-brick a V1 that can run on something other than XP. Better yet a program that un-bricks both with all formats of windows (32 and 64bit). I think that’s about as important as getting a new UI out there. Firmware upgrades are never 100% successful in my practices with routers so it seems like a necessity. Or is there one out already I’m unaware of?

If this will exist sure we’ll post it, but unfortunately only for V1 is one usable by the end user and for V2 is one but very difficult to use.
This utilities are made by the manufacturer and there is no source code or specs to do another utility.

I was very upset about this thread because the fault is of the user and instead of asking for help and be willing to learn how to fix things that he doesn’t understand/know he says that it will post bad comments, why?
Also the users that mess up with their units are more, and they came on support telling us that they didn’t do anything and from sudden Vera stopped working or doesn’t work properly etc, and then you loose a lot of hours debugging nonexistent scenarios and thinking what it could be wrong in your code, when there is no problem and helping/fixing the user issue it could take only 5 minutes if he offers from start all the required information and admit everything that he did.

The title of this thread reminds me for some reason of the famous incident in the UK that the Sun newspaper printed.

Freddie Starr ate my hamster! :slight_smile:

So, getting back to the topic at hand…

Does anyone have any Tools, Techniques, or Pointers to assist @theevaluator in getting their Vera 2 back to a workable state?

Given some of the other Network devices I’ve worked with, sometimes you have to try the “pin-techniques” a few times to get them working correctly. Unfortunately Sercomm doesn’t seem to be forthcoming with any form of tool on their site for this device either.

We’ve all been there, so let’s see if we can keep this thread, and all public threads, civil

I don’t think I ever remember seeing a post from someone with a Vera2 ever detailing a method! One thing is for sure and its times like this I’m glad I have a Vera1 and can recover it with the Asus tool (in Win7 I’ll add for the naysayers). I’d almost become a pro at it too, and really haven’t had it brick during a firmware upgrade for months. UI4 upgrade process on a Vera1 seems rock solid now. But anyway, I digress…

I think without getting network connectivity to it then I think the OP is going to be hard pushed to recover if the factory recovery doesn’t work.


Are you using the WAN or LAN port? Sorry if you already tried swapping ports but its worth a try if you didn’t. I think first if everyone has a brief understanding of how you have your PC, modem, router and Vera (unless you were using vera as your router?) etc all connecting, along with extra details like static or dynamic addressing, then we may be able to help.


If you could offer the forum more information and what trouble shooting procedures you tried we could help you further.

With little info I guess we start from the obvious…
Is your PC a Mac or Windows based?
Is your PC setup with a static IP or using DHCP? Was Vera the DHCP service or another router?
What is your IP address 192.168.81.?? If not in this range then Vera’s DHCP is not working.
Can you ping
Remove all other network devices from Vera except your PC connected to port 1. Set your PC to a static IP of Ping, is that successful?
If you can ping can you telnet into it?

Tha language you just gave can be very confusing to some.

We tech savv people know what that means. You and I know how to place a static Ip in the PC. But do others that may try Vera.
I am sure that D-link , Linksys, Netgear. release firmware updates availabel for the general public to try that may cause such problems. I have bricked Vera 1 about a dozen or so times during an update. I know how to recover it. Vera 2 I bricked and it took several hours for it to come back so I could connect via static IP.

However Vera is sold to the none tech savy. This is the main issue.

I agree it is technical to some but we have no idea what the ability of theevaluator is. If this is over his head he needs to let us know and we can break each step down into layman’s terms. Need more input…

I know, I telnetted into my ping statically and the LED just beeped at me…no luck.

Kidding, of course.

Do you think it would help if the OP tried to flash the firmware from the Vera2 web-based firmware upgrade page (for the life of me I can’t find it now, but it has popped up before) that CJ speaks of?

I can understand CJ’s frustration and OP’s mistake, but only waiting 2 hours before threatening bad reviews seems premature. Hell, I’ve threatened bad reviews of Hotels on Trip Advisor during my stay there, but they’d really have to have wronged me…I’m fairly easy going otherwise. From a customer service standpoint, I have to swallow so much frustration each day before I speak to customers and try to just deal with one customer at a time, one problem at a time. I’ll spend hours with a customer if I can make them happy, fix their problem, and most importantly teach them to fish so maybe they won’t call me again. MCV has done some of that in the past, especially when the community was much smaller. Things are getting more complicated with the new users, multiple platforms, etc. They could be a bit more transparent with fixes they’ve made and help us by teaching us to be experts. Building a strong network of experts early on is invaluable and will lessen the load on support, while empowering people to sell/buy and maintain more Veras themselves. Remoting into my box to blindly fix things, doesn’t keep me from coming back next time.

I think MCV is justified to be a bit frustrated, that if they could just finish up UI4 and get it out then it would be back to putting out small, reasonable fires. Yet, this is the bed they have made, the forum is a bit of a dangerous place for the average user. The only place there should be firmware version links is on the main MCV website, on a dedicated and ORGANIZED, easy-to-read, chronologically ordered, web page with a .txt file for each detailing the problems they either solve or resurrect, again. That still wouldn’t keep people from posting those links in the forum, but it would give us a central place like every other hardware company on the internet has. Even though MCV doesn’t make the hardware, they do sell it. This does expose a problem that probably should be remedied ASAP, a firmware restore tool or procedure for Vera2. Yes, more details are needed from the OP, but it seems the Find Vera servers should have last known info stored from our boxes.

Unfortunately, with UI2/UI3, while doing an upgrade, Vera is very vulnerable and any hiccup or power loss will leave it bricked.

The good news is that with UI4 we changed the way upgrade works to make it impossible to brick on upgrade anymore (we no longer re-write the boot and base o/s on upgrade). So once you’re on UI4, upgrading won’t brick again.

If you have a bricked unit, contact anne [at] micasaverde[dot]com. We’ll ship you a new Vera 2, and you can simply restore the last backup and it will be a clone. Sorry for the inconvenience.

Well done…thanks for the info…looking forward to UI4.

MCV admin → thanks for the information; it is great to see that MCV is (apparently) standing behind their hardware by offering to exchange any bricked VERA that was a result of upgrading to UI4 …

If MCV would also take the same position when it comes to firmware releases, we will have a fantastic product to work with, so let us try this and see the replies from MCV.

Any new updates on when UI4 will be finally released as a stable version?

Been a Vera user for a while now. I am able to adjust my thermostat remotely and my outside lights go on and off. Haven’t had a lot of play time recently so I am unable to change my Vera configuration or do much more with it. I’ve bricked my Vera before. Most upgrades have taken a significant time investment.

If you really don’t know the terms ping and telnet Vera might not be for you.

That being said the box offers value for those with some tech knowledge and a desire to play with z wave. I am looking forward to a stable UI4. IMHO