Total noop question, but I cant get it to work

Hi.
I have a total noop problem. I cant get Sonos to say anything. I had it working earlier today but for some reason it stopped working. It says the command finished with success, the only problem is that Sonos keeps quiet.

Please help, what am I doing wrong?

Step 1: Trigger: Manual
Step 2: No device selected
Step 3: Also, execute the following Luup code:
luup.call_action(“urn:micasaverde-com:serviceId:Sonos1”, “Say”,
{Text=“The sun shines outside”, Language=“en”},
19)
Then save the scene.

When going into my sonos device I can see the following
Params: Id 19

Is your TTS service setup correctly. In your Sonos device, go to TTS and in the top part enter text, set the correct TTS service and see if you get speech. If not, there’s mots likely an issue with your TTS service setup.

@jensk, slow question are you able to get the SONO’s device TTS tab to say anything? if not then there’s something wrong with either your plugin and/or credentials. What service are you currently using? Mike

Hi.
I haven’t changed anything in there as far as I know. It worked a couple of days ago with the simple say that I wrote here. Later it didn’t. I haven’t changed anything in the TTS tab. But it dosn’t work in there as well. The only App change I can come up with is that I installed PLEG. But I dont think that it has anything to do with that.
I am using all standard values. Meaning Google.

I have reinstalled the UPnP Event Proxy and the Sonos app and changed the id for the sonos as well.

As far as I can see in the threads is that the Microsoft TTS will stop working shortly so I dont want to use much time on that, if that is correct?

Do you want to post some values from my system?

Thanks for your help

Best regards,
Jens

If you are using the Google TTS, then I’m not surprised you are having these issues. It’s been unreliable like that for the better part of a year. With the Microsoft TTS on the way out your currently have 3 + 1 options.

Option 1: Use ResponsiveVoice.org. There is an updated plugin file that implements support for that. Just install it and pick Responsive Voice from the options menu and you should be good to go. The updated plugin is in teh MS TTS thread I believe.
Option 2: Install the free MaryTTS locally on a Windows or Unix machine, even on a Rasperry Pi. The drawback si that computer has to be on 24/7 but on the plus side, it will work even if the internet is down.
Option 3: if you have an Apple Mac, computer, use it’s internal TTS option. The plugin has support for that. Same is with option 2, that computer has to be on 24/7

Option 4: It’s currently being beta testing, but MrSlother has created an app that uses MS Windows TTS framework. It requires IIS and .Net framework to be installed on a Windows machine. Same as options 2 and 3, that machine needs to be on 24/7.

Since the Microsoft TTS is still working I’m still using that but I can switch to either option 1, 3 or 4 with the click of a mouse. Option 4 is running on my test Vera and is working well. As I have a WHS2011 box already on 24/7 for BlueIris and Serviio (as well as MaryTTS) it was relaltively painless to install MrSlothers solution as well.

Thanks BOFH.

I think its must be Option 1 then.
I have searched the forum and found this file Sonos_v1.4_ResponsiveVoice_TTS_Files.zip, here http://forum.micasaverde.com/index.php/topic,33223.msg312329.html#msg312329 is this the one?

Can you please guide me through this, if it is not too much trouble.

Thanks a lot for your trouble, its quite confusing to figure out as a new user.
I am actually starting a Danish blog about my journey with VeraPlus and IOT so other people can have a danish explanation on how to start using it and what is working and more important, what is not.

Best regards,
Jens

That is the one.

On your Vera dashboard, on the left menu, go to APPS -> develop apps
Then click the LUUP files link and use the UPLOAD button. Make sure you downloaded that .lua file in the post to your computer first.

Now follow the instructions in that post to complete the installation.

Thanks a lot.

I will try that when I get home from the job

Best regards,
Jens

Hi BOFH.

Just want to let you know that it worked.

Thanks a lot

Best regards,
Jens